clean up some noise in the diff file
authorBdale Garbee <bdale@gag.com>
Sat, 28 Mar 2009 13:02:51 +0000 (07:02 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 28 Mar 2009 13:02:51 +0000 (07:02 -0600)
config.sub
configure
debian/rules

index 6759825a5b7fcf64476b4398dc0e30b3090b925c..922d3b5d0bfd77e5b7bb71d6641f1013f9fb0465 100755 (executable)
@@ -148,7 +148,7 @@ case $os in
        -convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
        -c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
        -harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
-       -apple | -axis | -knuth | -cray)
+       -apple | -axis | -knuth | -cray | -sr2201*)
                os=
                basic_machine=$1
                ;;
@@ -583,6 +583,10 @@ case $basic_machine in
                basic_machine=h8500-hitachi
                os=-hms
                ;;
+       sr2201*)
+               basic_machine=harp1e-hitachi
+               os=-hiuxmpp
+               ;;
        harris)
                basic_machine=m88k-harris
                os=-sysv3
index 8188da6dcf885991b27e3856e1d6f94d33d72076..0bf4e23cf85afae991b60ba2825d13955efdb1ca 100755 (executable)
--- a/configure
+++ b/configure
@@ -1451,7 +1451,7 @@ Fine tuning of the installation directories:
   --bindir=DIR           user executables [EPREFIX/bin]
   --sbindir=DIR          system admin executables [EPREFIX/sbin]
   --libexecdir=DIR       program executables [EPREFIX/libexec]
-  --sysconfdir=DIR       read-only single-machine data [PREFIX/etc]
+  --sysconfdir=DIR       read-only single-machine data [etc]
   --sharedstatedir=DIR   modifiable architecture-independent data [PREFIX/com]
   --localstatedir=DIR    modifiable single-machine data [PREFIX/var]
   --libdir=DIR           object code libraries [EPREFIX/lib]
index 3cc6e6862a3067a62cfa744dcef9419a0ed26bd8..575bb10fac5890b79a4dba9318a1f033188bd259 100755 (executable)
@@ -8,9 +8,11 @@ CFLAGS += -g
 endif
 export CFLAGS
 
-config: config-stamp
-config-stamp:
+configure: configure-stamp
+configure-stamp:
        dh_testdir
+       cp -f /usr/share/misc/config.sub config.sub
+       cp -f /usr/share/misc/config.guess config.guess
 
        # simple version
        mkdir -p build-simple
@@ -46,9 +48,12 @@ config-stamp:
        touch config-stamp
 
 build: build-stamp
-build-stamp: config-stamp
+build-stamp: configure-stamp
        dh_testdir
 
+       # ensure our pod changes get picked up
+       $(MAKE) -C build-simple sudoers.man.in sudo.man.in visudo.man.in
+
        $(MAKE) -C build-simple
        $(MAKE) -C build-ldap
 
@@ -60,12 +65,6 @@ clean:
        rm -f config-stamp build-stamp
        rm -rf build-simple build-ldap
        rm -f config.cache
-
-       -test -r /usr/share/misc/config.sub && \
-               cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && \
-               cp -f /usr/share/misc/config.guess config.guess
-
        dh_clean
 
 install: build-stamp
@@ -115,4 +114,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+.PHONY: configure build clean binary-indep binary-arch binary install