Partial fix for ticket:81
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 4 Oct 2006 19:08:50 +0000 (19:08 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 4 Oct 2006 19:08:50 +0000 (19:08 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3709 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_gnuradio_examples.m4
gnuradio-core/src/python/gnuradio/gr/Makefile.am
gnuradio-examples/ChangeLog
gnuradio-examples/python/Makefile.am
gnuradio-examples/python/apps/Makefile.am [new file with mode: 0644]
gnuradio-examples/python/apps/hf_explorer/Makefile.am [new file with mode: 0644]
gnuradio-examples/python/apps/hf_radio/Makefile.am [new file with mode: 0644]
gnuradio-examples/python/audio/Makefile.am
gnuradio-examples/python/multi-antenna/Makefile.am [new file with mode: 0644]
gnuradio-examples/python/networking/Makefile.am [new file with mode: 0644]
usrp/fpga/Makefile.extra

index 60b93bb0e7a1d2ae3d9bb89cbe5fab6f12dfef03..5b987d6171f7a0e09808800b363d174e310e0ba2 100644 (file)
@@ -23,13 +23,18 @@ AC_DEFUN([GRC_GNURADIO_EXAMPLES],[
     AC_CONFIG_FILES([ \
         gnuradio-examples/Makefile \
         gnuradio-examples/python/Makefile \
+        gnuradio-examples/python/apps/hf_explorer/Makefile \
+        gnuradio-examples/python/apps/hf_radio/Makefile \
+        gnuradio-examples/python/apps/Makefile \
         gnuradio-examples/python/audio/Makefile \
         gnuradio-examples/python/channel-coding/Makefile \
         gnuradio-examples/python/channel-coding/fsm_files/Makefile \
-        gnuradio-examples/python/digital_voice/Makefile \
         gnuradio-examples/python/digital/Makefile \
-        gnuradio-examples/python/usrp/Makefile \
+        gnuradio-examples/python/digital_voice/Makefile \
+        gnuradio-examples/python/multi-antenna/Makefile \
         gnuradio-examples/python/multi_usrp/Makefile \
+        gnuradio-examples/python/networking/Makefile \
+        gnuradio-examples/python/usrp/Makefile
     ])
 
     passed=yes
index f562cd71776a91c8859da41f8c0c95cc55750589..ec91917b2e3e17b186deb9945554a85999cb07ae 100644 (file)
@@ -43,10 +43,14 @@ grgrpython_PYTHON =                 \
        scheduler.py            
 
 noinst_PYTHON =                        \
+       benchmark_filters.py            \
        qa_add_and_friends.py           \
+       qa_add_v_and_friends.py         \
        qa_agc.py                       \
        qa_basic_flow_graph.py          \
+       qa_cma_equalizer.py             \
        qa_complex_to_xxx.py            \
+       qa_constellation_decoder_cb.py  \
        qa_correlate_access_code.py     \
        qa_diff_encoder.py              \
        qa_diff_phasor_cc.py            \
@@ -56,6 +60,7 @@ noinst_PYTHON =                       \
        qa_flow_graph.py                \
        qa_frequency_modulator.py       \
        qa_fsk_stuff.py                 \
+       qa_goertzel.py                  \
        qa_head.py                      \
        qa_hilbert.py                   \
        qa_iir.py                       \
index c73bf0365dc14189f88e552519b10d3c1cb4d1ae..787fca04ccf37a0514ef113585d5d4e0ccda7f58 100644 (file)
@@ -1,3 +1,7 @@
+For more recent changes, please see:
+
+http://gnuradio.org/trac/timeline
+
 2006-06-20  Eric Blossom  <eb@comsec.com>
 
        * python/gmsk2/receive_path.py, python/gmsk2/transmit_path.py,
index 49d2ba3a815e2d98766ae8386f64b5b24ae720e1..62b79fccddc97e7f44f48491df7c29d3a1c8c694 100644 (file)
@@ -19,4 +19,5 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-SUBDIRS = audio channel-coding digital_voice digital multi_usrp usrp 
+SUBDIRS = apps audio channel-coding digital_voice digital multi-antenna \
+         multi_usrp networking usrp 
diff --git a/gnuradio-examples/python/apps/Makefile.am b/gnuradio-examples/python/apps/Makefile.am
new file mode 100644 (file)
index 0000000..1c66483
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+SUBDIRS = hf_explorer hf_radio
+EXTRA_DIST = README
+
diff --git a/gnuradio-examples/python/apps/hf_explorer/Makefile.am b/gnuradio-examples/python/apps/hf_explorer/Makefile.am
new file mode 100644 (file)
index 0000000..0a688c3
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+EXTRA_DIST =   \
+    README     \
+    hfx2.py    \
+    hfx_help
+
diff --git a/gnuradio-examples/python/apps/hf_radio/Makefile.am b/gnuradio-examples/python/apps/hf_radio/Makefile.am
new file mode 100644 (file)
index 0000000..3aec36a
--- /dev/null
@@ -0,0 +1,34 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+EXTRA_DIST =   \
+    hfir.sci   \
+    input.py   \
+    output.py  \
+    radio.py   \
+    radio.xml  \
+    README.TXT \
+    ssbagc.py  \
+    ssbdemod.py \
+    ssb_taps   \
+    startup.py \
+    ui.py
+
index 0d9e16fd420c10d000e61d071865160e3a8868f3..135ca96a66c611611ba6926cc52476b99e2fec1b 100644 (file)
@@ -21,6 +21,7 @@
 
 EXTRA_DIST =                   \
        audio_copy.py           \
+       audio_fft.py            \
        audio_play.py           \
        audio_to_file.py        \
        dial_tone.py            \
diff --git a/gnuradio-examples/python/multi-antenna/Makefile.am b/gnuradio-examples/python/multi-antenna/Makefile.am
new file mode 100644 (file)
index 0000000..9b55834
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+EXTRA_DIST =           \
+    multi_fft.py       \
+    multi_file.py      \
+    multi_scope.py
diff --git a/gnuradio-examples/python/networking/Makefile.am b/gnuradio-examples/python/networking/Makefile.am
new file mode 100644 (file)
index 0000000..f50e602
--- /dev/null
@@ -0,0 +1,23 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+EXTRA_DIST =           \
+    measurement_slave.py
\ No newline at end of file
index c3ccaa043c5192fa3f6372c2d457731aee29b197..921781190f45376a4dab0d28299c7bc8be5f6daa 100644 (file)
@@ -91,6 +91,7 @@ EXTRA_DIST =                                           \
        sdr_lib/ram16.v                                \
        sdr_lib/ram32.v                                \
        sdr_lib/ram64.v                                \
+       sdr_lib/rssi.v                                 \
        sdr_lib/rx_buffer.v                            \
        sdr_lib/rx_chain.v                             \
        sdr_lib/rx_chain_dual.v                        \