Tweaks to Debian packaging.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 10 Oct 2007 11:46:53 +0000 (11:46 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 10 Oct 2007 11:46:53 +0000 (11:46 +0000)
Added .so versioning where needed (libpmt, libmblock, libgromnithread) to allow automated dependency checking.

Reverted (perhaps temporarily) to '3.0.svn' version numbering as the '~' trick wasn't working with Ubuntu

Note: the -dev packages don't seem to be sufficient to compile the gr-howto-write-a-block module, so still debugging.

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6610 221aa14e-8319-0410-a670-987f0aec2ac5

debian/changelog
debian/control
debian/gen-install-files.sh
debian/install-build-deps.sh
debian/libgnuradio-omnithread0c2a.install
debian/libmblock0c2a.install
debian/libpmt0c2a.install
gr-audio-alsa/src/Makefile.am
mblock/src/lib/Makefile.am
omnithread/Makefile.am
pmt/src/lib/Makefile.am

index a2e46ce5193b13e0cf9056906796c88467701efe..acccb61366ba054cbfa4c8bbbc11aab19173fdfb 100644 (file)
@@ -1,4 +1,4 @@
-gnuradio (3.0~svn) unstable; urgency=low
+gnuradio (3.0.svn) unstable; urgency=low
 
   * add/split packages to cover entire GNU Radio distribution
   * fix build failure with gcc-4.3 by adding a #include, closes: #420896
index 25a4ad760485c52b18ec0102a140ae63bc8bb1f3..14456dab042070d700e0f12066e63ac784796a86 100644 (file)
@@ -28,7 +28,7 @@ Description: GNU Radio Omnithreads Abstraction Library
 Package: libpmt0c2a
 Section: libs
 Architecture: any
-Depends: ${shlibs:Depends}, libgnuradio-omnithread0c2a
+Depends: ${shlibs:Depends}
 Description: GNU Radio Polymorphic Type Library
  This package implements polymorphic types.  These are similar 
  to lisp or Python data objects, and implement transparent
@@ -48,7 +48,7 @@ Description: GNU Radio Polymorphic Type Library
 Package: libmblock0c2a
 Section: libs
 Architecture: any
-Depends: ${shlibs:Depends}, libgnuradio-omnithread0c2a, libpmt0c2a
+Depends: ${shlibs:Depends}
 Description: GNU Radio Message Block Library
  This package provides the GNU Radio message block library.
 
@@ -64,7 +64,7 @@ Description: GNU Radio Message Block Library
 Package: libgnuradio-core0c2a
 Section: libs
 Architecture: any
-Depends: ${shlibs:Depends}, libgnuradio-omnithread0c2a
+Depends: ${shlibs:Depends}
 Conflicts:  libgnuradio-core0, libgnuradio-core0c2
 Replaces:  libgnuradio-core0, libgnuradio-core0c2
 Suggests: gnuradio-doc
@@ -228,7 +228,7 @@ Description: GNU Radio Example Programs
 Package: gnuradio
 Section: comm
 Architecture: all
-Depends: gnuradio-doc, python-gnuradio, gnuradio-examples
+Depends: gnuradio-doc, python-gnuradio, gnuradio-examples, gnuradio-utils
 Suggests: usrp
 Description: GNU Software Defined Radio
  This is a virtual package that depends the entire GNU Radio collection of
@@ -349,7 +349,7 @@ Description: GNU Radio Utilities
 Package: usrp
 Section: contrib/comm
 Architecture: all
-Depends: usrp-doc, usrp-firmware
+Depends: usrp-doc, usrp-firmware, libusrp0c2a
 Description: The Universal Software Radio Peripheral
  This is a virtual package that depends on the entire USRP software collection.
 
index 4fcccadc70e392161b3f9ff3063244967034b315..e7a63b1a32f3c0b71ce6181cde63722504844683 100755 (executable)
@@ -106,11 +106,11 @@ $EXTRACT gr-audio-alsa/src/Makefile ourpython_PYTHON >>$NAME
 # They are only separate in this package for C++ only experimentation
 $EXTRACT gr-audio-alsa/src/Makefile lib_LTLIBRARIES >>$NAME
 $EXTRACT gr-audio-alsa/src/Makefile lib_LTLIBRARIES | \
-    sed -e 's/\.la$/.so/' >>$NAME
+    sed -e 's/\.la$/.so*/' >>$NAME
 #
 $EXTRACT gr-audio-alsa/src/Makefile ourlib_LTLIBRARIES >>$NAME
 $EXTRACT gr-audio-alsa/src/Makefile ourlib_LTLIBRARIES | \
-    sed -e 's/\.la$/.so/' >>$NAME
+    sed -e 's/\.la$/.so*/' >>$NAME
 
 # python-gnuradio-audio-jack
 NAME=debian/python-gnuradio-audio-jack.install
index 3dbbf8b8b39313b570d05bb0173ec9f88d807229..d223b24be81c475628008776f87108e61e3490ae 100755 (executable)
@@ -9,7 +9,7 @@ else
 fi
 
 sudo apt-get install \
-    autotools-dev doxygen $FFTW3DEV libasound2-dev \
+    build-essential autotools-dev doxygen $FFTW3DEV libasound2-dev \
     libboost-dev libcppunit-dev libjack0.100.0-dev libsdl1.2-dev \
     portaudio19-dev libtool libusb-dev pkg-config python python-all-dev \
     python-central python-numpy python-wxgtk2.6 sdcc swig xmlto
index 65ecd351e01ed560eb836f1ca23705da8a0bfcc1..128b39895c358fd13b9b725107c2d82ee23c4527 100644 (file)
@@ -1,3 +1,3 @@
 usr/lib/libgromnithread.la
-usr/lib/libgromnithread.so
+usr/lib/libgromnithread*.so*
 usr/lib/pkgconfig/gnuradio-omnithread.pc
index ea29c8f73c610da9955b1cf7ae20de49d4bc44fc..8e96520fbe309414e9906f11de662c32212f7c26 100644 (file)
@@ -1,4 +1,4 @@
 usr/lib/pkgconfig/mblock.pc
 usr/lib/libmblock.la
-usr/lib/libmblock.so
+usr/lib/libmblock*.so*
 
index d27f75a68cd1e439d9ef3809dfb873e1055fd794..1f50f0532a1a54bf15bffd713771e5f4a214a580 100644 (file)
@@ -1,4 +1,3 @@
 usr/lib/libpmt.la
-usr/lib/libpmt.so
+usr/lib/libpmt*.so*
 usr/lib/pkgconfig/pmt.pc
-usr/share/gnuradio/pmt*
index 0b4b93947ef951662ef815d3f0ee06b5fd47d501..d6c5c9edbd9f1c4226d274950f6bfbcdadb7480b 100644 (file)
@@ -88,7 +88,7 @@ libgr_audio_alsa_la_LIBADD =          \
 
 _audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 
-libgr_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libgr_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED)
 
 audio_alsa.cc audio_alsa.py: $(LOCAL_IFILES) $(NON_LOCAL_IFILES)
        $(SWIG) $(SWIGPYTHONARGS) -module audio_alsa -o audio_alsa.cc $(LOCAL_IFILES)
index 45fd8279bc5fa757c0e450883655cd52e6cfa5b6..9a653759de79cf8bcae9106e643f2f5a6d08fa10 100644 (file)
@@ -66,7 +66,7 @@ libmblock_la_SOURCES =                        \
 
 
 # magic flags
-libmblock_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libmblock_la_LDFLAGS = $(NO_UNDEFINED)
 
 # link the library against the c++ standard library
 libmblock_la_LIBADD =                  \
index 526cae0e9f7a558c8bf8ebebc1163230d575d2d5..dfbb3b3d3566709c6aad5f26ec24bb04bcd84451 100644 (file)
@@ -44,7 +44,7 @@ libgromnithread_la_SOURCES =          \
        nt.cc
 endif
 
-libgromnithread_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version 
+libgromnithread_la_LDFLAGS = $(NO_UNDEFINED) 
 
 libgromnithread_la_LIBADD =            \
        $(PTHREAD_LIBS)
index ab23586c1d3366a401e58bdb3fb230fbf44ee530..69286040800f5d9e79ea247986fd9beabca6a45d 100644 (file)
@@ -67,7 +67,7 @@ libpmt_la_SOURCES =                   \
        pmt_unv.cc                      
 
 # magic flags
-libpmt_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libpmt_la_LDFLAGS = $(NO_UNDEFINED)
 
 # link the library against the c++ standard library
 libpmt_la_LIBADD =                     \
@@ -94,7 +94,7 @@ libpmt_qa_la_SOURCES =                        \
        qa_pmt_unv.cc                   
 
 # magic flags
-libpmt_qa_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libpmt_qa_la_LDFLAGS = $(NO_UNDEFINED) -avoid version
 
 libpmt_qa_la_LIBADD =                  \
        libpmt.la                       \