When using python to check for wx module, call it via the variable
authorgdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 25 Nov 2006 13:00:42 +0000 (13:00 +0000)
committergdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 25 Nov 2006 13:00:42 +0000 (13:00 +0000)
earlier set with the path to the python interpreter, rather than
hard-coding 'python'.  Fixes build on systems where python is
installed with a version suffix (e.g. python2.4), such as pkgsrc.

From Berndt Josef Wulf via gnuradio-discuss; change is below the
copyright threshold.

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4017 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_gr_wxgui.m4

index dff666b0aa057bcbd632a9275c02a883a9f03f3b..8c8848f4f4e576e4cd93d6a23b44a4ca5d4a14a9 100644 (file)
@@ -26,9 +26,7 @@ AC_DEFUN([GRC_GR_WXGUI],[
          gr-wxgui/src/python/Makefile \
     ])
 
-    # FIXME: this breaks pkgsrc by calling python without a version number
-    # gdt--patch welcome :-)
-    if python -c 'import wx'; then
+    if ${PYTHON} -c 'import wx'; then
        passed=yes
     else
        passed=no