build: avoid non-srcdir build failure
authorJim Meyering <meyering@redhat.com>
Sun, 16 Aug 2009 08:51:19 +0000 (10:51 +0200)
committerJim Meyering <meyering@redhat.com>
Tue, 18 Aug 2009 07:28:05 +0000 (09:28 +0200)
* Makefile.am (gzip.doc.gz): Use $(srcdir)/gzip.doc, not gzip.doc.
Don't redirect directly to $@.  Use $(AM_V_GEN).
(gzip.doc, .in): Don't redirect directly to $@.  Use $(AM_V_GEN).
* NEWS: Add template header for upcoming release.

Makefile.am
NEWS

index 1ef6415558d85581a88689d9b08d45a26dbb9bea..d5d41f7ec346a1ab6afe1d971e3e0ad965d5dd5d 100644 (file)
@@ -48,19 +48,21 @@ gzip_SOURCES = \
 gzip_LDADD = lib/libgzip.a
 
 gzip.doc: gzip.1
-       groff -man -Tascii $(srcdir)/gzip.1 | col -b | uniq >$@
+       $(AM_V_GEN)groff -man -Tascii $(srcdir)/gzip.1 | col -b | uniq > $@-t \
+         && mv $@-t $@
 
 gzip.doc.gz: gzip.doc $(bin_PROGRAMS)
-       ./gzip <gzip.doc >$@
+       $(AM_V_GEN)./gzip < $(srcdir)/gzip.doc >$@-t && mv $@-t $@
 
 SUFFIXES = .in
 .in:
-       sed \
+       $(AM_V_GEN)sed \
                -e 's|/bin/sh|$(SHELL)|g' \
                -e 's|[@]bindir@|'\''$(bindir)'\''|g' \
                -e 's|[@]VERSION@|$(VERSION)|g' \
-               $(srcdir)/$@.in >$@
-       chmod a+x $@
+               $(srcdir)/$@.in >$@-t \
+         && chmod a+x $@-t \
+         && mv $@-t $@
 
 # Arrange so that .tarball-version appears only in the distribution
 # tarball, and never in a checked-out repository.
diff --git a/NEWS b/NEWS
index eda76836adbd5ff7101cdbe88e858048100d19ba..90c2e6117c05e15d3da7db6e7ac51b8cf10259d2 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,10 @@
+GNU gzip NEWS                                    -*- outline -*-
+
+* Noteworthy changes in release ?.?.? (????-??-??) [?]
+
+** Bug fixes
+
+
 Major changes in Gzip 1.3.12 (2007-04-13)
 
 * znew now uses $TMPDIR (default /tmp) instead of always using /tmp.