Use system byteswap implementations where available.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 23 Jun 2008 00:25:56 +0000 (00:25 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 23 Jun 2008 00:25:56 +0000 (00:25 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8658 221aa14e-8319-0410-a670-987f0aec2ac5

configure.ac
gruel/src/include/gruel/inet.h.in

index 529d91e77ea18ee59b0836f64a54dc7bdf8c0bd0..4dc4e18739db41fd5246a09ceb65cd406c369f13 100644 (file)
@@ -128,7 +128,13 @@ AC_CHECK_HEADERS(linux/ppdev.h dev/ppbus/ppi.h sys/mman.h sys/select.h sys/types
 AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h sys/syscall.h)
 AC_CHECK_HEADERS(netinet/in.h)
 AC_CHECK_HEADERS(windows.h)
+
+dnl Allow creating autoconf independent header files for bytesex routines
+AC_CHECK_HEADER(arpa/inet.h, [GR_HAVE_ARPA_INET=1],[GR_HAVE_ARPA_INET=0])
+AC_CHECK_HEADER(netinet/in.h, [GR_HAVE_NETINET_IN=1],[GR_HAVE_NETINET_IN=0])
 AC_CHECK_HEADER(byteswap.h, [GR_HAVE_BYTESWAP=1],[GR_HAVE_BYTESWAP=0])
+AC_SUBST(GR_HAVE_ARPA_INET)
+AC_SUBST(GR_HAVE_NETINET_IN)
 AC_SUBST(GR_HAVE_BYTESWAP)
 
 dnl Checks for typedefs, structures, and compiler characteristics.
index dd05257083b1b5441594a3b4c232ceaace4d6f68..a98d83e9c57962b02aa78a3dab10eecea725ebaa 100644 (file)
 #ifndef INCLUDED_INET_H
 #define INCLUDED_INET_H
 
+#if @GR_HAVE_ARPA_INET@  /* GR_HAVE_ARPA_INET */
+#include <arpa/inet.h>
+#elif @GR_HAVE_NETINET_IN@  /* GR_HAVE_NETINET_IN */
+#include <netinet/in.h>
+#else
 #include <stdint.h>
 
 #if @GR_ARCH_BIGENDIAN@  /* GR_ARCH_BIGENDIAN */
@@ -31,19 +36,17 @@ static inline uint16_t ntohs(uint16_t x){ return x; }
 #if @GR_HAVE_BYTESWAP@  /* GR_HAVE_BYTESWAP */
 #include <byteswap.h>
 #else
-#warning Using non-portable code (likely wrong other than ILP32).
-
-static inline unsigned short int
-bswap_16 (unsigned short int x)
+static inline uint16_t
+bswap_16 (uint16_t x)
 {
   return ((((x) >> 8) & 0xff) | (((x) & 0xff) << 8));
 }
 
-static inline unsigned int
-bswap_32 (unsigned int x)
+static inline uint32_t
+bswap_32 (uint32_t x)
 {
-  return ((((x) & 0xff000000) >> 24) | (((x) & 0x00ff0000) >>  8)      \
-       | (((x) & 0x0000ff00) <<  8) | (((x) & 0x000000ff) << 24));
+  return ((((x) & 0xff000000) >> 24) | (((x) & 0x00ff0000) >>  8) \
+        | (((x) & 0x0000ff00) <<  8) | (((x) & 0x000000ff) << 24));
 }
 #endif /* GR_HAVE_BYTESWAP */
 
@@ -53,6 +56,8 @@ static inline uint32_t ntohl(uint32_t x){ return bswap_32(x); }
 static inline uint16_t ntohs(uint16_t x){ return bswap_16(x); }
 #endif /* GR_ARCH_BIGENDIAN */
 
+#endif /* !(GR_HAVE_NETINET_IN || GR_HAVE_ARPA_INET) */
+
 static inline uint8_t  ntohx(uint8_t  x){ return x;        }
 static inline uint16_t ntohx(uint16_t x){ return ntohs(x); }
 static inline uint32_t ntohx(uint32_t x){ return ntohl(x); }