specify multiarch path for libsss-sudo location
authorBdale Garbee <bdale@gag.com>
Sat, 17 Aug 2013 13:39:21 +0000 (15:39 +0200)
committerBdale Garbee <bdale@gag.com>
Sat, 17 Aug 2013 13:39:21 +0000 (15:39 +0200)
debian/changelog
debian/rules

index c05c18079d4b1a35303116bd557a48f31246493c..39e9b6fa28e1141b48db958cfdf5459c8ce0a179 100644 (file)
@@ -1,3 +1,10 @@
+sudo (1.8.7-3) unstable; urgency=low
+
+  * use --with-sssd-lib to help sudo find libsss-sudo in multiarch path,
+    closes: #719987
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 17 Aug 2013 15:38:53 +0200
+
 sudo (1.8.7-2) unstable; urgency=low
 
   * let debhelper scripts manage the update-rc.d calls, closes: #719755
index 0a73e30473a77f7d90f995ddf9484532f90db0f7..a700c553265fdc5f0ae65c57e9061409b5fc2c94 100755 (executable)
@@ -7,6 +7,7 @@ CFLAGS += -Wall -Wno-comment
 LDFLAGS = `dpkg-buildflags --get LDFLAGS`
 CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
 
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
 ifeq ($(DEB_HOST_ARCH_OS),linux)
   configure_args += --with-selinux
@@ -44,7 +45,7 @@ configure-stamp: reconf-stamp
                --with-timedir=/var/lib/sudo \
                --mandir=/usr/share/man \
                --libexecdir=/usr/lib/sudo \
-               --with-sssd \
+               --with-sssd-lib=/usr/lib/$(DEB_HOST_MULTIARCH) \
                $(configure_args)
 
        # LDAP version