build: use more gnulib modules for better POSIX compliance
authorJim Meyering <meyering@redhat.com>
Wed, 30 Sep 2009 10:40:01 +0000 (12:40 +0200)
committerJim Meyering <meyering@redhat.com>
Wed, 30 Sep 2009 10:55:51 +0000 (12:55 +0200)
* bootstrap.conf (gnulib_modules): Add modules exposed via
make CFLAGS=-DGNULIB_POSIXCHECK 2>&1 \
|perl -lne '/.* use gnulib module (\S+).*/ and print $1' \
|sort |uniq -c|sort -nr
Add these: calloc close fclose fprintf-posix lstat malloc
perror printf-posix realloc

bootstrap.conf
lib/.gitignore
m4/.gitignore

index 30e2af0ef345889ea1a9f8f78504c10aa23a9eae..6ddd1ab961b0bbf1bd3d5d1dcf3343893096c317 100644 (file)
@@ -21,16 +21,25 @@ IMPORT_FROM_GETTEXT=no
 
 # gnulib modules used by this package.
 gnulib_modules='
+       calloc
+       close
        closein
+       fclose
        fcntl
        fcntl-safer
        fdl
+       fprintf-posix
        getopt-gnu
        git-version-gen
        gitlog-to-changelog
        gnu-make
        gnumakefile
+       lstat
        maintainer-makefile
+       malloc
+       perror
+       printf-posix
+       realloc
        stat-time
        sys_stat
        time
index f87d969f4bdb4c3ac21eb436e8ac8fb5dc362ebd..51066951b4262c30ecc1bf694fcd7f0ab044acb5 100644 (file)
@@ -1,9 +1,16 @@
 .deps
 Makefile
 Makefile.in
+alloca.h
+alloca.in.h
+asnprintf.c
+calloc.c
 charset.alias
+close-hook.c
+close-hook.h
 close-stream.c
 close-stream.h
+close.c
 closein.c
 closein.h
 closeout.c
@@ -14,12 +21,14 @@ config.hin
 configmake.h
 creat-safer.c
 dup-safer.c
+dup2.c
 errno.h
 errno.in.h
 error.c
 error.h
 exitfail.c
 exitfail.h
+fclose.c
 fcntl--.h
 fcntl-safer.h
 fcntl.h
@@ -27,41 +36,80 @@ fcntl.in.h
 fcntl_.h
 fd-safer.c
 fflush.c
+float+.h
+float.h
+float.in.h
 fpending.c
 fpending.h
+fprintf.c
+fpucw.h
 fpurge.c
 fpurge.h
 freadahead.c
 freadahead.h
 freading.c
 freading.h
+frexp.c
+frexpl.c
 fseeko.c
+fseterr.c
+fseterr.h
 ftello.c
 getopt.c
 getopt.h
 getopt.in.h
 getopt1.c
 getopt_int.h
+getpagesize.c
 gettext.h
 gnulib.mk
 intprops.h
+isnan.c
+isnand-nolibm.h
+isnand.c
+isnanf-nolibm.h
+isnanf.c
+isnanl-nolibm.h
+isnanl.c
 libgzip.a
 localcharset.c
 localcharset.h
 lseek.c
+lstat.c
+malloc.c
+math.h
+math.in.h
 mbrtowc.c
 mbsinit.c
+memchr.c
+memchr.valgrind
 open-safer.c
 open.c
+perror.c
 pipe-safer.c
+printf-args.c
+printf-args.h
+printf-frexp.c
+printf-frexp.h
+printf-frexpl.c
+printf-frexpl.h
+printf-parse.c
+printf-parse.h
+printf.c
 quotearg.c
 quotearg.h
+realloc.c
 ref-add.sed
 ref-add.sin
 ref-del.sed
 ref-del.sin
+signbitd.c
+signbitf.c
+signbitl.c
+size_max.h
 stamp-h1
 stat-time.h
+stat.c
 stdbool.h
 stdbool.in.h
 stdbool_.h
@@ -98,7 +146,10 @@ unistd.in.h
 unistd_.h
 utimens.c
 utimens.h
+vasnprintf.c
+vasnprintf.h
 verify.h
+vfprintf.c
 wchar.h
 wchar.in.h
 wchar_.h
@@ -108,5 +159,6 @@ wctype_.h
 xalloc-die.c
 xalloc.h
 xmalloc.c
+xsize.h
 yesno.c
 yesno.h
index e9195156aaf63c49ccab8d42e86f0cdb29b0d8bb..01c37175ee4c562abdd2ce5b0b8aa8c6a2acb721 100644 (file)
@@ -1,22 +1,37 @@
 00gnulib.m4
 absolute-header.m4
+alloca.m4
+calloc.m4
 close-stream.m4
+close.m4
 closein.m4
 closeout.m4
 codeset.m4
+dos.m4
+dup2.m4
 errno_h.m4
 error.m4
 exitfail.m4
+exponentd.m4
+exponentf.m4
+exponentl.m4
 extensions.m4
+fclose.m4
 fcntl-safer.m4
 fcntl_h.m4
 fflush.m4
+float_h.m4
 fpending.m4
+fpieee.m4
+fprintf-posix.m4
 fpurge.m4
 freading.m4
+frexp.m4
+frexpl.m4
 fseeko.m4
 ftello.m4
 getopt.m4
+getpagesize.m4
 glibc21.m4
 gnu-make.m4
 gnulib-cache.m4
@@ -25,24 +40,46 @@ gnulib-comp.m4
 gnulib-tool.m4
 include_next.m4
 inline.m4
+intmax_t.m4
+inttypes_h.m4
+isnand.m4
+isnanf.m4
+isnanl.m4
+ldexpl.m4
 localcharset.m4
 locale-fr.m4
 locale-ja.m4
 locale-zh.m4
 longlong.m4
 lseek.m4
+lstat.m4
+malloc.m4
+math_h.m4
 mbrtowc.m4
 mbsinit.m4
 mbstate_t.m4
+memchr.m4
+mmap-anon.m4
 mode_t.m4
 multiarch.m4
+nocrash.m4
 open.m4
 openat.m4
+perror.m4
+printf-frexp.m4
+printf-frexpl.m4
+printf-posix-rpl.m4
+printf.m4
 quotearg.m4
+realloc.m4
+signbit.m4
+size_max.m4
 stat-time.m4
+stat.m4
 stdbool.m4
 stddef_h.m4
 stdint.m4
+stdint_h.m4
 stdio_h.m4
 stdlib_h.m4
 strerror.m4
@@ -55,9 +92,12 @@ unistd_h.m4
 utimbuf.m4
 utimens.m4
 utimes.m4
+vasnprintf.m4
+vfprintf-posix.m4
 wchar.m4
 wchar_t.m4
 wctype.m4
 wint_t.m4
 xalloc.m4
+xsize.m4
 yesno.m4