Merging trondeau/digital branch r11185:11205 to improve digital example interfacing...
authortrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 17 Jun 2009 02:14:59 +0000 (02:14 +0000)
committertrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 17 Jun 2009 02:14:59 +0000 (02:14 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11209 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-examples/python/digital/Makefile.am
gnuradio-examples/python/digital/benchmark_loopback.py
gnuradio-examples/python/digital/benchmark_rx.py
gnuradio-examples/python/digital/benchmark_tx.py
gnuradio-examples/python/digital/receive_path.py
gnuradio-examples/python/digital/receive_path_lb.py [deleted file]
gnuradio-examples/python/digital/transmit_path.py
gnuradio-examples/python/digital/transmit_path_lb.py [deleted file]

index 97e586a7060cb68b330bd536dde34006e4a6f75e..f89ce1a9497c63ae4e4d6bd2d2ca3da249ec2c82 100644 (file)
@@ -28,9 +28,7 @@ dist_ourdata_DATA =           \
        generic_usrp.py         \
        pick_bitrate.py         \
        receive_path.py         \
-       receive_path_lb.py      \
        transmit_path.py        \
-       transmit_path_lb.py     \
        usrp_options.py
 
 dist_ourdata_SCRIPTS =         \
index e62c12eac79dd4ecfa1172ceb8f2cc2da865878f..4cc4a7bee3698f1a14ae36706ce9c37307dd6ef7 100755 (executable)
@@ -28,8 +28,8 @@ from optparse import OptionParser
 import random, time, struct, sys, math
 
 # from current dir
-from transmit_path_lb import transmit_path
-from receive_path_lb import receive_path
+from transmit_path import transmit_path
+from receive_path import receive_path
 
 class my_top_block(gr.top_block):
     def __init__(self, mod_class, demod_class, rx_callback, options):
index b0b99ecff164861aeb40f9220c21650b2aa9c2cb..736110da45e82220250e57fb7d5b720cfb826b3a 100755 (executable)
@@ -40,8 +40,120 @@ from receive_path import receive_path
 class my_top_block(gr.top_block):
     def __init__(self, demodulator, rx_callback, options):
         gr.top_block.__init__(self)
+
+        self._rx_freq            = options.rx_freq         # receiver's center frequency
+        self._rx_gain            = options.rx_gain         # receiver's gain
+        self._rx_subdev_spec     = options.rx_subdev_spec  # daughterboard to use
+        self._decim              = options.decim           # Decimating rate for the USRP (prelim)
+
+        if self._rx_freq is None:
+            sys.stderr.write("-f FREQ or --freq FREQ or --rx-freq FREQ must be specified\n")
+            raise SystemExit
+
+        # Set up USRP source
+        self._setup_usrp_source()
+        ok = self.set_freq(self._rx_freq)
+        if not ok:
+            print "Failed to set Rx frequency to %s" % (eng_notation.num_to_str(self._rx_freq))
+            raise ValueError, eng_notation.num_to_str(self._rx_freq)
+        g = self.subdev.gain_range()
+        if options.show_rx_gain_range:
+            print "Rx Gain Range: minimum = %g, maximum = %g, step size = %g" \
+                  % (g[0], g[1], g[2])
+        self.set_gain(options.rx_gain)
+        self.set_auto_tr(True)                 # enable Auto Transmit/Receive switching
+
+        # Set up receive path
         self.rxpath = receive_path(demodulator, rx_callback, options) 
-        self.connect(self.rxpath)
+
+        self.connect(self.u, self.rxpath)
+        
+    def _setup_usrp_source(self):
+        self.u = usrp.source_c ()
+        adc_rate = self.u.adc_rate()
+
+        self.u.set_decim_rate(self._decim)
+
+        # determine the daughterboard subdevice we're using
+        if self._rx_subdev_spec is None:
+            self._rx_subdev_spec = usrp.pick_rx_subdevice(self.u)
+        self.subdev = usrp.selected_subdev(self.u, self._rx_subdev_spec)
+
+        self.u.set_mux(usrp.determine_rx_mux_value(self.u, self._rx_subdev_spec))
+
+    def set_freq(self, target_freq):
+        """
+        Set the center frequency we're interested in.
+
+        @param target_freq: frequency in Hz
+        @rypte: bool
+
+        Tuning is a two step process.  First we ask the front-end to
+        tune as close to the desired frequency as it can.  Then we use
+        the result of that operation and our target_frequency to
+        determine the value for the digital up converter.
+        """
+        r = self.u.tune(0, self.subdev, target_freq)
+        if r:
+            return True
+
+        return False
+
+    def set_gain(self, gain):
+        """
+        Sets the analog gain in the USRP
+        """
+        if gain is None:
+            r = self.subdev.gain_range()
+            gain = (r[0] + r[1])/2               # set gain to midpoint
+        self.gain = gain
+        return self.subdev.set_gain(gain)
+
+    def set_auto_tr(self, enable):
+        return self.subdev.set_auto_tr(enable)
+
+    def decim(self):
+        return self._decim
+
+    def add_options(normal, expert):
+        """
+        Adds usrp-specific options to the Options Parser
+        """
+        add_freq_option(normal)
+        normal.add_option("-R", "--rx-subdev-spec", type="subdev", default=None,
+                          help="select USRP Rx side A or B")
+        normal.add_option("", "--rx-gain", type="eng_float", default=None, metavar="GAIN",
+                          help="set receiver gain in dB [default=midpoint].  See also --show-rx-gain-range")
+        normal.add_option("", "--show-rx-gain-range", action="store_true", default=False, 
+                          help="print min and max Rx gain available on selected daughterboard")
+        normal.add_option("-v", "--verbose", action="store_true", default=False)
+
+        expert.add_option("", "--rx-freq", type="eng_float", default=None,
+                          help="set Rx frequency to FREQ [default=%default]", metavar="FREQ")
+        expert.add_option("-d", "--decim", type="intx", default=128,
+                          help="set fpga decimation rate to DECIM [default=%default]")
+        expert.add_option("", "--snr", type="eng_float", default=30,
+                          help="set the SNR of the channel in dB [default=%default]")
+   
+
+    # Make a static method to call before instantiation
+    add_options = staticmethod(add_options)
+
+
+def add_freq_option(parser):
+    """
+    Hackery that has the -f / --freq option set both tx_freq and rx_freq
+    """
+    def freq_callback(option, opt_str, value, parser):
+        parser.values.rx_freq = value
+        parser.values.tx_freq = value
+
+    if not parser.has_option('--freq'):
+        parser.add_option('-f', '--freq', type="eng_float",
+                          action="callback", callback=freq_callback,
+                          help="set Tx and/or Rx frequency to FREQ [default=%default]",
+                          metavar="FREQ")
+
 
 # /////////////////////////////////////////////////////////////////////////////
 #                                   main
@@ -77,6 +189,7 @@ def main():
                       help="Select modulation from: %s [default=%%default]"
                             % (', '.join(demods.keys()),))
 
+    my_top_block.add_options(parser, expert_grp)
     receive_path.add_options(parser, expert_grp)
 
     for mod in demods.values():
index 5115d764c9e4e767b8c7635e8a606233fea5c2e8..3e3ce8a462ede03ae7f90319c42033cab4e805fd 100755 (executable)
@@ -38,8 +38,127 @@ from transmit_path import transmit_path
 class my_top_block(gr.top_block):
     def __init__(self, modulator, options):
         gr.top_block.__init__(self)
+
+        self._tx_freq            = options.tx_freq         # tranmitter's center frequency
+        self._tx_subdev_spec     = options.tx_subdev_spec  # daughterboard to use
+        self._interp             = options.interp          # interpolating rate for the USRP (prelim)
+
+        if self._tx_freq is None:
+            sys.stderr.write("-f FREQ or --freq FREQ or --tx-freq FREQ must be specified\n")
+            raise SystemExit
+
+        # Set up USRP sink; also adjusts interp, and bitrate
+        self._setup_usrp_sink()
+
+        # copy the final answers back into options for use by modulator
+        #options.bitrate = self._bitrate
+
         self.txpath = transmit_path(modulator, options)
-        self.connect(self.txpath)
+
+        self.connect(self.txpath, self.u)
+
+    def _setup_usrp_sink(self):
+        """
+        Creates a USRP sink, determines the settings for best bitrate,
+        and attaches to the transmitter's subdevice.
+        """
+        self.u = usrp.sink_c()
+
+        self.u.set_interp_rate(self._interp)
+
+        # determine the daughterboard subdevice we're using
+        if self._tx_subdev_spec is None:
+            self._tx_subdev_spec = usrp.pick_tx_subdevice(self.u)
+        self.u.set_mux(usrp.determine_tx_mux_value(self.u, self._tx_subdev_spec))
+        self.subdev = usrp.selected_subdev(self.u, self._tx_subdev_spec)
+
+        # Set center frequency of USRP
+        ok = self.set_freq(self._tx_freq)
+        if not ok:
+            print "Failed to set Tx frequency to %s" % (eng_notation.num_to_str(self._tx_freq),)
+            raise ValueError
+
+        # Set the USRP for maximum transmit gain
+        # (Note that on the RFX cards this is a nop.)
+        self.set_gain(self.subdev.gain_range()[1])
+
+        # enable Auto Transmit/Receive switching
+        self.set_auto_tr(True)
+
+    def set_freq(self, target_freq):
+        """
+        Set the center frequency we're interested in.
+
+        @param target_freq: frequency in Hz
+        @rypte: bool
+
+        Tuning is a two step process.  First we ask the front-end to
+        tune as close to the desired frequency as it can.  Then we use
+        the result of that operation and our target_frequency to
+        determine the value for the digital up converter.
+        """
+        r = self.u.tune(self.subdev.which(), self.subdev, target_freq)
+        if r:
+            return True
+
+        return False
+        
+    def set_gain(self, gain):
+        """
+        Sets the analog gain in the USRP
+        """
+        self.gain = gain
+        self.subdev.set_gain(gain)
+
+    def set_auto_tr(self, enable):
+        """
+        Turns on auto transmit/receive of USRP daughterboard (if exits; else ignored)
+        """
+        return self.subdev.set_auto_tr(enable)
+        
+    def interp(self):
+        return self._interp
+
+    def add_options(normal, expert):
+        """
+        Adds usrp-specific options to the Options Parser
+        """
+        add_freq_option(normal)
+        normal.add_option("-T", "--tx-subdev-spec", type="subdev", default=None,
+                          help="select USRP Tx side A or B")
+        normal.add_option("-v", "--verbose", action="store_true", default=False)
+
+        expert.add_option("", "--tx-freq", type="eng_float", default=None,
+                          help="set transmit frequency to FREQ [default=%default]", metavar="FREQ")
+        expert.add_option("-i", "--interp", type="intx", default=256,
+                          help="set fpga interpolation rate to INTERP [default=%default]")
+    # Make a static method to call before instantiation
+    add_options = staticmethod(add_options)
+
+    def _print_verbage(self):
+        """
+        Prints information about the transmit path
+        """
+        print "Using TX d'board %s"    % (self.subdev.side_and_name(),)
+        print "modulation:      %s"    % (self._modulator_class.__name__)
+        print "interp:          %3d"   % (self._interp)
+        print "Tx Frequency:    %s"    % (eng_notation.num_to_str(self._tx_freq))
+        
+
+def add_freq_option(parser):
+    """
+    Hackery that has the -f / --freq option set both tx_freq and rx_freq
+    """
+    def freq_callback(option, opt_str, value, parser):
+        parser.values.rx_freq = value
+        parser.values.tx_freq = value
+
+    if not parser.has_option('--freq'):
+        parser.add_option('-f', '--freq', type="eng_float",
+                          action="callback", callback=freq_callback,
+                          help="set Tx and/or Rx frequency to FREQ [default=%default]",
+                          metavar="FREQ")
+
 
 # /////////////////////////////////////////////////////////////////////////////
 #                                   main
@@ -72,6 +191,7 @@ def main():
     parser.add_option("","--from-file", default=None,
                       help="use file for packet contents")
 
+    my_top_block.add_options(parser, expert_grp)
     transmit_path.add_options(parser, expert_grp)
 
     for mod in mods.values():
index 507d05e7baeba4c4081861420a8d2eead4cb1749..a6bffeeac4c942a69c74b0c96770a69d30be03fc 100644 (file)
@@ -1,6 +1,6 @@
 #!/usr/bin/env python
 #
-# Copyright 2005,2006,2007,2009 Free Software Foundation, Inc.
+# Copyright 2005,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # 
 
 from gnuradio import gr, gru, blks2
-from gnuradio import usrp
 from gnuradio import eng_notation
 import copy
 import sys
 
-# from current dir
-from pick_bitrate import pick_rx_bitrate
-import usrp_options
-
 # /////////////////////////////////////////////////////////////////////////////
 #                              receive path
 # /////////////////////////////////////////////////////////////////////////////
 
 class receive_path(gr.hier_block2):
     def __init__(self, demod_class, rx_callback, options):
-
        gr.hier_block2.__init__(self, "receive_path",
-                                gr.io_signature(0, 0, 0), # Input signature
-                                gr.io_signature(0, 0, 0)) # Output signature
+                               gr.io_signature(1, 1, gr.sizeof_gr_complex), # Input signature
+                               gr.io_signature(0, 0, 0))                    # Output signature
 
+        
         options = copy.copy(options)    # make a copy so we can destructively modify
 
         self._verbose            = options.verbose
-        self._rx_freq            = options.rx_freq         # receiver's center frequency
         self._bitrate            = options.bitrate         # desired bit rate
-        self._decim              = options.decim           # Decimating rate for the USRP (prelim)
         self._samples_per_symbol = options.samples_per_symbol  # desired samples/symbol
 
         self._rx_callback   = rx_callback      # this callback is fired when there's a packet available
         self._demod_class   = demod_class      # the demodulator_class we're using
 
-        if self._rx_freq is None:
-            sys.stderr.write("-f FREQ or --freq FREQ or --rx-freq FREQ must be specified\n")
-            raise SystemExit
-
-        # Set up USRP source; also adjusts decim, samples_per_symbol, and bitrate
-        self._setup_usrp_source(options)
-
-        # Set RF frequency
-        ok = self.set_freq(self._rx_freq)
-        if not ok:
-            print "Failed to set Rx frequency to %s" % (eng_notation.num_to_str(self._rx_freq))
-            raise ValueError, eng_notation.num_to_str(self._rx_freq)
-
-        # copy the final answers back into options for use by demodulator
-        options.samples_per_symbol = self._samples_per_symbol
-        options.bitrate = self._bitrate
-        options.decim = self._decim
-
         # Get demod_kwargs
         demod_kwargs = self._demod_class.extract_kwargs_from_options(options)
 
@@ -79,73 +54,40 @@ class receive_path(gr.hier_block2):
                                           sw_decim * self._samples_per_symbol, # sampling rate
                                           1.0,                  # midpoint of trans. band
                                           0.5,                  # width of trans. band
-                                          gr.firdes.WIN_HANN)   # filter type 
-
-        # Decimating channel filter
-        # complex in and out, float taps
-        self.chan_filt = gr.fft_filter_ccc(sw_decim, chan_coeffs)
-        #self.chan_filt = gr.fir_filter_ccf(sw_decim, chan_coeffs)
-
+                                          gr.firdes.WIN_HANN)   # filter type
+        self.channel_filter = gr.fft_filter_ccc(sw_decim, chan_coeffs)
+        
         # receiver
         self.packet_receiver = \
             blks2.demod_pkts(self._demod_class(**demod_kwargs),
                              access_code=None,
                              callback=self._rx_callback,
                              threshold=-1)
-    
+
         # Carrier Sensing Blocks
         alpha = 0.001
         thresh = 30   # in dB, will have to adjust
-
-        if options.log_rx_power == True:
-            self.probe = gr.probe_avg_mag_sqrd_cf(thresh,alpha)
-            self.power_sink = gr.file_sink(gr.sizeof_float, "rxpower.dat")
-            self.connect(self.chan_filt, self.probe, self.power_sink)
-        else:
-            self.probe = gr.probe_avg_mag_sqrd_c(thresh,alpha)
-            self.connect(self.chan_filt, self.probe)
+        self.probe = gr.probe_avg_mag_sqrd_c(thresh,alpha)
 
         # Display some information about the setup
         if self._verbose:
             self._print_verbage()
-            
-        self.connect(self.u, self.chan_filt, self.packet_receiver)
-
-    def _setup_usrp_source(self, options):
-
-        self.u = usrp_options.create_usrp_source(options)
-        adc_rate = self.u.adc_rate()
 
-        # derive values of bitrate, samples_per_symbol, and decim from desired info
-        (self._bitrate, self._samples_per_symbol, self._decim) = \
-            pick_rx_bitrate(self._bitrate, self._demod_class.bits_per_symbol(), \
-                            self._samples_per_symbol, self._decim, adc_rate, self.u.get_decim_rates())
+       # connect block input to channel filter
+       self.connect(self, self.channel_filter)
 
-        self.u.set_decim(self._decim)
+        # connect the channel input filter to the carrier power detector
+        self.connect(self.channel_filter, self.probe)
 
-    def set_freq(self, target_freq):
-        """
-        Set the center frequency we're interested in.
-
-        @param target_freq: frequency in Hz
-        @rypte: bool
+        # connect channel filter to the packet receiver
+        self.connect(self.channel_filter, self.packet_receiver)
 
-        Tuning is a two step process.  First we ask the front-end to
-        tune as close to the desired frequency as it can.  Then we use
-        the result of that operation and our target_frequency to
-        determine the value for the digital up converter.
-        """
-        return self.u.set_center_freq(target_freq)
-        
     def bitrate(self):
         return self._bitrate
 
     def samples_per_symbol(self):
         return self._samples_per_symbol
 
-    def decim(self):
-        return self._decim
-
     def carrier_sensed(self):
         """
         Return True if we think carrier is present.
@@ -168,49 +110,31 @@ class receive_path(gr.hier_block2):
         """
         self.probe.set_threshold(threshold_in_db)
     
-    @staticmethod
+        
     def add_options(normal, expert):
         """
         Adds receiver-specific options to the Options Parser
         """
-        add_freq_option(normal)
         if not normal.has_option("--bitrate"):
-            normal.add_option("-r", "--bitrate", type="eng_float", default=None,
-                              help="specify bitrate.  samples-per-symbol and interp/decim will be derived.")
-        usrp_options.add_rx_options(normal)
+            normal.add_option("-r", "--bitrate", type="eng_float", default=100e3,
+                              help="specify bitrate [default=%default].")
+        normal.add_option("", "--show-rx-gain-range", action="store_true", default=False, 
+                          help="print min and max Rx gain available on selected daughterboard")
         normal.add_option("-v", "--verbose", action="store_true", default=False)
-        expert.add_option("-S", "--samples-per-symbol", type="int", default=None,
+        expert.add_option("-S", "--samples-per-symbol", type="int", default=2,
                           help="set samples/symbol [default=%default]")
-        expert.add_option("", "--rx-freq", type="eng_float", default=None,
-                          help="set Rx frequency to FREQ [default=%default]", metavar="FREQ")
         expert.add_option("", "--log", action="store_true", default=False,
                           help="Log all parts of flow graph to files (CAUTION: lots of data)")
-        expert.add_option("", "--log-rx-power", action="store_true", default=False,
-                          help="Log receive signal power to file (CAUTION: lots of data)")
+
+    # Make a static method to call before instantiation
+    add_options = staticmethod(add_options)
+
 
     def _print_verbage(self):
         """
         Prints information about the receive path
         """
         print "\nReceive Path:"
-        print "USRP %s"    % (self.u,)
-        print "Rx gain:         %g"    % (self.u.gain(),)
         print "modulation:      %s"    % (self._demod_class.__name__)
         print "bitrate:         %sb/s" % (eng_notation.num_to_str(self._bitrate))
         print "samples/symbol:  %3d"   % (self._samples_per_symbol)
-        print "decim:           %3d"   % (self._decim)
-        print "Rx Frequency:    %s"    % (eng_notation.num_to_str(self._rx_freq))
-
-def add_freq_option(parser):
-    """
-    Hackery that has the -f / --freq option set both tx_freq and rx_freq
-    """
-    def freq_callback(option, opt_str, value, parser):
-        parser.values.rx_freq = value
-        parser.values.tx_freq = value
-
-    if not parser.has_option('--freq'):
-        parser.add_option('-f', '--freq', type="eng_float",
-                          action="callback", callback=freq_callback,
-                          help="set Tx and/or Rx frequency to FREQ [default=%default]",
-                          metavar="FREQ")
diff --git a/gnuradio-examples/python/digital/receive_path_lb.py b/gnuradio-examples/python/digital/receive_path_lb.py
deleted file mode 100644 (file)
index a6bffee..0000000
+++ /dev/null
@@ -1,140 +0,0 @@
-#!/usr/bin/env python
-#
-# Copyright 2005,2006,2007 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-from gnuradio import gr, gru, blks2
-from gnuradio import eng_notation
-import copy
-import sys
-
-# /////////////////////////////////////////////////////////////////////////////
-#                              receive path
-# /////////////////////////////////////////////////////////////////////////////
-
-class receive_path(gr.hier_block2):
-    def __init__(self, demod_class, rx_callback, options):
-       gr.hier_block2.__init__(self, "receive_path",
-                               gr.io_signature(1, 1, gr.sizeof_gr_complex), # Input signature
-                               gr.io_signature(0, 0, 0))                    # Output signature
-
-        
-        options = copy.copy(options)    # make a copy so we can destructively modify
-
-        self._verbose            = options.verbose
-        self._bitrate            = options.bitrate         # desired bit rate
-        self._samples_per_symbol = options.samples_per_symbol  # desired samples/symbol
-
-        self._rx_callback   = rx_callback      # this callback is fired when there's a packet available
-        self._demod_class   = demod_class      # the demodulator_class we're using
-
-        # Get demod_kwargs
-        demod_kwargs = self._demod_class.extract_kwargs_from_options(options)
-
-        # Design filter to get actual channel we want
-        sw_decim = 1
-        chan_coeffs = gr.firdes.low_pass (1.0,                  # gain
-                                          sw_decim * self._samples_per_symbol, # sampling rate
-                                          1.0,                  # midpoint of trans. band
-                                          0.5,                  # width of trans. band
-                                          gr.firdes.WIN_HANN)   # filter type
-        self.channel_filter = gr.fft_filter_ccc(sw_decim, chan_coeffs)
-        
-        # receiver
-        self.packet_receiver = \
-            blks2.demod_pkts(self._demod_class(**demod_kwargs),
-                             access_code=None,
-                             callback=self._rx_callback,
-                             threshold=-1)
-
-        # Carrier Sensing Blocks
-        alpha = 0.001
-        thresh = 30   # in dB, will have to adjust
-        self.probe = gr.probe_avg_mag_sqrd_c(thresh,alpha)
-
-        # Display some information about the setup
-        if self._verbose:
-            self._print_verbage()
-
-       # connect block input to channel filter
-       self.connect(self, self.channel_filter)
-
-        # connect the channel input filter to the carrier power detector
-        self.connect(self.channel_filter, self.probe)
-
-        # connect channel filter to the packet receiver
-        self.connect(self.channel_filter, self.packet_receiver)
-
-    def bitrate(self):
-        return self._bitrate
-
-    def samples_per_symbol(self):
-        return self._samples_per_symbol
-
-    def carrier_sensed(self):
-        """
-        Return True if we think carrier is present.
-        """
-        #return self.probe.level() > X
-        return self.probe.unmuted()
-
-    def carrier_threshold(self):
-        """
-        Return current setting in dB.
-        """
-        return self.probe.threshold()
-
-    def set_carrier_threshold(self, threshold_in_db):
-        """
-        Set carrier threshold.
-
-        @param threshold_in_db: set detection threshold
-        @type threshold_in_db:  float (dB)
-        """
-        self.probe.set_threshold(threshold_in_db)
-    
-        
-    def add_options(normal, expert):
-        """
-        Adds receiver-specific options to the Options Parser
-        """
-        if not normal.has_option("--bitrate"):
-            normal.add_option("-r", "--bitrate", type="eng_float", default=100e3,
-                              help="specify bitrate [default=%default].")
-        normal.add_option("", "--show-rx-gain-range", action="store_true", default=False, 
-                          help="print min and max Rx gain available on selected daughterboard")
-        normal.add_option("-v", "--verbose", action="store_true", default=False)
-        expert.add_option("-S", "--samples-per-symbol", type="int", default=2,
-                          help="set samples/symbol [default=%default]")
-        expert.add_option("", "--log", action="store_true", default=False,
-                          help="Log all parts of flow graph to files (CAUTION: lots of data)")
-
-    # Make a static method to call before instantiation
-    add_options = staticmethod(add_options)
-
-
-    def _print_verbage(self):
-        """
-        Prints information about the receive path
-        """
-        print "\nReceive Path:"
-        print "modulation:      %s"    % (self._demod_class.__name__)
-        print "bitrate:         %sb/s" % (eng_notation.num_to_str(self._bitrate))
-        print "samples/symbol:  %3d"   % (self._samples_per_symbol)
index 2819e87f483c91ce6696fb20242ec286722ef33e..11d37026940f23c50bd43b28ff210a02695903a2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2005,2006,2007,2009 Free Software Foundation, Inc.
+# Copyright 2005, 2006, 2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # 
 
 from gnuradio import gr, gru, blks2
-from gnuradio import usrp
 from gnuradio import eng_notation
 
 import copy
 import sys
 
-# from current dir
-from pick_bitrate import pick_tx_bitrate
-import usrp_options
-
 # /////////////////////////////////////////////////////////////////////////////
 #                              transmit path
 # /////////////////////////////////////////////////////////////////////////////
 
-class transmit_path(gr.hier_block2): 
+class transmit_path(gr.hier_block2):
     def __init__(self, modulator_class, options):
         '''
         See below for what options should hold
         '''
        gr.hier_block2.__init__(self, "transmit_path",
-                                gr.io_signature(0, 0, 0), # Input signature
-                                gr.io_signature(0, 0, 0)) # Output signature
-
+                               gr.io_signature(0, 0, 0),                    # Input signature
+                               gr.io_signature(1, 1, gr.sizeof_gr_complex)) # Output signature
+        
         options = copy.copy(options)    # make a copy so we can destructively modify
 
         self._verbose            = options.verbose
-        self._tx_freq            = options.tx_freq         # tranmitter's center frequency
         self._tx_amplitude       = options.tx_amplitude    # digital amplitude sent to USRP
         self._bitrate            = options.bitrate         # desired bit rate
-        self._interp             = options.interp          # interpolating rate for the USRP (prelim)
         self._samples_per_symbol = options.samples_per_symbol  # desired samples/baud
-        self._use_whitener_offset = options.use_whitener_offset # increment start of whitener XOR data
-        
-        self._modulator_class = modulator_class         # the modulator_class we are using
-    
-        if self._tx_freq is None:
-            sys.stderr.write("-f FREQ or --freq FREQ or --tx-freq FREQ must be specified\n")
-            raise SystemExit
-
-        # Set up USRP sink; also adjusts interp, samples_per_symbol, and bitrate
-        self._setup_usrp_sink(options)
 
-        # copy the final answers back into options for use by modulator
-        options.samples_per_symbol = self._samples_per_symbol
-        options.bitrate = self._bitrate
-        options.interp = self._interp
+        self._modulator_class = modulator_class         # the modulator_class we are using
 
         # Get mod_kwargs
         mod_kwargs = self._modulator_class.extract_kwargs_from_options(options)
-
-        # Set center frequency of USRP
-        ok = self.set_freq(self._tx_freq)
-        if not ok:
-            print "Failed to set Tx frequency to %s" % (eng_notation.num_to_str(self._tx_freq),)
-            raise ValueError
     
         # transmitter
+       modulator = self._modulator_class(**mod_kwargs)
         self.packet_transmitter = \
-            blks2.mod_pkts(self._modulator_class(**mod_kwargs),
+            blks2.mod_pkts(modulator,
                            access_code=None,
                            msgq_limit=4,
-                           pad_for_usrp=True,
-                           use_whitener_offset=options.use_whitener_offset)
-
-
-        # Set the USRP for maximum transmit gain
-        # (Note that on the RFX cards this is a nop.)
-        #self.set_gain(self.u.gain_range()[1])
+                           pad_for_usrp=True)
 
         self.amp = gr.multiply_const_cc(1)
         self.set_tx_amplitude(self._tx_amplitude)
@@ -96,47 +65,17 @@ class transmit_path(gr.hier_block2):
         if self._verbose:
             self._print_verbage()
 
-        # Create and setup transmit path flow graph
-        self.connect(self.packet_transmitter, self.amp, self.u)
-
-    def _setup_usrp_sink(self, options):
-        """
-        Creates a USRP sink, determines the settings for best bitrate,
-        and attaches to the transmitter's subdevice.
-        """
-        self.u = usrp_options.create_usrp_sink(options)
-        dac_rate = self.u.dac_rate();
-
-        # derive values of bitrate, samples_per_symbol, and interp from desired info
-        (self._bitrate, self._samples_per_symbol, self._interp) = \
-            pick_tx_bitrate(self._bitrate, self._modulator_class.bits_per_symbol(),
-                            self._samples_per_symbol, self._interp, dac_rate, self.u.get_interp_rates())
-        
-        self.u.set_interp(self._interp)
-
-
-    def set_freq(self, target_freq):
-        """
-        Set the center frequency we're interested in.
-
-        @param target_freq: frequency in Hz
-        @rypte: bool
-
-        Tuning is a two step process.  First we ask the front-end to
-        tune as close to the desired frequency as it can.  Then we use
-        the result of that operation and our target_frequency to
-        determine the value for the digital up converter.
-        """
-        return self.u.set_center_freq(target_freq)
+        # Connect components in the flowgraph
+        self.connect(self.packet_transmitter, self.amp, self)
 
     def set_tx_amplitude(self, ampl):
         """
         Sets the transmit amplitude sent to the USRP
-        @param ampl the amplitude between 0.0 and 1.0
+        @param: ampl 0 <= ampl < 32768.  Try 8000
         """
-        self._tx_amplitude = max(0.0, min(ampl, 1.0))
+        self._tx_amplitude = max(0.0, min(ampl, 32767.0))
         self.amp.set_k(self._tx_amplitude)
-
+        
     def send_pkt(self, payload='', eof=False):
         """
         Calls the transmitter method to send a packet
@@ -149,29 +88,21 @@ class transmit_path(gr.hier_block2):
     def samples_per_symbol(self):
         return self._samples_per_symbol
 
-    def interp(self):
-        return self._interp
-
     def add_options(normal, expert):
         """
         Adds transmitter-specific options to the Options Parser
         """
-        add_freq_option(normal)
         if not normal.has_option('--bitrate'):
-            normal.add_option("-r", "--bitrate", type="eng_float", default=None,
-                              help="specify bitrate.  samples-per-symbol and interp/decim will be derived.")
-        usrp_options.add_tx_options(normal)
-        normal.add_option("--tx-amplitude", type="eng_float", default=0.15, metavar="AMPL",
-                          help="set transmitter digital amplitude (0.0-1.0) [default=%default].")
+            normal.add_option("-r", "--bitrate", type="eng_float", default=100e3,
+                              help="specify bitrate [default=%default].")
+        normal.add_option("", "--tx-amplitude", type="eng_float", default=12000, metavar="AMPL",
+                          help="set transmitter digital amplitude: 0 <= AMPL < 32768 [default=%default]")
         normal.add_option("-v", "--verbose", action="store_true", default=False)
-        expert.add_option("-S", "--samples-per-symbol", type="int", default=None,
+
+        expert.add_option("-S", "--samples-per-symbol", type="int", default=2,
                           help="set samples/symbol [default=%default]")
-        expert.add_option("", "--tx-freq", type="eng_float", default=None,
-                          help="set transmit frequency to FREQ [default=%default]", metavar="FREQ")
         expert.add_option("", "--log", action="store_true", default=False,
                           help="Log all parts of flow graph to file (CAUTION: lots of data)")
-        expert.add_option("","--use-whitener-offset", action="store_true", default=False,
-                          help="make sequential packets use different whitening")
 
     # Make a static method to call before instantiation
     add_options = staticmethod(add_options)
@@ -180,25 +111,8 @@ class transmit_path(gr.hier_block2):
         """
         Prints information about the transmit path
         """
-        print "Using TX d'board %s"    % (self.u,)
         print "Tx amplitude     %s"    % (self._tx_amplitude)
         print "modulation:      %s"    % (self._modulator_class.__name__)
         print "bitrate:         %sb/s" % (eng_notation.num_to_str(self._bitrate))
         print "samples/symbol:  %3d"   % (self._samples_per_symbol)
-        print "interp:          %3d"   % (self._interp)
-        print "Tx Frequency:    %s"    % (eng_notation.num_to_str(self._tx_freq))
         
-
-def add_freq_option(parser):
-    """
-    Hackery that has the -f / --freq option set both tx_freq and rx_freq
-    """
-    def freq_callback(option, opt_str, value, parser):
-        parser.values.rx_freq = value
-        parser.values.tx_freq = value
-
-    if not parser.has_option('--freq'):
-        parser.add_option('-f', '--freq', type="eng_float",
-                          action="callback", callback=freq_callback,
-                          help="set Tx and/or Rx frequency to FREQ [default=%default]",
-                          metavar="FREQ")
diff --git a/gnuradio-examples/python/digital/transmit_path_lb.py b/gnuradio-examples/python/digital/transmit_path_lb.py
deleted file mode 100644 (file)
index 11d3702..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-#
-# Copyright 2005, 2006, 2007 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-from gnuradio import gr, gru, blks2
-from gnuradio import eng_notation
-
-import copy
-import sys
-
-# /////////////////////////////////////////////////////////////////////////////
-#                              transmit path
-# /////////////////////////////////////////////////////////////////////////////
-
-class transmit_path(gr.hier_block2):
-    def __init__(self, modulator_class, options):
-        '''
-        See below for what options should hold
-        '''
-       gr.hier_block2.__init__(self, "transmit_path",
-                               gr.io_signature(0, 0, 0),                    # Input signature
-                               gr.io_signature(1, 1, gr.sizeof_gr_complex)) # Output signature
-        
-        options = copy.copy(options)    # make a copy so we can destructively modify
-
-        self._verbose            = options.verbose
-        self._tx_amplitude       = options.tx_amplitude    # digital amplitude sent to USRP
-        self._bitrate            = options.bitrate         # desired bit rate
-        self._samples_per_symbol = options.samples_per_symbol  # desired samples/baud
-
-        self._modulator_class = modulator_class         # the modulator_class we are using
-
-        # Get mod_kwargs
-        mod_kwargs = self._modulator_class.extract_kwargs_from_options(options)
-    
-        # transmitter
-       modulator = self._modulator_class(**mod_kwargs)
-        self.packet_transmitter = \
-            blks2.mod_pkts(modulator,
-                           access_code=None,
-                           msgq_limit=4,
-                           pad_for_usrp=True)
-
-        self.amp = gr.multiply_const_cc(1)
-        self.set_tx_amplitude(self._tx_amplitude)
-
-        # Display some information about the setup
-        if self._verbose:
-            self._print_verbage()
-
-        # Connect components in the flowgraph
-        self.connect(self.packet_transmitter, self.amp, self)
-
-    def set_tx_amplitude(self, ampl):
-        """
-        Sets the transmit amplitude sent to the USRP
-        @param: ampl 0 <= ampl < 32768.  Try 8000
-        """
-        self._tx_amplitude = max(0.0, min(ampl, 32767.0))
-        self.amp.set_k(self._tx_amplitude)
-        
-    def send_pkt(self, payload='', eof=False):
-        """
-        Calls the transmitter method to send a packet
-        """
-        return self.packet_transmitter.send_pkt(payload, eof)
-        
-    def bitrate(self):
-        return self._bitrate
-
-    def samples_per_symbol(self):
-        return self._samples_per_symbol
-
-    def add_options(normal, expert):
-        """
-        Adds transmitter-specific options to the Options Parser
-        """
-        if not normal.has_option('--bitrate'):
-            normal.add_option("-r", "--bitrate", type="eng_float", default=100e3,
-                              help="specify bitrate [default=%default].")
-        normal.add_option("", "--tx-amplitude", type="eng_float", default=12000, metavar="AMPL",
-                          help="set transmitter digital amplitude: 0 <= AMPL < 32768 [default=%default]")
-        normal.add_option("-v", "--verbose", action="store_true", default=False)
-
-        expert.add_option("-S", "--samples-per-symbol", type="int", default=2,
-                          help="set samples/symbol [default=%default]")
-        expert.add_option("", "--log", action="store_true", default=False,
-                          help="Log all parts of flow graph to file (CAUTION: lots of data)")
-
-    # Make a static method to call before instantiation
-    add_options = staticmethod(add_options)
-
-    def _print_verbage(self):
-        """
-        Prints information about the transmit path
-        """
-        print "Tx amplitude     %s"    % (self._tx_amplitude)
-        print "modulation:      %s"    % (self._modulator_class.__name__)
-        print "bitrate:         %sb/s" % (eng_notation.num_to_str(self._bitrate))
-        print "samples/symbol:  %3d"   % (self._samples_per_symbol)
-