get all the docs in the sudo-ldap package into one directory, not two!
authorBdale Garbee <bdale@gag.com>
Tue, 7 Sep 2010 18:16:00 +0000 (12:16 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 7 Sep 2010 18:16:00 +0000 (12:16 -0600)
debian/rules

index 19362dec7aaab58bfcf01d826f68e81c82035c6b..2cfefa971a1188677d24c860c54ec04211e9ba49 100755 (executable)
@@ -98,6 +98,11 @@ install: build-stamp
                debian/sudo/usr/share/doc/sudo/LICENSE* \
                debian/sudo-ldap/usr/share/doc/sudo/LICENSE*
 
+       # move upstream-installed docs to the right place for ldap package
+       mv      debian/sudo-ldap/usr/share/doc/sudo/* \
+               debian/sudo-ldap/usr/share/doc/sudo-ldap/
+       rmdir   debian/sudo-ldap/usr/share/doc/sudo
+
        # and install things we do want that make install doesn't know about
        install -o root -g root -m 0644 debian/sudo.pam \
                debian/sudo/etc/pam.d/sudo