* doc/gzip.texi (Overview): Mention limits of gzip format's
authorPaul Eggert <eggert@cs.ucla.edu>
Sat, 2 Dec 2006 06:13:03 +0000 (06:13 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Sat, 2 Dec 2006 06:13:03 +0000 (06:13 +0000)
time stamps.  Also, gzip doesn't always preserve time stamps.

any more (the hosts it caters to are long extinct), and was
questionable anyway since the code assumes the skip= line was line 2.

ChangeLog
doc/gzip.texi

index b6d0620df22a57d7b5ad4d17bfe3985426f4ac02..8bf7830402dbd912a8ff962d6edd31dca51ef80b 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,13 +1,16 @@
 2006-12-01  Paul Eggert  <eggert@cs.ucla.edu>
 
+       * doc/gzip.texi (Overview): Mention limits of gzip format's
+       time stamps.  Also, gzip doesn't always preserve time stamps.
+
        * gzip.c (abort_gzip_signal): Don't call abort () as a "safeguard",
        since it actually causes a core dump.  Problem reported by
        Jakub Bogusz.
 
        * NEWS: Describe gzexe changes noted below.
        * Makefile.am (.in): Don't bother with SEDCMD.  This stuff isn't needed
-       any more (the hosts it caters to are long extinct), and was questionable
-       anyway since the code assumes the skip= line was line 2.
+       any more (the hosts it caters to are long extinct), and was
+       questionable anyway since the code assumes the skip= line was line 2.
        * configure.ac (AC_SYS_INTERPRETER, SEDCMD): Remove; no longer needed.
 
        * gzexe.in: Sweep the code and fix some bugs.
index 2e46c023a56ed89358c03728e939f7e5d8c9b366..fd782aa8e864008d0ef8f0844beace4e926439e6 100644 (file)
@@ -96,7 +96,13 @@ By default, @code{gzip} keeps the original file name and timestamp in
 the compressed file. These are used when decompressing the file with the
 @samp{-N} option. This is useful when the compressed file name was
 truncated or when the time stamp was not preserved after a file
-transfer.
+transfer.  However, due to limitations in the current @code{gzip} file
+format, fractional seconds are discarded.  Also, time stamps must fall
+within the range 1970-01-01 00:00:00 through 2106-02-07 06:28:15
+@acronym{UTC}, and hosts whose operating systems use 32-bit time
+stamps are further restricted to time stamps no later than 2038-01-19
+03:14:07 @acronym{UTC}.  The upper bounds assume the typical case
+where leap seconds are ignored.
 
 Compressed files can be restored to their original form using @samp{gzip -d}
 or @code{gunzip} or @code{zcat}.  If the original name saved in the
@@ -153,8 +159,8 @@ Compression is always performed, even if the compressed file is slightly
 larger than the original. The worst case expansion is a few bytes for
 the @code{gzip} file header, plus 5 bytes every 32K block, or an expansion
 ratio of 0.015% for large files. Note that the actual number of used
-disk blocks almost never increases. @code{gzip} preserves the mode,
-ownership and timestamps of files when compressing or decompressing.
+disk blocks almost never increases.  @code{gzip} normally preserves the mode,
+ownership and time stamps of files when compressing or decompressing.
 
 The @code{gzip} file format is specified in P. Deutsch, @sc{gzip} file
 format specification version 4.3,