Added noise example using LFSR.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 23 Feb 2007 19:10:22 +0000 (19:10 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 23 Feb 2007 19:10:22 +0000 (19:10 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4615 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-examples/python/audio/Makefile.am
gnuradio-examples/python/audio/noise.py [new file with mode: 0755]

index 0a1213c340214a69737d30d938eb079b6814901c..28a1bc6c51c63914b9ec23627fa2bff9e5ecf9a2 100644 (file)
@@ -29,5 +29,6 @@ EXTRA_DIST =                  \
        dialtone_v.py           \
        mono_tone.py            \
        multi_tone.py           \
+       noise.py                \
        spectrum_inversion.py   \
        test_resampler.py       
diff --git a/gnuradio-examples/python/audio/noise.py b/gnuradio-examples/python/audio/noise.py
new file mode 100755 (executable)
index 0000000..73694f3
--- /dev/null
@@ -0,0 +1,55 @@
+#!/usr/bin/env python
+#
+# Copyright 2007 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+from gnuradio import gr
+from gnuradio import audio
+from gnuradio.eng_option import eng_option
+from optparse import OptionParser
+
+class my_graph(gr.flow_graph):
+
+    def __init__(self):
+        gr.flow_graph.__init__(self)
+
+        parser = OptionParser(option_class=eng_option)
+        parser.add_option("-O", "--audio-output", type="string", default="",
+                          help="pcm output device name.  E.g., hw:0,0 or /dev/dsp")
+        parser.add_option("-r", "--sample-rate", type="eng_float", default=48000,
+                          help="set sample rate to RATE (48000)")
+        (options, args) = parser.parse_args ()
+        if len(args) != 0:
+            parser.print_help()
+            raise SystemExit, 1
+
+        sample_rate = int(options.sample_rate)
+        ampl = 0.1
+
+        src = gr.glfsr_source_b(32)     # Pseudorandom noise source
+        b2f = gr.chunks_to_symbols_bf([ampl, -ampl], 1)
+        dst = audio.sink(sample_rate, options.audio_output)
+        self.connect(src, b2f, dst)
+
+if __name__ == '__main__':
+    try:
+        my_graph().run()
+    except KeyboardInterrupt:
+        pass