build: unlzw.c: avoid warnings about unused macros
authorJim Meyering <meyering@redhat.com>
Fri, 20 Nov 2009 18:34:46 +0000 (19:34 +0100)
committerJim Meyering <meyering@redhat.com>
Fri, 20 Nov 2009 18:34:46 +0000 (19:34 +0100)
* configure.ac: Turn off -Wunused-macros.

configure.ac

index d87c5f3901149daa1f81fea5ea724496ff971723..6442ab64307a60919d2b5dcb648a27082bd1b857 100644 (file)
@@ -90,6 +90,7 @@ if test "$gl_gcc_warnings" = yes; then
   # initial problems in gzip
   nw="$nw -Wold-style-definition"
   nw="$nw -Wshadow"
+  nw="$nw -Wunused-macros"
   # ?? -Wstrict-overflow
 
   gl_MANYWARN_ALL_GCC([ws])
@@ -120,7 +121,6 @@ if test "$gl_gcc_warnings" = yes; then
   # Remove the following and save the result in GNULIB_WARN_CFLAGS.
   nw=
   nw="$nw -Wuninitialized"
-  nw="$nw -Wunused-macros"
   nw="$nw -Wmissing-prototypes"
   nw="$nw -Wold-style-definition"
   gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])