maint: remove crypt.[ch] stubs
authorJim Meyering <meyering@redhat.com>
Mon, 9 May 2011 07:54:16 +0000 (09:54 +0200)
committerJim Meyering <meyering@redhat.com>
Mon, 9 May 2011 08:11:25 +0000 (10:11 +0200)
* Makefile.am (gzip_SOURCES): Remove crypt.c
(EXTRA_DIST): Remove crypt.h
* crypt.c, crypt.h: Remove files.
* unpack.c: Don't #include "crypt.h"
* zip.c: Likewise
* util.c: Likewise.
* unzip.c: Likewise.

Makefile.am
crypt.c [deleted file]
crypt.h [deleted file]
unpack.c
unzip.c
util.c
zip.c

index b93403d459f2abb5e3e03f464f7848dda8458434..c035410c7c71db141b4eaaff1e28f4b668cfc31a 100644 (file)
@@ -40,7 +40,7 @@ EXTRA_DIST = $(ACINCLUDE_INPUTS) $(man_MANS) \
   cfg.mk       \
   dist-check.mk        \
   algorithm.doc amiga/match.a amiga/Makefile.gcc amiga/Makefile.sasc \
-  amiga/tailor.c amiga/utime.h atari/Makefile.st crypt.h \
+  amiga/tailor.c amiga/utime.h atari/Makefile.st \
   gunzip.in gzexe.in gzip.doc msdos/match.asm msdos/tailor.c \
   msdos/gzip.prj msdos/doturboc.bat msdos/Makefile.msc msdos/Makefile.bor \
   msdos/Makefile.djg nt/Makefile.nt os2/gzip.def os2/Makefile.os2 \
@@ -56,7 +56,7 @@ bin_PROGRAMS = gzip
 bin_SCRIPTS = gunzip gzexe zcat zcmp zdiff \
   zegrep zfgrep zforce zgrep zless zmore znew
 gzip_SOURCES = \
-  bits.c crypt.c deflate.c gzip.c inflate.c lzw.c \
+  bits.c deflate.c gzip.c inflate.c lzw.c \
   trees.c unlzh.c unlzw.c unpack.c unzip.c util.c zip.c
 gzip_LDADD = libver.a lib/libgzip.a
 gzip_LDADD += $(LIB_CLOCK_GETTIME)
diff --git a/crypt.c b/crypt.c
deleted file mode 100644 (file)
index ff14a7b..0000000
--- a/crypt.c
+++ /dev/null
@@ -1,5 +0,0 @@
-/* crypt.c (dummy version) -- do not perform encryption
- * Hardly worth copyrighting :-)
- */
-#include <config.h>
-typedef int dummy;
diff --git a/crypt.h b/crypt.h
deleted file mode 100644 (file)
index 2a4c203..0000000
--- a/crypt.h
+++ /dev/null
@@ -1,12 +0,0 @@
-/* crypt.h (dummy version) -- do not perform encryption
- * Hardly worth copyrighting :-)
- */
-
-#ifdef CRYPT
-#  undef CRYPT      /* dummy version */
-#endif
-
-#define RAND_HEAD_LEN  12  /* length of encryption random header */
-
-#define zencode
-#define zdecode
index 276e925907757f04e40d5c8552e24e206306a293..947d7a59d8dfdce1f74bb6dd746c5dbd916cd266 100644 (file)
--- a/unpack.c
+++ b/unpack.c
@@ -20,7 +20,6 @@
 #include <config.h>
 #include "tailor.h"
 #include "gzip.h"
-#include "crypt.h"
 
 #define MIN(a,b) ((a) <= (b) ? (a) : (b))
 /* The arguments must not have side effects. */
diff --git a/unzip.c b/unzip.c
index c481a896ef32ba792eb017fc3360847330c684ba..302194cb7ef5b619a10c19c1c92f0d8cac66a017 100644 (file)
--- a/unzip.c
+++ b/unzip.c
@@ -31,7 +31,6 @@
 #include <config.h>
 #include "tailor.h"
 #include "gzip.h"
-#include "crypt.h"
 
 /* PKZIP header definitions */
 #define LOCSIG 0x04034b50L      /* four-byte lead-in (lsb first) */
diff --git a/util.c b/util.c
index 12e37c0c82512cfd89170050a05c67c0f821e522..58e00928bbf39a06a55137d70ba0e23d9e5fa9f3 100644 (file)
--- a/util.c
+++ b/util.c
@@ -31,7 +31,6 @@
 #include <errno.h>
 
 #include "gzip.h"
-#include "crypt.h"
 #include <xalloc.h>
 
 #ifndef CHAR_BIT
diff --git a/zip.c b/zip.c
index b205cd99092e78e90d5e8619a439f9f3d0b4073a..28f737228b2f58ee13aa372be2ab7bd27ace4aff 100644 (file)
--- a/zip.c
+++ b/zip.c
@@ -22,7 +22,6 @@
 
 #include "tailor.h"
 #include "gzip.h"
-#include "crypt.h"
 
 #include <unistd.h>
 #include <fcntl.h>