Merged r6285:6297 from features/deb into trunk. Nearing completion on Debian packagi...
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 4 Sep 2007 21:28:57 +0000 (21:28 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 4 Sep 2007 21:28:57 +0000 (21:28 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6299 221aa14e-8319-0410-a670-987f0aec2ac5

15 files changed:
config/grc_gnuradio_core.m4
debian/build-all.sh
debian/control
debian/gen-install-files.sh
debian/gnuradio-radar-mono-firmware.install [new file with mode: 0644]
debian/gnuradio-sounder-firmware.install [new file with mode: 0644]
debian/rules
gnuradio-core/src/python/gnuradio/Makefile.am
gnuradio-core/src/python/gnuradio/vocoder/Makefile.am [new file with mode: 0644]
gnuradio-core/src/python/gnuradio/vocoder/__init__.py [new file with mode: 0644]
gr-cvsd-vocoder/src/lib/Makefile.am
gr-cvsd-vocoder/src/lib/__init__.py [deleted file]
gr-gsm-fr-vocoder/src/lib/Makefile.am
gr-gsm-fr-vocoder/src/lib/__init__.py [deleted file]
gr-pager/src/Makefile.am

index af83cb6a57850572cb89a42ce73d282b21f91b75..c4774413e7d620eb4045f8377b2ce23142a75873 100644 (file)
@@ -51,6 +51,7 @@ AC_DEFUN([GRC_GNURADIO_CORE],[
         gnuradio-core/src/python/gnuradio/gr/run_tests \
         gnuradio-core/src/python/gnuradio/gru/Makefile \
         gnuradio-core/src/python/gnuradio/gruimpl/Makefile \
+       gnuradio-core/src/python/gnuradio/vocoder/Makefile \
         gnuradio-core/src/tests/Makefile \
         gnuradio-core/src/utils/Makefile \
     ])
index 5e0c26937132c9d0d94ce4ffbf39f1bff23a088b..0b3ec2460b6844376504708e4894e6bcc774eb62 100755 (executable)
@@ -7,4 +7,6 @@ svn-buildpackage \
     -us \
     -rfakeroot
 
+cd ../build-area
+dpkg-scanpackages . /dev/null | gzip -9c > Packages.gz
 
index 3c3568eb33c15e99fc08c40be4be44564450494a..a38fcd3f97c16c9e521dd355e2d569116d24da1f 100644 (file)
@@ -90,8 +90,6 @@ Description: Software Defined Radio
 Package: python-gnuradio-core
 Architecture: any
 Depends: ${python:Depends}, libgnuradio-core0c2a, python-numpy
-Conflicts: python-gnuradio 
-Replaces: python-gnuradio
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -103,6 +101,7 @@ Package: python-gnuradio-audio-alsa
 Architecture: any
 Depends: ${python:Depends}, python-gnuradio-core, libasound2
 Section: python
+Provides: python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
 Description: Python bindings for GNU Radio ALSA audio driver
  This package provides the Python interface to the GNU Radio ALSA
@@ -115,6 +114,7 @@ Depends: libusb-0.1-4
 Conflicts: libusrp0
 Replaces: libusrp0
 Suggests: usrp-doc
+Recommends: usrp-firmware
 Description: Client side library for the USRP
  The Universal Software Radio Peripheral (USRP) is an USB-connected,
  low-cost and open board. It features four high-speed analog-to-digital
@@ -224,6 +224,7 @@ Package: python-gnuradio-audio-jack
 Architecture: any
 Depends: ${python:Depends}, python-gnuradio-core, libjack0.100.0-0
 Section: python
+Provides: python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
 Description: GNU Radio Python JACK Audio Driver
  This package provides the Python interface to the GNU Radio driver
@@ -233,6 +234,7 @@ Package: python-gnuradio-audio-oss
 Architecture: any
 Depends: ${python:Depends}, python-gnuradio-core
 Section: python
+Provides: python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
 Description: GNU Radio Python OSS Audio Driver
  This package provides the Python interface to the GNU Radio driver
@@ -242,6 +244,7 @@ Package: python-gnuradio-audio-portaudio
 Architecture: any
 Depends: ${python:Depends}, python-gnuradio-core, libportaudio2
 Section: python
+Provides: python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
 Description: GNU Radio Python PortAudio Driver
  This package provides the Python interface to the GNU Radio driver
@@ -288,6 +291,108 @@ Architecture: any
 Depends: ${python:Depends}, python-gnuradio-core, libsdl1.2debian
 Section: python
 XB-Python-Version: ${python:Versions}
+Description: GNU SDL Interface Library
+ This package provides an interface to the SDL rendering library
+ for GNU Radio.
+
+Package: python-gnuradio-utils
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-usrp, python-gnuradio-wxgui
+Section: python
+XB-Python-Version: ${python:Versions}
 Description: GNU Radio Trellis-Coded Modulation library
- This package provides an implementation of trellis-coded modulation
+ This package provides commonly used utilities for GNU Radio
+
+Package: gnuradio-examples
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp, python-gnuradio-wxgui, python-gnuradio-audio
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Example Programs
+ This package provides examples of GNU Radio usage using Python
+
+Package: gnuradio-pager
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio FLEX Pager Decoder
+ This package provides a decoder for the FLEX paging protocol for GNU Radio
+
+Package: gnuradio-radio-astronomy
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp, python-gnuradio-wxgui
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Radio Astronomy Applications
+ This package provides radio astronomy applications for GNU Radio
+
+Package: gnuradio-radar-mono
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Recommends: gnuradio-radar-mono-firmware
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Mono-static Radar Application
+ This package provides a mono-static radar application for GNU Radio
+
+Package: gnuradio-radar-mono-firmware
+Section: contrib/comm
+Architecture: all
+Description: GNU Radio Mono-static Radar Firmware
+ This package provides a mono-static radar application for GNU Radio
+ .
+ This package contains the FPGA bitstrings for the USRP, which require
+ non-free tools to build.
+
+Package: gnuradio-sounder
+Architecture: any
+Depends: ${python:Depends}, python-gnuradio-core, python-gnuradio-usrp
+Recommends: gnuradio-sounder-firmware
+Section: comm
+XB-Python-Version: ${python:Versions}
+Description: GNU Radio Channel Sounder Application
+ This package provides an RF channel sounder application for GNU Radio
+
+Package: gnuradio-sounder-firmware
+Section: contrib/comm
+Architecture: all
+Description: GNU Radio Channel Sounder Application
+ This package provides an RF channel sounder application for GNU Radio
+ .
+ This package contains the FPGA bitstrings for the USRP, which require
+ non-free tools to build.
+
+Package: python-gnuradio
+Section: python
+Architecture: all
+Depends: python-gnuradio-atsc, python-gnuradio-audio-alsa, python-gnuradio-audio-jack, python-gnuradio-audio-oss, python-gnuradio-audio-portaudio, python-gnuradio-comedi, python-gnuradio-core, python-gnuradio-cvsd-vocoder, python-gnuradio-gsm-fr-vocoder, python-gnuradio-trellis, python-gnuradio-usrp, python-gnuradio-utils, python-gnuradio-video-sdl, python-gnuradio-wxgui
+Description: Python Libraries for GNU Radio Components
+ This is a virtual package that depends upon all the Python components 
  for GNU Radio.
+
+Package: gnuradio
+Section: comm
+Architecture: all
+Depends: gnuradio-doc, gnuradio-examples, python-gnuradio, gnuradio-pager, gnuradio-radar-mono, gnuradio-radio-astronomy, gnuradio-sounder
+Suggests: usrp
+Descripton: GNU Software Defined Radio
+ This is a virtual package that depends the entire GNU Radio collection of
+ components.  If you are using a USRP, you should also install the usrp package.
+
+Package: gnuradio-dev
+Section: libdevel
+Architecture: all
+Depends: libgnuradio-core0-dev, libgnuradio-omnithread0-dev, libmblock0-dev, libpmt0-dev
+Description: Development headers for GNU Radio C++ development
+ This is a virtual package that depends on all the development header packages
+ for the various GNU Radio components.  It is only needed if you intend to develop
+ custom GNU Radio signal processing blocks in C++.
+
+Package: usrp
+Section: comm
+Architecture: all
+Depends: libusrp0c2a, python-usrp, usrp-doc
+Description: The Univeral Software Radio Peripheral
+ This is a virtual package that depends on the entire USRP software collection. You will
+ still need to install package usrp-firmware, in contrib/comm, however.
index 1eaabd213bcb2b7772ed67b4d0776c3e0cbf99a2..b7e9f91a1adbfc525fcde39d2f747babfb1a8868 100755 (executable)
@@ -44,6 +44,7 @@ $EXTRACT gnuradio-core/src/python/gnuradio/blksimpl/Makefile grblkspython_PYTHON
 $EXTRACT gnuradio-core/src/python/gnuradio/blksimpl2/Makefile grblkspython_PYTHON >>$NAME
 $EXTRACT gnuradio-core/src/python/gnuradio/gru/Makefile grblkspython_PYTHON >>$NAME
 $EXTRACT gnuradio-core/src/python/gnuradio/gruimpl/Makefile grupython_PYTHON >>$NAME
+$EXTRACT gnuradio-core/src/python/gnuradio/vocoder/Makefile grvocoderpython_PYTHON >>$NAME
 
 # libusrp0-dev
 NAME=debian/libusrp0-dev.install
@@ -93,6 +94,7 @@ $EXTRACT gr-atsc/src/lib/Makefile ourpython_PYTHON >>$NAME
 $EXTRACT gr-atsc/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
 $EXTRACT gr-atsc/src/lib/Makefile ourlib_LTLIBRARIES | \
     sed -e 's/\.la$/.so/' >>$NAME
+$EXTRACT gr-atsc/src/python/Makefile ourdata_DATA >>$NAME
 
 # python-gnuradio-audio-alsa
 NAME=debian/python-gnuradio-audio-alsa.install
@@ -176,6 +178,8 @@ $EXTRACT gr-trellis/src/lib/Makefile ourpython_PYTHON >>$NAME
 $EXTRACT gr-trellis/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
 $EXTRACT gr-trellis/src/lib/Makefile ourlib_LTLIBRARIES | \
     sed -e 's/\.la$/.so/' >>$NAME
+$EXTRACT gr-trellis/src/examples/Makefile ourdata_DATA >>$NAME
+$EXTRACT gr-trellis/src/examples/fsm_files/Makefile ourdata_DATA >>$NAME
 
 # python-gnuradio-video-sdl
 NAME=debian/python-gnuradio-video-sdl.install
@@ -185,3 +189,59 @@ $EXTRACT gr-video-sdl/src/Makefile ourpython_PYTHON >>$NAME
 $EXTRACT gr-video-sdl/src/Makefile ourlib_LTLIBRARIES >>$NAME
 $EXTRACT gr-video-sdl/src/Makefile ourlib_LTLIBRARIES | \
     sed -e 's/\.la$/.so/' >>$NAME
+
+# python-gnuradio-video-sdl
+NAME=debian/python-gnuradio-utils.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-utils/src/python/Makefile bin_SCRIPTS >>$NAME
+
+# gnuradio-examples
+NAME=debian/gnuradio-examples.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gnuradio-examples/python/apps/hf_explorer/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/apps/hf_radio/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/audio/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/digital/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/digital_voice/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/multi-antenna/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/multi_usrp/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/ofdm/Makefile ourdata_DATA >>$NAME
+$EXTRACT gnuradio-examples/python/usrp/Makefile ourdata_DATA >>$NAME
+
+# gnuradio-pager
+NAME=debian/gnuradio-pager.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-pager/src/Makefile bin_SCRIPTS >>$NAME
+$EXTRACT gr-pager/src/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-pager/src/Makefile ourlib_LTLIBRARIES >>$NAME
+$EXTRACT gr-pager/src/Makefile ourlib_LTLIBRARIES |
+    sed -e 's/\.la$/.so/' >>$NAME
+
+# gnuradio-radio-astronomy
+NAME=debian/gnuradio-radio-astronomy.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile wxguipython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/python/Makefile bin_SCRIPTS >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourlib_LTLIBRARIES >>$NAME
+$EXTRACT gr-radio-astronomy/src/lib/Makefile ourlib_LTLIBRARIES |
+    sed -e 's/\.la$/.so/' >>$NAME
+
+# gnuradio-radar-mono
+NAME=debian/gnuradio-radar-mono.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-radar-mono/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-radar-mono/src/python/Makefile bin_SCRIPTS >>$NAME
+
+# gnuradio-sounder
+NAME=debian/gnuradio-sounder.install
+rm -f $NAME
+touch $NAME
+$EXTRACT gr-sounder/src/python/Makefile ourpython_PYTHON >>$NAME
+$EXTRACT gr-sounder/src/python/Makefile bin_SCRIPTS >>$NAME
diff --git a/debian/gnuradio-radar-mono-firmware.install b/debian/gnuradio-radar-mono-firmware.install
new file mode 100644 (file)
index 0000000..a73ec45
--- /dev/null
@@ -0,0 +1,3 @@
+usr/share/usrp/rev2/usrp_radar_mono.rbf
+usr/share/usrp/rev4/usrp_radar_mono.rbf
+
diff --git a/debian/gnuradio-sounder-firmware.install b/debian/gnuradio-sounder-firmware.install
new file mode 100644 (file)
index 0000000..9c5e731
--- /dev/null
@@ -0,0 +1,3 @@
+usr/share/usrp/rev2/usrp_sounder.rbf
+usr/share/usrp/rev4/usrp_sounder.rbf
+
index cc8b2bfc974f2a1a4ad48d3524530240d15d842e..a0f70f4d7075ecf8c8dc63a34c31221b49d186c9 100755 (executable)
@@ -62,7 +62,7 @@ configure-stamp:
        touch configure-stamp
 
 extract: extract-stamp
-extract-stamp: configure-stamp
+extract-stamp: configure-stamp debian/gen-install-files.sh
        dh_testdir
        debian/gen-install-files.sh 
        touch $@
index d769647be71273863f7d8f2a563af294c17d91de..d9815b52306eded55a900061f6fd12fd1d6ba741 100644 (file)
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-SUBDIRS = gr gru gruimpl blks blksimpl blks2 blksimpl2
+SUBDIRS = gr gru gruimpl blks blksimpl blks2 blksimpl2 vocoder
 
 grpython_PYTHON =                      \
        __init__.py                     \
diff --git a/gnuradio-core/src/python/gnuradio/vocoder/Makefile.am b/gnuradio-core/src/python/gnuradio/vocoder/Makefile.am
new file mode 100644 (file)
index 0000000..69c140c
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright 2004,2007 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+include $(top_srcdir)/Makefile.common
+
+grvocoderpythondir = $(grpythondir)/vocoder
+grvocoderpython_PYTHON = \
+       __init__.py
diff --git a/gnuradio-core/src/python/gnuradio/vocoder/__init__.py b/gnuradio-core/src/python/gnuradio/vocoder/__init__.py
new file mode 100644 (file)
index 0000000..a4917cf
--- /dev/null
@@ -0,0 +1 @@
+# make this a package
index c2c628e47f4c260ab8af6609d9f37de0e40eb88e..f4531afcbd53b95a37636c72311b3db8dbb30864 100644 (file)
@@ -54,7 +54,6 @@ BUILT_SOURCES =                       \
 
 # This gets cvsd_vocoder.py installed in the right place
 ourpython_PYTHON =                     \
-       __init__.py                     \
        cvsd_vocoder.py
 
 ourlib_LTLIBRARIES = _cvsd_vocoder.la
diff --git a/gr-cvsd-vocoder/src/lib/__init__.py b/gr-cvsd-vocoder/src/lib/__init__.py
deleted file mode 100644 (file)
index ccde1f5..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
index 857cd4d9c5090c0dc5c23bfab3d28b0c6cc988e4..254855bce5f95cf7507f65ed5644286e2850aa8c 100644 (file)
@@ -56,7 +56,6 @@ BUILT_SOURCES =                       \
 
 # This gets gsm_full_rate.py installed in the right place
 ourpython_PYTHON =                     \
-       __init__.py                     \
        gsm_full_rate.py
 
 ourlib_LTLIBRARIES = _gsm_full_rate.la
diff --git a/gr-gsm-fr-vocoder/src/lib/__init__.py b/gr-gsm-fr-vocoder/src/lib/__init__.py
deleted file mode 100644 (file)
index ccde1f5..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
index 984a5d70a80259aeb3c3b74aeced992e4b83fac7..fdf30d4c3098a7736fc1925883ab6b74443c489e 100644 (file)
@@ -22,8 +22,9 @@
 include $(top_srcdir)/Makefile.common
 
 EXTRA_DIST = \
-    run_tests.in
-
+    run_tests.in \
+    $(bin_SCRIPTS)
+    
 TESTS = \
     run_tests
 
@@ -65,14 +66,11 @@ BUILT_SOURCES = \
     pager_swig.cc \
     pager_swig.py                              
 
-# This gets pgr.py installed in the right place
+# This gets imported Python objects installed in the right place
 ourpython_PYTHON = \
     __init__.py \
     pager_swig.py \
-    flex_demod.py \
-    usrp_flex.py \
-    usrp_flex_all.py \
-    usrp_flex_band.py
+    flex_demod.py
         
 ourlib_LTLIBRARIES = _pager_swig.la