fix ldap config file path, closes: #430826
authorBdale Garbee <bdale@gag.com>
Wed, 11 Mar 2009 16:51:27 +0000 (10:51 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 11 Mar 2009 16:51:27 +0000 (10:51 -0600)
debian/changelog
debian/postinst
debian/rules

index e0be9d4751f722180720f3e2dab7a90658120404..8530024c0493bec0ea4cc6ae38d28b11ff76f39b 100644 (file)
@@ -1,3 +1,9 @@
+sudo (1.6.9p17-3) unstable; urgency=low
+
+  * fix ldap config file path for sudo-ldap package, closes: #430826
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 11 Mar 2009 10:44:21 -0600
+
 sudo (1.6.9p17-2) unstable; urgency=high
 
   * patch from upstream to fix privilege escalation with certain 
index 2229c83598147e87584f2aabf3385dc76eda2774..b89a8a533ec651bb3797882bd6738aeef8c7c418 100644 (file)
@@ -63,4 +63,10 @@ if ($gid != 27) {
 print "Creating group 'sudo' with gid = $gid\n";
 system("groupadd -g $gid sudo");
 
+# create symlink to ease transition to new path for ldap config
+# if old config file exists and new one doesn't
+if (-e "/etc/ldap/ldap.conf" && ! -e "/etc/sudo-ldap.conf") {
+  system("ln -s ldap/ldap.conf /etc/sudo-ldap.conf");
+}
+
 print "";
index fd9c2b348c3f60862a1355f8d0c37a9815f50209..71c59f6ca2a32910866ad62da7a9dd941fe1bfc0 100755 (executable)
@@ -25,7 +25,6 @@ config-stamp:
                --disable-root-mailer --disable-setresuid \
                --with-sendmail=/usr/sbin/sendmail \
                --mandir=/usr/share/man --libexecdir=/usr/lib/sudo \
-               --with-ldap-conf-file=/etc/sudo-ldap.conf \
                --with-secure-path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"
 
        # LDAP version
@@ -40,7 +39,7 @@ config-stamp:
                --with-passprompt="[sudo] password for %p: " \
                --disable-root-mailer --disable-setresuid \
                --with-sendmail=/usr/sbin/sendmail \
-               --with-ldap-conf-file=/etc/ldap/ldap.conf \
+               --with-ldap-conf-file=/etc/sudo-ldap.conf \
                --mandir=/usr/share/man --libexecdir=/usr/lib/sudo \
                --with-secure-path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"