build: quiet warnings from util.c
authorJim Meyering <meyering@redhat.com>
Sun, 20 Dec 2009 16:40:15 +0000 (17:40 +0100)
committerJim Meyering <meyering@redhat.com>
Wed, 30 Dec 2009 16:33:55 +0000 (17:33 +0100)
* configure.ac (warnings): Add -Wno-overflow and -Wno-type-limits.

configure.ac

index 6442ab64307a60919d2b5dcb648a27082bd1b857..7c9cda3855807f781b46c3b82b0ab33901f26bb4 100644 (file)
@@ -102,6 +102,8 @@ if test "$gl_gcc_warnings" = yes; then
   gl_WARN_ADD([-Wno-sign-compare])     # Too many warnings for now
   gl_WARN_ADD([-Wno-pointer-sign])     # Too many warnings for now
   gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
+  gl_WARN_ADD([-Wno-overflow])         # util.c
+  gl_WARN_ADD([-Wno-type-limits])      # util.c
 
   # In spite of excluding -Wlogical-op above, it is enabled, as of
   # gcc 4.5.0 20090517, and it provokes warnings in cat.c, dd.c, truncate.c