Created skeleton wxgui term window component
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 15 Oct 2009 16:11:59 +0000 (09:11 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 29 Oct 2009 14:00:34 +0000 (07:00 -0700)
gr-wxgui/src/python/Makefile.am
gr-wxgui/src/python/term_window.py [new file with mode: 0644]
gr-wxgui/src/python/termsink.py [new file with mode: 0644]
grc/blocks/Makefile.am
grc/blocks/block_tree.xml
grc/blocks/wxgui_termsink.xml [new file with mode: 0644]

index e06298a2d081b93ae561e93b421df0124e2b2e40..0b4550b381a3c2ac86a449441cb40b8e76615507 100644 (file)
@@ -53,6 +53,8 @@ ourpython_PYTHON =                    \
        scopesink_nongl.py              \
        scopesink_gl.py                 \
        scope_window.py                 \
+       term_window.py                  \
+       termsink.py                     \
        waterfallsink2.py               \
        waterfallsink_nongl.py          \
        waterfallsink_gl.py             \
diff --git a/gr-wxgui/src/python/term_window.py b/gr-wxgui/src/python/term_window.py
new file mode 100644 (file)
index 0000000..cae19c0
--- /dev/null
@@ -0,0 +1,28 @@
+#
+# Copyright 2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+import wx
+import pubsub
+
+class term_window(wx.Panel, pubsub.pubsub):
+       def __init__(self, parent):
+               pubsub.pubsub.__init__(self)
+               wx.Panel.__init__(self, parent, style=wx.SIMPLE_BORDER)
diff --git a/gr-wxgui/src/python/termsink.py b/gr-wxgui/src/python/termsink.py
new file mode 100644 (file)
index 0000000..92aba47
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# Copyright 2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+import term_window
+import common
+from gnuradio import gr
+
+class termsink(gr.hier_block2, common.wxgui_hb):
+       def __init__(self,parent):
+               gr.hier_block2.__init__(
+                       self,
+                       "termsink",
+                       gr.io_signature(0, 0, 0),
+                       gr.io_signature(0, 0, 0),
+               )
+
+               self.win = term_window.term_window(
+                       parent=parent,
+               )
+
index 9194d99ec2a79734ff2cd0ac2152f5ef615dd1c0..e436cc7645e970708505ba4c8d8db2173a2f4580 100644 (file)
@@ -230,6 +230,7 @@ dist_ourdata_DATA = \
        wxgui_histosink2.xml \
        wxgui_numbersink2.xml \
        wxgui_scopesink2.xml \
+       wxgui_termsink.xml \
        wxgui_waterfallsink2.xml \
        xmlrpc_client.xml \
        xmlrpc_server.xml
index 187ca196a1ea2d27507eaed2ed64eaacc85800fc..5d1d510239d84833dadcfb839454888df26ceb0a 100644 (file)
@@ -46,6 +46,7 @@
                <block>wxgui_constellationsink2</block>
                <block>wxgui_waterfallsink2</block>
                <block>wxgui_histosink2</block>
+               <block>wxgui_termsink</block>
        </cat>
        <cat>
                <name>Operators</name>
diff --git a/grc/blocks/wxgui_termsink.xml b/grc/blocks/wxgui_termsink.xml
new file mode 100644 (file)
index 0000000..e1d52cd
--- /dev/null
@@ -0,0 +1,32 @@
+<?xml version="1.0"?>
+<!--
+###################################################
+##Terminal window
+###################################################
+ -->
+<block>
+       <name>Terminal Sink</name>
+       <key>wxgui_termsink</key>
+       <import>from gnuradio.wxgui import termsink</import>
+       <make>#set $parent = $notebook() and 'self.%s.GetPage(%s)'%$notebook() or 'self'
+termsink.termsink(
+       $(parent).GetWin(),
+)
+#if not $grid_pos()
+$(parent).Add(self.$(id).win)
+#else
+$(parent).GridAdd(self.$(id).win, $(', '.join(map(str, $grid_pos()))))
+#end if</make>
+       <param>
+               <name>Grid Position</name>
+               <key>grid_pos</key>
+               <value></value>
+               <type>grid_pos</type>
+       </param>
+       <param>
+               <name>Notebook</name>
+               <key>notebook</key>
+               <value></value>
+               <type>notebook</type>
+       </param>
+</block>