patch from Jakub Wilk adding noopt and nostrip build option support
authorBdale Garbee <bdale@gag.com>
Wed, 1 Dec 2010 17:18:36 +0000 (10:18 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 1 Dec 2010 17:18:36 +0000 (10:18 -0700)
debian/changelog
debian/rules

index 941a569b9bf5b3a6bb73bee4a492f15c926a4f58..02a14f833b2444aeeada04b55371693bfa2ab7ab 100644 (file)
@@ -1,3 +1,10 @@
+sudo (1.7.4p4-6) UNRELEASED; urgency=low
+
+  * patch from Jakub Wilk to add noopt and nostrip build option support,
+    closes: #605580
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 01 Dec 2010 10:18:01 -0700
+
 sudo (1.7.4p4-5) unstable; urgency=low
 
   * add Vcs entries to the control file
index 15f94a4bd037ead91d0700e166938f5c3a630591..5011197f7959fe02286bd7836c550cd27437ef26 100755 (executable)
@@ -2,9 +2,11 @@
 
 export DH_VERBOSE=1
 
-CFLAGS = -O2 -Wall -Wno-comment
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -g
+CFLAGS = -Wall -Wno-comment -g
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
 endif
 export CFLAGS