Merge branch 'vrt' of http://gnuradio.org/git/jblum
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 21 Oct 2009 21:20:15 +0000 (14:20 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 21 Oct 2009 21:20:15 +0000 (14:20 -0700)
Merge fix: added GRUEL_INCLUDES to vrt Makefile
Merge fix: added missing include in gr-vrt

* 'vrt' of http://gnuradio.org/git/jblum:
  query the model number from the host
  fix so all handlers get called on event
  simplfied the code while i was looking at it
  added access methods for gps stuff
  added access methods and parsing for caldiv if context
  use existing utility method
  reading the lo back and storing it
  use the new htonll and vrt types to send cal and lo freqs
  checking for if context packets and setting up the payload pointer and size
  Reading 64 bit freq out of chunk of context packet.
  copied over vrt context and type headers, updated bits.h as well
  Dump IF-Context packets in hex.
  use gruel/inet.h instead of arap/inet.h
  fix white space
  made rxdspno a parameter for: start/stop streaming, and quadradio32fc

1  2 
gr-vrt/src/vrt_source_32fc.cc
vrt/lib/Makefile.am

index beb5ef26d256ac3ffa0bfd024af4e2d0c8020caf,e56e3f2ad272d6ee4b452a041119aaf1ac66545c..f9375d31cb6e2f124505f3526a8f67ed2f766cfc
@@@ -30,6 -32,9 +32,9 @@@
  #include <gr_io_signature.h>
  #include <missing_pkt_checker.h>
  #include <iostream>
 -
+ #include <gruel/inet.h>
+ #include <cstdio>
++#include <cstring>
  
  #define VERBOSE 1             // define to 0 or 1
  
index 9832c0cd54375fcda991279a6b0d0a7e5ca915cd,9832c0cd54375fcda991279a6b0d0a7e5ca915cd..d41343a5d8800de6141383835ec7ca7d541b7ad8
@@@ -20,7 -20,7 +20,8 @@@ include $(top_srcdir)/Makefile.commo
  AM_CPPFLAGS = \
      $(VRT_INCLUDES) \
      $(BOOST_CPPFLAGS) \
--    $(CPPUNIT_INCLUDES)
++    $(CPPUNIT_INCLUDES) \
++    $(GRUEL_INCLUDES)
  
  bin_PROGRAMS =