Merge branch 'flattopwindow' of http://gnuradio.org/git/jblum
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 29 Oct 2009 13:52:53 +0000 (06:52 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 29 Oct 2009 13:52:53 +0000 (06:52 -0700)
Merge-fix: Remove debugging print
Merge-fix: Update copyrights

* 'flattopwindow' of http://gnuradio.org/git/jblum:
  Added window option to wxgui fft and waterfall sink.
  redid cos windows, added flattop and nuttall_cfd

18 files changed:
Makefile.common
gnuradio-core/src/python/gnuradio/window.py
gr-noaa/grc/Makefile.am
gr-wxgui/src/python/fftsink_gl.py
gr-wxgui/src/python/fftsink_nongl.py
gr-wxgui/src/python/waterfallsink_gl.py
grc/Makefile.am
grc/Makefile.inc [deleted file]
grc/base/Makefile.am
grc/blocks/Makefile.am
grc/blocks/gr_message_sink.xml
grc/blocks/gr_message_source.xml
grc/freedesktop/Makefile.am
grc/gui/Makefile.am
grc/python/Makefile.am
grc/python/flow_graph.tmpl
grc/scripts/Makefile.am
grc/todo.txt

index aca56b34aeac948d2a9757a878d7a780f54931fa..64891345ba778b99600d6b7e2620b6beb9df2068 100644 (file)
@@ -113,6 +113,9 @@ gr_docdir = $(docdir)-$(DOCVER)
 # System configuration files
 gr_prefsdir = $(GR_PREFSDIR)
 
+# Data directory for grc block wrappers
+grc_blocksdir = $(pkgdatadir)/grc/blocks
+
 # Other common defines; use "+=" to add to these
 STAMPS =
 MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
index 7f6d62b7c0c6be7efca17667ed8c110cd90fa6cb..e109a98920300a14df862e5fede79fd21cd27b93 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005 Free Software Foundation, Inc.
+# Copyright 2004,2005,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -166,7 +166,7 @@ def kaiser(fft_size,beta):
 def coswindow(coeffs):
     def closure(fft_size):
         window = [0] * fft_size
-        print list(enumerate(coeffs))
+        #print list(enumerate(coeffs))
         for w_index in range(fft_size):
             for (c_index, coeff) in enumerate(coeffs):
                 window[w_index] += (-1)**c_index * coeff * math.cos(2.0*c_index*math.pi*(w_index+0.5)/(fft_size-1))
index 1f056473c5be0be468b554702523081c0eb00eb7..a290204b0a45c7950590f88d8c7d1b1e6b86031d 100644 (file)
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-grcblocksdir = $(prefix)/share/gnuradio/grc/blocks
+grcblocksdir = $(grc_blocksdir)
 
 dist_grcblocks_DATA = \
        noaa_hrpt_decoder.xml \
index 9b2f9a487e453404b304ef90034e8dfe55d024ad..8ddea9a8e3fd0109a737a8f5f49a28478e604b5d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008,2009 Free Software Foundation, Inc.
 #
 # This file is part of GNU Radio
 #
index b3a48a716dfe15c60ce74db19a408a2fe4859534..937eb27cce936ad14c5243ecc66568bb750833cb 100644 (file)
@@ -1,6 +1,6 @@
 #!/usr/bin/env python
 #
-# Copyright 2003,2004,2005,2006,2007 Free Software Foundation, Inc.
+# Copyright 2003,2004,2005,2006,2007,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
index c6b0df65c6b5c481b7333f2e02a985199013ef0e..c2c4e8df7a1481ce165c5746ae7f65610aebd3ef 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008,2009 Free Software Foundation, Inc.
 #
 # This file is part of GNU Radio
 #
index 30b955a1efbb3a47419303d7de5d74b0b9940127..2b5dc730b5e3184b9c25c6ad3e1a34f4b0dd0cde 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 if PYTHON
 SUBDIRS = \
@@ -35,7 +35,7 @@ if XDG_UTILS
 SUBDIRS += freedesktop
 endif
 
-ourpythondir = $(grc_src_prefix)
+ourpythondir = $(pkgpythondir)/grc
 ourpython_PYTHON = __init__.py
 
 etcdir = $(gr_prefsdir)
diff --git a/grc/Makefile.inc b/grc/Makefile.inc
deleted file mode 100644 (file)
index c45d1ce..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#
-# Copyright 2008, 2009 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-grc_src_prefix = $(pkgpythondir)/grc
-grc_blocksdir = $(pkgdatadir)/grc/blocks
index e489601db264095dbb23149f265ba0e306ae734a..6a95e33b983b841dcb691e0aa4eeb2ff05b6769e 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/base
+ourpythondir = $(pkgpythondir)/grc/base
 ourpython_PYTHON = \
        odict.py \
        ParseXML.py \
@@ -35,7 +35,7 @@ ourpython_PYTHON = \
        Port.py \
        __init__.py
 
-ourdatadir = $(grc_src_prefix)/base
+ourdatadir = $(pkgpythondir)/grc/base
 dist_ourdata_DATA = \
        block_tree.dtd \
        flow_graph.dtd
index 61c0038038e5ce8ef6dcd7d4466380d035dde556..9194d99ec2a79734ff2cd0ac2152f5ef615dd1c0 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 ourdatadir = $(grc_blocksdir)
 dist_ourdata_DATA = \
index 76537f2833e56e74e9d849c8574a9c0eb29b8601..18e92adb97ff725d6097896afda4dead7719c57f 100644 (file)
@@ -8,7 +8,7 @@
        <name>Message Sink</name>
        <key>gr_message_sink</key>
        <import>from gnuradio import gr</import>
-       <make>gr.message_sink($type.size*$vlen, $(id)_msgq, $dont_block)</make>
+       <make>gr.message_sink($type.size*$vlen, $(id)_msgq_out, $dont_block)</make>
        <param>
                <name>Input Type</name>
                <key>type</key>
index 44378ae83fc976527ca8468d9f75dfdcb7089db5..72367b21b0066361a8718410144e7b91ef31362c 100644 (file)
@@ -8,7 +8,7 @@
        <name>Message Source</name>
        <key>gr_message_source</key>
        <import>from gnuradio import gr</import>
-       <make>gr.message_source($type.size*$vlen, $(id)_msgq)</make>
+       <make>gr.message_source($type.size*$vlen, $(id)_msgq_in)</make>
        <param>
                <name>Output Type</name>
                <key>type</key>
index 79388ba3a00984e1ef4d3e3f137969e52cbbb4ca..bfbdee9404fea4671740d578050cec6132bc2706 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 ourdatadir = $(pkgdatadir)/grc/freedesktop
 
index b14817d04e0d9e891544a99736a99ad3ccbe358a..a73b6855dc5514fde4b0c1e174cfb08da78cf9b1 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/gui
+ourpythondir = $(pkgpythondir)/grc/gui
 ourpython_PYTHON = \
        Block.py \
        Colors.py \
index 0a62c08257a36e9ba3fef5294b899a0933243dd7..67b71bc4723d75cf9b524042d9ca0282bb5aa915 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/python
+ourpythondir = $(pkgpythondir)/grc/python
 ourpython_PYTHON = \
        convert_hier.py \
        expr_utils.py \
@@ -37,7 +37,7 @@ ourpython_PYTHON = \
        Port.py \
        __init__.py
 
-ourdatadir = $(grc_src_prefix)/python
+ourdatadir = $(pkgpythondir)/grc/python
 dist_ourdata_DATA = \
        block.dtd \
        default_flow_graph.grc \
index 31d99a61c2dde5096e55b120c4f63c720956578a..ab764006c06e304f9a663a655b7a2edd66ed75bb 100644 (file)
@@ -135,7 +135,7 @@ class $(class_name)(gr.hier_block2):
                $DIVIDER
 #end if
 #for $msg in $messages
-               $(msg.get_source().get_parent().get_id())_msgq = $(msg.get_sink().get_parent().get_id())_msgq = gr.msg_queue(2)
+               $(msg.get_source().get_parent().get_id())_msgq_out = $(msg.get_sink().get_parent().get_id())_msgq_in = gr.msg_queue(2)
 #end for
 ########################################################
 ##Create Blocks
index 35c75d5feb5ba3a54fcdcd77942c6b8926920d64..e24f88800f0ddc68b65d7245ceed2efab379ec8d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008, 2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -19,6 +19,6 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 dist_bin_SCRIPTS = grc usrp2_probe usrp_probe
index e4fd4647a7cab3077be2fc88029ce0d91f15001c..9dad05730198475b1be8c776da7c9a250a668453 100644 (file)
@@ -26,6 +26,7 @@
 * callbacks for set average on fft, waterfall, number sinks
 * add units to params: Sps, Hz, dB...
 * add bool type to command line option store_true or store_false
+* messages for packet blocks and probe blocks
 
 ##################################################
 # Features
@@ -53,6 +54,7 @@
 * concept of a project, or project flow graph
   * collection of blocks, hier and top
   * system-wide, default/work, and user created
+* use templates/macros to generate the repetative stuff in the xml
 
 ##################################################
 # Problems
@@ -68,6 +70,7 @@
 * threads dont die on exit in probe and variable sink
 * align param titles in properties dialog
 * weird grid params misbehaving
+* gr hier blocks have more diverse IO capabilities than we allow for
 
 ##################################################
 # Future