Imported Debian patch 1.6.8p12-1 debian/1.6.8p12-1
authorBdale Garbee <bdale@gag.com>
Wed, 28 Dec 2005 20:49:10 +0000 (13:49 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 14 May 2008 18:03:47 +0000 (12:03 -0600)
22 files changed:
CHANGES
Makefile.in
debian/changelog
debian/compat [new file with mode: 0644]
debian/control
debian/docs
debian/postinst
debian/rules
debian/sudo-ldap.dirs [new file with mode: 0644]
debian/sudo-ldap.docs [new file with mode: 0644]
debian/sudo-ldap.init.d [new file with mode: 0644]
debian/sudo-ldap.lintian [new file with mode: 0644]
debian/sudo-ldap.postinst [new file with mode: 0644]
debian/sudo-ldap.postrm [new file with mode: 0644]
env.c
sudo.cat
sudo.man.in
sudoers.cat
sudoers.man.in
version.h
visudo.cat
visudo.man.in

diff --git a/CHANGES b/CHANGES
index 221d7bd13fd1a0e98d110b2da2c20239eb54e938..2ab4d684cc4db7b248797bc201ef80102d02f2ab 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1793,3 +1793,18 @@ Sudo 1.6.8p8 released.
      safe_cmnd.
 
 Sudo 1.6.8p9 released.
+
+567) Added PS4 and SHELLOPTS to the list of variables to remove from
+     the environment.
+
+Sudo 1.6.8p10 released.
+
+567) Added JAVA_TOOL_OPTIONS to the list of variables to remove from
+     the environment.
+
+Sudo 1.6.8p11 released.
+
+567) Added PERLLIB, PERL5LIB and PERL5OPT to the list of variables to
+     remove from the environment.
+
+Sudo 1.6.8p12 released.
index 58f78d4525ef5787b342064c367cd5004cde510e..893ac812396d1bc7c852dedd4048fda0ddba153e 100644 (file)
@@ -130,7 +130,7 @@ TESTOBJS = interfaces.o testsudoers.o $(PARSEOBJS)
 
 LIBOBJS = @LIBOBJS@ @ALLOCA@
 
-VERSION = 1.6.8p9
+VERSION = 1.6.8p12
 
 DISTFILES = $(SRCS) $(HDRS) BUGS CHANGES HISTORY INSTALL INSTALL.configure \
            LICENSE Makefile.in PORTING README README.LDAP RUNSON TODO \
index 98086a3c6a44e22b9e0d1380dcd1db4ea7cba31e..65271b282e7c4d054ee6b57d91f1b612dfb74480 100644 (file)
@@ -1,3 +1,15 @@
+sudo (1.6.8p12-1) unstable; urgency=low
+
+  * new upstream version, closes: #342948 (CVE-2005-4158)
+  * add env_reset to the sudoers file we create if none already exists,
+    as a further precaution in response to discussion about CVS-2005-4158
+  * split ldap support into a new sudo-ldap package.  I was trying to avoid
+    doing this, but the impact of going from 4 to 17 linked shlibs on the 
+    autobuilder chroots is sufficient motivation for me.
+    closes: #344034
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 28 Dec 2005 13:49:10 -0700
+
 sudo (1.6.8p9-4) unstable; urgency=low
 
   * enable ldap support, deliver README.LDAP and sudoers2ldif, closes: #283231 
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..b8626c4
--- /dev/null
@@ -0,0 +1 @@
+4
index 4e0328314623cfd3402d84f1216b0e67b2e532f2..85a29ca3c15709300316afc57a59562821a38251 100644 (file)
@@ -8,8 +8,25 @@ Standards-Version: 3.6.2.1
 Package: sudo
 Architecture: any
 Depends: ${shlibs:Depends}, libpam-modules
+Conflicts: sudo-ldap
+Replaces: sudo-ldap
 Description: Provide limited super user privileges to specific users
  Sudo is a program designed to allow a sysadmin to give limited root
  privileges to users and log root activity.  The basic philosophy is to give
  as few privileges as possible but still allow people to get their work done.
+ .
+ This version is built with minimal shared library dependencies, use the
+ sudo-ldap package instead if you need LDAP support.
 
+Package: sudo-ldap
+Architecture: any
+Depends: ${shlibs:Depends}, libpam-modules
+Conflicts: sudo
+Replaces: sudo
+Provides: sudo
+Description: Provide limited super user privileges to specific users
+ Sudo is a program designed to allow a sysadmin to give limited root
+ privileges to users and log root activity.  The basic philosophy is to give
+ as few privileges as possible but still allow people to get their work done.
+ .
+ This version is built with LDAP support.
index bafbdedd0b8cab0fd057d27e512b7c298a18e807..b66c0277b772bafb8fa5ccfa51758e2aa1d6e03d 100644 (file)
@@ -6,6 +6,4 @@ PORTING
 TODO 
 HISTORY 
 README 
-README.LDAP 
 TROUBLESHOOTING
-sudoers2ldif
index 1dd64622e0d27f73a98ea86c3740e33b7b0fe97e..732d750ce3f8114fc81a67e50e5c87dc3da9dc1d 100644 (file)
@@ -15,7 +15,8 @@ if ( ! -f "/etc/sudoers") {
          "# This file MUST be edited with the 'visudo' command as root.\n",
          "#\n",
          "# See the man page for details on how to write a sudoers file.\n",
-         "#\n\n# Host alias specification\n\n",
+         "#\n\nDefaults\tenv_reset\n\n",
+         "# Host alias specification\n\n",
          "# User alias specification\n\n",
          "# Cmnd alias specification\n\n",
          "# User privilege specification\nroot\tALL=(ALL) ALL\n";
index 5529cf35466840417c46282b14265d94f4f650f7..2e5f18f7df737961ac14361d688585744f20c8af 100755 (executable)
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 export DH_VERBOSE=1
-export DH_COMPAT=4
 
 CFLAGS = -O2 -Wall -Wno-comment
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
@@ -9,11 +8,25 @@ CFLAGS += -g
 endif
 export CFLAGS
 
-build: build-stamp
-build-stamp:
+build: config-stamp
+config-stamp:
        dh_testdir
 
-       ./configure --prefix=/usr -v \
+       # simple version
+       mkdir -p build-simple
+       cd build-simple && ../configure --prefix=/usr -v \
+               --with-all-insults \
+               --with-exempt=sudo --with-pam --with-fqdn \
+               --with-logging=syslog --with-logfac=authpriv \
+               --with-env-editor --with-editor=/usr/bin/editor \
+               --with-timeout=15 --with-password-timeout=0 \
+               --disable-root-mailer --disable-setresuid \
+               --with-sendmail=/usr/sbin/sendmail \
+               --with-secure-path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"
+
+       # LDAP version
+       mkdir -p build-ldap
+       cd build-ldap && ../configure --prefix=/usr -v \
                --with-all-insults \
                --with-exempt=sudo --with-pam --with-ldap --with-fqdn \
                --with-logging=syslog --with-logfac=authpriv \
@@ -21,18 +34,26 @@ build-stamp:
                --with-timeout=15 --with-password-timeout=0 \
                --disable-root-mailer --disable-setresuid \
                --with-sendmail=/usr/sbin/sendmail \
+               --with-ldap-conf-file=/etc/ldap/ldap.conf \
                --with-secure-path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin"
 
-       -$(MAKE)
+       touch config-stamp
+
+build: build-stamp
+build-stamp: config-stamp
+       dh_testdir
+
+       -$(MAKE) -C build-simple
+       -$(MAKE) -C build-ldap
 
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
-
-       -$(MAKE) distclean || exit 0
+       rm -f config-stamp build-stamp
+       rm -rf build-simple build-ldap
+       rm -f config.cache
 
        -test -r /usr/share/misc/config.sub && \
                cp -f /usr/share/misc/config.sub config.sub
@@ -41,21 +62,23 @@ clean:
 
        dh_clean
 
-install: build
+install: build-stamp
        dh_testdir
        dh_testroot
        dh_clean -k
        dh_installdirs
 
-       install -o root -g root -m 4755 -s sudo debian/sudo/usr/bin/sudo
+       # simple version
+       install -o root -g root -m 4755 -s build-simple/sudo debian/sudo/usr/bin/sudo
        ln -sf sudo debian/sudo/usr/bin/sudoedit
-       install -o root -g root -m 0755 -s visudo debian/sudo/usr/sbin/visudo
-       install -o root -g root -m 0644 sudo.man \
+       install -o root -g root -m 0755 -s build-simple/visudo \
+               debian/sudo/usr/sbin/visudo
+       install -o root -g root -m 0644 build-simple/sudo.man \
                debian/sudo/usr/share/man/man8/sudo.8 
        ln -sf sudo.8 debian/sudo/usr/share/man/man8/sudoedit.8
-       install -o root -g root -m 0644 visudo.man \
+       install -o root -g root -m 0644 build-simple/visudo.man \
                debian/sudo/usr/share/man/man8/visudo.8 
-       install -o root -g root -m 0644 sudoers.man \
+       install -o root -g root -m 0644 build-simple/sudoers.man \
                debian/sudo/usr/share/man/man5/sudoers.5 
        install -o root -g root -m 0644 sample.sudoers \
                debian/sudo/usr/share/doc/sudo/examples/sudoers
@@ -65,25 +88,41 @@ install: build
        install -o root -g root -m 0644 debian/sudo.lintian \
                debian/sudo/usr/share/lintian/overrides/sudo
 
+       # LDAP version
+       install -o root -g root -m 4755 -s build-ldap/sudo debian/sudo-ldap/usr/bin/sudo
+       ln -sf sudo debian/sudo-ldap/usr/bin/sudoedit
+       install -o root -g root -m 0755 -s build-ldap/visudo debian/sudo-ldap/usr/sbin/visudo
+       install -o root -g root -m 0644 build-ldap/sudo.man \
+               debian/sudo-ldap/usr/share/man/man8/sudo.8 
+       ln -sf sudo.8 debian/sudo-ldap/usr/share/man/man8/sudoedit.8
+       install -o root -g root -m 0644 build-ldap/visudo.man \
+               debian/sudo-ldap/usr/share/man/man8/visudo.8 
+       install -o root -g root -m 0644 build-ldap/sudoers.man \
+               debian/sudo-ldap/usr/share/man/man5/sudoers.5 
+       install -o root -g root -m 0644 sample.sudoers \
+               debian/sudo-ldap/usr/share/doc/sudo-ldap/examples/sudoers
+       install -o root -g root -m 0644 debian/sudo.pam \
+               debian/sudo-ldap/etc/pam.d/sudo
+
+       install -o root -g root -m 0644 debian/sudo-ldap.lintian \
+               debian/sudo-ldap/usr/share/lintian/overrides/sudo-ldap
+
 binary-indep: build install
 
 binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installinit
-       dh_installcron
+       dh_installexamples -A
+       dh_installinit -psudo -psudo-ldap
        dh_installmanpages fnmatch.3
-       dh_installinfo
+       dh_installinfo -A
        dh_installchangelogs CHANGES
-       dh_link
        dh_strip
        dh_compress
        dh_fixperms
-       chown root.root debian/sudo/usr/bin/sudo
-       chmod 4755 debian/sudo/usr/bin/sudo
+       chown root.root debian/sudo/usr/bin/sudo debian/sudo-ldap/usr/bin/sudo
+       chmod 4755 debian/sudo/usr/bin/sudo debian/sudo-ldap/usr/bin/sudo
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
diff --git a/debian/sudo-ldap.dirs b/debian/sudo-ldap.dirs
new file mode 100644 (file)
index 0000000..cde2069
--- /dev/null
@@ -0,0 +1,7 @@
+etc/pam.d
+usr/bin
+usr/share/man/man8
+usr/share/man/man5
+usr/sbin
+usr/share/doc/sudo-ldap/examples
+usr/share/lintian/overrides
diff --git a/debian/sudo-ldap.docs b/debian/sudo-ldap.docs
new file mode 100644 (file)
index 0000000..bafbded
--- /dev/null
@@ -0,0 +1,11 @@
+debian/OPTIONS 
+BUGS 
+RUNSON 
+UPGRADE 
+PORTING
+TODO 
+HISTORY 
+README 
+README.LDAP 
+TROUBLESHOOTING
+sudoers2ldif
diff --git a/debian/sudo-ldap.init.d b/debian/sudo-ldap.init.d
new file mode 100644 (file)
index 0000000..ba67255
--- /dev/null
@@ -0,0 +1,31 @@
+#! /bin/sh
+
+### BEGIN INIT INFO
+# Provides:          sudu
+# Required-Start:    $local_fs $remote_fs
+# Required-Stop:
+# Default-Start:     S 1 2 3 4 5
+# Default-Stop:      0 6
+### END INIT INFO
+
+N=/etc/init.d/sudo
+
+set -e
+
+case "$1" in
+  start)
+       # make sure privileges don't persist across reboots
+       if [ -d /var/run/sudo ]
+       then
+                find /var/run/sudo -type f -exec touch -t 198501010000 '{}' \;
+       fi
+       ;;
+  stop|reload|restart|force-reload)
+       ;;
+  *)
+       echo "Usage: $N {start|stop|restart|force-reload}" >&2
+       exit 1
+       ;;
+esac
+
+exit 0
diff --git a/debian/sudo-ldap.lintian b/debian/sudo-ldap.lintian
new file mode 100644 (file)
index 0000000..eea5106
--- /dev/null
@@ -0,0 +1,3 @@
+sudo-ldap: setuid-binary usr/bin/sudo 4755 root/root
+sudo-ldap: postrm-contains-additional-updaterc.d-calls /etc/init.d/sudo-ldap
+sudo-ldap: script-in-etc-init.d-not-registered-via-update-rc.d /etc/init.d/sudo-ldap
diff --git a/debian/sudo-ldap.postinst b/debian/sudo-ldap.postinst
new file mode 100644 (file)
index 0000000..732d750
--- /dev/null
@@ -0,0 +1,62 @@
+#!/usr/bin/perl
+
+# remove old link
+
+unlink ("/etc/alternatives/sudo") if ( -l "/etc/alternatives/sudo");
+
+# make sure we have a sudoers file
+if ( ! -f "/etc/sudoers") {
+
+       print "No /etc/sudoers found... creating one for you.\n";
+
+       open (SUDOERS, "> /etc/sudoers");
+       print SUDOERS "# /etc/sudoers\n",
+         "#\n",
+         "# This file MUST be edited with the 'visudo' command as root.\n",
+         "#\n",
+         "# See the man page for details on how to write a sudoers file.\n",
+         "#\n\nDefaults\tenv_reset\n\n",
+         "# Host alias specification\n\n",
+         "# User alias specification\n\n",
+         "# Cmnd alias specification\n\n",
+         "# User privilege specification\nroot\tALL=(ALL) ALL\n";
+       close SUDOERS;
+
+}
+
+# make sure sudoers has the correct permissions and owner/group
+system ('chown root:root /etc/sudoers');
+system ('chmod 440 /etc/sudoers');
+
+# must do a remove first to un-do the "bad" links created by previous version
+system ('update-rc.d -f sudo remove >/dev/null 2>&1');
+
+system ('update-rc.d sudo start 75 S . >/dev/null');
+
+# make sure we have a sudo group
+
+exit 0 if getgrnam("sudo"); # we're finished if there is a group sudo
+
+$gid = 27;                 # start searcg with gid 27
+setgrent;
+while (getgrgid($gid)) {
+       ++$gid;
+}
+endgrent;
+
+if ($gid != 27) {
+       print "On Debian we normally use gid 27 for 'sudo'.\n";
+       $gname = getgrgid(27);
+       print "However, on your system gid 27 is group '$gname'.\n\n";
+       print "Would you like me to stop configuring sudo so that you can change this? [n] "; 
+       $ans = <STDIN>;
+        if ($ans =~ m/^[yY].*/) {
+               print "'dpkg --pending --configure' will restart the configuration.\n\n\n";
+               exit 1;
+       }
+}
+
+print "Creating group 'sudo' with gid = $gid\n";
+system("groupadd -g $gid sudo");
+
+print "";
diff --git a/debian/sudo-ldap.postrm b/debian/sudo-ldap.postrm
new file mode 100644 (file)
index 0000000..e018f12
--- /dev/null
@@ -0,0 +1,21 @@
+#! /bin/sh
+
+set -e
+
+case "$1" in
+       purge)
+       rm -f /etc/sudoers
+        ;;
+
+       remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+        ;;
+
+    *)
+        echo "postrm called with unknown argument \`$1'" >&2
+        exit 1
+
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/env.c b/env.c
index 8116178538c5a2afa5ff82a75c986787fa1af2b4..ed738a899f51f3b3107a314ba215b7d9f9799fec 100644 (file)
--- a/env.c
+++ b/env.c
@@ -126,6 +126,12 @@ static const char *initial_badenv_table[] = {
     "TERMCAP",                 /* XXX - only if it starts with '/' */
     "ENV",
     "BASH_ENV",
+    "PS4",
+    "SHELLOPTS",
+    "JAVA_TOOL_OPTIONS",
+    "PERLLIB",
+    "PERL5LIB",
+    "PERL5OPT",
     NULL
 };
 
index fdca4d8aaa074c69969a06cca77fbc17384ab007..c5d7434afff0fe4220dd426154ba227c0a91d2b6 100644 (file)
--- a/sudo.cat
+++ b/sudo.cat
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.6.8p                 June, 20 2005                          1
+1.6.8p12                 June, 20 2005                          1
 
 
 
@@ -127,7 +127,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.6.8p                 June, 20 2005                          2
+1.6.8p12                 June, 20 2005                          2
 
 
 
@@ -193,7 +193,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p                 June, 20 2005                          3
+1.6.8p12                 June, 20 2005                          3
 
 
 
@@ -259,7 +259,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p                 June, 20 2005                          4
+1.6.8p12                 June, 20 2005                          4
 
 
 
@@ -325,7 +325,7 @@ S\bSE\bEC\bCU\bUR\bRI\bIT\bTY\bY N\bNO\bOT\bTE\bES\bS
 
 
 
-1.6.8p                 June, 20 2005                          5
+1.6.8p12                 June, 20 2005                          5
 
 
 
@@ -391,7 +391,7 @@ E\bEN\bNV\bVI\bIR\bRO\bON\bNM\bME\bEN\bNT\bT
 
 
 
-1.6.8p                 June, 20 2005                          6
+1.6.8p12                 June, 20 2005                          6
 
 
 
@@ -457,7 +457,7 @@ A\bAU\bUT\bTH\bHO\bOR\bRS\bS
 
 
 
-1.6.8p                 June, 20 2005                          7
+1.6.8p12                 June, 20 2005                          7
 
 
 
@@ -523,7 +523,7 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p                 June, 20 2005                          8
+1.6.8p12                 June, 20 2005                          8
 
 
 
@@ -589,6 +589,6 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p                 June, 20 2005                          9
+1.6.8p12                 June, 20 2005                          9
 
 
index 896121e79b6892fcaee1526ca7df63f0ea1b1747..4e8e3727f1b371ce5a62f4ebaabaa0c2104f64c9 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDO @mansectsu@"
-.TH SUDO @mansectsu@ "June 20, 2005" "1.6.8p9" "MAINTENANCE COMMANDS"
+.TH SUDO @mansectsu@ "June 20, 2005" "1.6.8p12" "MAINTENANCE COMMANDS"
 .SH "NAME"
 sudo, sudoedit \- execute a command as another user
 .SH "SYNOPSIS"
index 8be0790528835646deeddb9d81b74e90b52c13e7..41d3489bd35fec4d1dee1087334fcd20eb9f7187 100644 (file)
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.6.8p                 June, 20 2005                          1
+1.6.8p12                 June, 20 2005                          1
 
 
 
@@ -127,7 +127,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          2
+1.6.8p12                 June, 20 2005                          2
 
 
 
@@ -193,7 +193,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          3
+1.6.8p12                 June, 20 2005                          3
 
 
 
@@ -259,7 +259,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          4
+1.6.8p12                 June, 20 2005                          4
 
 
 
@@ -325,7 +325,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          5
+1.6.8p12                 June, 20 2005                          5
 
 
 
@@ -391,7 +391,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          6
+1.6.8p12                 June, 20 2005                          6
 
 
 
@@ -457,7 +457,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          7
+1.6.8p12                 June, 20 2005                          7
 
 
 
@@ -523,7 +523,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          8
+1.6.8p12                 June, 20 2005                          8
 
 
 
@@ -589,7 +589,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                          9
+1.6.8p12                 June, 20 2005                          9
 
 
 
@@ -655,7 +655,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         10
+1.6.8p12                 June, 20 2005                         10
 
 
 
@@ -721,7 +721,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         11
+1.6.8p12                 June, 20 2005                         11
 
 
 
@@ -787,7 +787,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         12
+1.6.8p12                 June, 20 2005                         12
 
 
 
@@ -853,7 +853,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         13
+1.6.8p12                 June, 20 2005                         13
 
 
 
@@ -919,7 +919,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         14
+1.6.8p12                 June, 20 2005                         14
 
 
 
@@ -985,7 +985,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         15
+1.6.8p12                 June, 20 2005                         15
 
 
 
@@ -1051,7 +1051,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         16
+1.6.8p12                 June, 20 2005                         16
 
 
 
@@ -1117,7 +1117,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         17
+1.6.8p12                 June, 20 2005                         17
 
 
 
@@ -1183,7 +1183,7 @@ E\bEX\bXA\bAM\bMP\bPL\bLE\bES\bS
 
 
 
-1.6.8p                 June, 20 2005                         18
+1.6.8p12                 June, 20 2005                         18
 
 
 
@@ -1249,7 +1249,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         19
+1.6.8p12                 June, 20 2005                         19
 
 
 
@@ -1315,7 +1315,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p                 June, 20 2005                         20
+1.6.8p12                 June, 20 2005                         20
 
 
 
@@ -1381,7 +1381,7 @@ P\bPR\bRE\bEV\bVE\bEN\bNT\bTI\bIN\bNG\bG S\bSH\bHE\bEL\bLL\bL E\bES\bSC\bCA\bAP\bPE\bES\bS
 
 
 
-1.6.8p                 June, 20 2005                         21
+1.6.8p12                 June, 20 2005                         21
 
 
 
@@ -1447,7 +1447,7 @@ C\bCA\bAV\bVE\bEA\bAT\bTS\bS
 
 
 
-1.6.8p                 June, 20 2005                         22
+1.6.8p12                 June, 20 2005                         22
 
 
 
@@ -1513,6 +1513,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p                 June, 20 2005                         23
+1.6.8p12                 June, 20 2005                         23
 
 
index a81fa07ee088f27384d91185d3466701c7a75f6c..1b81f1c6652187902045cbe7e4096b733c7ed1ee 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDOERS @mansectform@"
-.TH SUDOERS @mansectform@ "June 20, 2005" "1.6.8p9" "MAINTENANCE COMMANDS"
+.TH SUDOERS @mansectform@ "June 20, 2005" "1.6.8p12" "MAINTENANCE COMMANDS"
 .SH "NAME"
 sudoers \- list of which users may execute what
 .SH "DESCRIPTION"
index 12c46a2311a6743f1191642f589fd179f26445ae..3c2bc4ce979489bf1236ecc77a51d492532fa49d 100644 (file)
--- a/version.h
+++ b/version.h
@@ -23,6 +23,6 @@
 #ifndef _SUDO_VERSION_H
 #define _SUDO_VERSION_H
 
-static const char version[] = "1.6.8p9";
+static const char version[] = "1.6.8p12";
 
 #endif /* _SUDO_VERSION_H */
index 6eb2a7fd47b67245270757997d9d1ec09c34348a..c1be3524fbb01def41cbca40d3f3e7b0ddb54022 100644 (file)
@@ -61,7 +61,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.6.8p                 June, 20 2005                          1
+1.6.8p12                 June, 20 2005                          1
 
 
 
@@ -127,7 +127,7 @@ D\bDI\bIA\bAG\bGN\bNO\bOS\bST\bTI\bIC\bCS\bS
 
 
 
-1.6.8p                 June, 20 2005                          2
+1.6.8p12                 June, 20 2005                          2
 
 
 
@@ -193,6 +193,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p                 June, 20 2005                          3
+1.6.8p12                 June, 20 2005                          3
 
 
index 26f6e32abe5f424d05bd98199646af9cf9439025..ad8e8c403c13a6618acd328f9a510e98c4b6042f 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "VISUDO @mansectsu@"
-.TH VISUDO @mansectsu@ "June 20, 2005" "1.6.8p9" "MAINTENANCE COMMANDS"
+.TH VISUDO @mansectsu@ "June 20, 2005" "1.6.8p12" "MAINTENANCE COMMANDS"
 .SH "NAME"
 visudo \- edit the sudoers file
 .SH "SYNOPSIS"