build: link with $(LIB_CLOCK_GETTIME)
authorJim Meyering <meyering@redhat.com>
Fri, 30 Oct 2009 18:38:00 +0000 (19:38 +0100)
committerJim Meyering <meyering@redhat.com>
Fri, 30 Oct 2009 18:38:55 +0000 (19:38 +0100)
* Makefile.am (gzip_LDADD): Add $(LIB_CLOCK_GETTIME), now that
utimens pulls in gettime.
(FILES_TO_CHECK): Remove $(gzip_LDADD), now that it may contain -lrt.

Makefile.am

index 3bca0eefe7cd5c64cacd759f32df28e386ff99f1..59cc615e7b31e77bbfeb2a58f22d3b5448946073 100644 (file)
@@ -48,6 +48,7 @@ gzip_SOURCES = \
   bits.c crypt.c deflate.c gzip.c inflate.c lzw.c \
   trees.c unlzh.c unlzw.c unpack.c unzip.c util.c zip.c
 gzip_LDADD = lib/libgzip.a
+gzip_LDADD += $(LIB_CLOCK_GETTIME)
 
 gzip.doc: gzip.1
        $(AM_V_GEN)groff -man -Tascii $(srcdir)/gzip.1 | col -b | uniq > $@-t \
@@ -82,7 +83,7 @@ gen-ChangeLog:
        fi
 
 # A simple test, just of gzip -- more of a sanity check than anything else.
-FILES_TO_CHECK = $(bin_SCRIPTS) $(gzip_LDADD) \
+FILES_TO_CHECK = $(bin_SCRIPTS) \
   $(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
 check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
        { test '$(srcdir)' != . || ./zdiff --__bindir . -c gzip.doc.gz; }