]> git.gag.com Git - debian/pforth/commitdiff
Merge pull request #80 from letoh/use-pattern-rules
authorPhil Burk <philburk@mobileer.com>
Sun, 13 Sep 2020 20:36:19 +0000 (13:36 -0700)
committerGitHub <noreply@github.com>
Sun, 13 Sep 2020 20:36:19 +0000 (13:36 -0700)
use pattern rules instead of suffix rules in the Makefile

build/unix/Makefile

index e80b56d5d7648dfb27e53b3d77826e508eaa6fe4..626d0cefd8eb38e14e9fdf8a13cc4a159fd98355 100644 (file)
@@ -73,10 +73,10 @@ LINK = $(CC) $(LDFLAGS)
 PFOBJS     = $(PFSOURCE:.c=.o)
 PFEMBOBJS  = $(PFSOURCE:.c=.eo)
 
-.c.o: $(PFINCLUDES)
+%.o: %.c $(PFINCLUDES)
        $(COMPILE) -c -o $@ $<
 
-.c.eo: $(PFINCLUDES) pfdicdat.h
+%.eo: %.c $(PFINCLUDES) pfdicdat.h
        $(COMPILE) $(EMBCCOPTS) -c -o $@ $<
 
 .PHONY: all clean test