Merged r10385:10413 from michaelld/swig_tweaks into trunk. Passes distcheck.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 10 Feb 2009 04:53:37 +0000 (04:53 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 10 Feb 2009 04:53:37 +0000 (04:53 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10414 221aa14e-8319-0410-a670-987f0aec2ac5

35 files changed:
gnuradio-core/src/lib/runtime/Makefile.am
gnuradio-core/src/lib/runtime/gr_swig_block_magic.i [deleted file]
gnuradio-core/src/lib/swig/Makefile.am
gnuradio-core/src/lib/swig/atsc.i [deleted file]
gnuradio-core/src/lib/swig/gnuradio.i
gnuradio-core/src/lib/swig/gr_shared_ptr.i [new file with mode: 0644]
gnuradio-core/src/lib/swig/gr_swig_block_magic.i [new file with mode: 0644]
gnuradio-core/src/lib/swig/shared_ptr.i [deleted file]
gnuradio-core/src/lib/swig/sw_filter.i
gnuradio-core/src/lib/swig/sw_general.i
gnuradio-core/src/lib/swig/sw_gengen.i
gnuradio-core/src/lib/swig/sw_io.i
gnuradio-core/src/lib/swig/sw_runtime.i [new file with mode: 0644]
gr-atsc/src/lib/atsc.i
gr-audio-alsa/src/audio_alsa.i
gr-audio-jack/src/audio_jack.i
gr-audio-oss/src/audio_oss.i
gr-audio-osx/src/audio_osx.i
gr-audio-portaudio/src/audio_portaudio.i
gr-audio-windows/src/audio_windows.i
gr-comedi/src/comedi.i
gr-cvsd-vocoder/src/lib/cvsd_vocoder.i
gr-gcell/src/gcell.i
gr-gpio/src/lib/gpio.i
gr-gsm-fr-vocoder/src/lib/gsm_full_rate.i
gr-howto-write-a-block/src/lib/howto.i
gr-msdd6000/src/msdd.i
gr-pager/src/pager.i
gr-qtgui/src/lib/qtgui.i
gr-radio-astronomy/src/lib/ra.i
gr-trellis/src/lib/trellis.i
gr-usrp/src/usrp.i
gr-usrp2/src/usrp2.i
gr-video-sdl/src/video_sdl.i
usrp/host/lib/legacy/db_base.i

index b21b324128c6d7c74717ecb44ba67f41747eb7c3..cc8da49de4ecf0cd9a9b14712d7898a0cd5407de 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2003,2004,2007,2008 Free Software Foundation, Inc.
+# Copyright 2003,2004,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -152,7 +152,6 @@ swiginclude_HEADERS =                       \
        gr_sync_block.i                 \
        gr_sync_decimator.i             \
        gr_sync_interpolator.i          \
-       gr_swig_block_magic.i           \
        gr_top_block.i                  \
        runtime.i
 
diff --git a/gnuradio-core/src/lib/runtime/gr_swig_block_magic.i b/gnuradio-core/src/lib/runtime/gr_swig_block_magic.i
deleted file mode 100644 (file)
index 083d606..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2004 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 3, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-%define GR_SWIG_BLOCK_MAGIC(PKG, BASE_NAME)
-_GR_SWIG_BLOCK_MAGIC_HELPER(PKG, PKG ## _ ## BASE_NAME, BASE_NAME)
-%enddef
-
-%define _GR_SWIG_BLOCK_MAGIC_HELPER(PKG, NAME, BASE_NAME)
-class NAME;
-typedef boost::shared_ptr<NAME> NAME ## _sptr;
-%template(NAME ## _sptr) boost::shared_ptr<NAME>;
-%rename(BASE_NAME) PKG ## _make_ ## BASE_NAME;
-%inline {
-  gr_block_sptr NAME ## _block (NAME ## _sptr r)
-  {
-    return gr_block_sptr (r);
-  }
-}
-
-%pythoncode %{
-NAME ## _sptr.block = lambda self: NAME ## _block (self)
-NAME ## _sptr.__repr__ = lambda self: "<gr_block %s (%d)>" % (self.name(), self.unique_id ())
-%}
-
-%ignore NAME;
-%enddef
index d468b41a9d7ea244e3d0faaf49becaa57041f365..98c0321994362a3878f5bab9fff0c0dda0fe1ebd 100644 (file)
@@ -35,11 +35,13 @@ EXTRA_DIST = gen-swig-bug-fix
 
 LOCAL_IFILES =                         \
        gnuradio.i                      \
-       shared_ptr.i                    \
+       gr_swig_block_magic.i           \
+       gr_shared_ptr.i                 \
        sw_general.i                    \
        sw_gengen.i                     \
        sw_filter.i                     \
-       sw_io.i
+       sw_io.i                         \
+       sw_runtime.i
 
 ALL_IFILES =                           \
        $(LOCAL_IFILES)
@@ -99,7 +101,7 @@ _gnuradio_swig_py_io_la_CXXFLAGS      = @swig_CXXFLAGS@
 
 
 # ----------------------------------------------------------------
-# Part 1: gnuradio.i -> gnuradio_swig_py_runtime
+# Part 1: sw_runtime.i -> gnuradio_swig_py_runtime
 #
 # We continue to call this gnuradio.i to avoid having to touch
 # lots of code in other modules
@@ -123,8 +125,8 @@ _gnuradio_swig_py_runtime_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
 
 gnuradio_swig_py_runtime.py gnuradio_swig_py_runtime.h: gnuradio_swig_py_runtime.cc
 
-gnuradio_swig_py_runtime.cc : $(srcdir)/gnuradio.i
-       if $(SWIG) $(STD_SWIG_PYTHON_ARGS) -MMD -MF gnuradio_swig_py_runtime.Td -module gnuradio_swig_py_runtime -o gnuradio_swig_py_runtime.cc $(srcdir)/gnuradio.i ;\
+gnuradio_swig_py_runtime.cc : $(srcdir)/sw_runtime.i
+       if $(SWIG) $(STD_SWIG_PYTHON_ARGS) -MMD -MF gnuradio_swig_py_runtime.Td -module gnuradio_swig_py_runtime -o gnuradio_swig_py_runtime.cc $(srcdir)/sw_runtime.i ;\
        then if test $(host_os) = mingw32; \
             then sed 's,\\\\,/,g' <gnuradio_swig_py_runtime.Td >gnuradio_swig_py_runtime.d; rm -f gnuradio_swig_py_runtime.Td; \
             else mv -f gnuradio_swig_py_runtime.Td gnuradio_swig_py_runtime.d; fi \
diff --git a/gnuradio-core/src/lib/swig/atsc.i b/gnuradio-core/src/lib/swig/atsc.i
deleted file mode 100644 (file)
index 67f6ac6..0000000
+++ /dev/null
@@ -1,136 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2003 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 3, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-%{
-#include <atsc_types.h>
-#include <atsc_consts.h>
-#include <GrAtscRandomizer.h>
-#include <GrAtscRSEncoder.h>
-#include <GrAtscInterleaver.h>
-#include <GrAtscTrellisEncoder.h>
-#include <GrAtscFieldSyncMux.h>
-#include <GrAtscSymbolMapper.h>
-#include <GrAtscConvert2xTo20.h>
-#include <GrWeaverModHead.h>
-#include <GrWeaverModTail.h>
-
-%}
-
-// from atsc_types.h
-class plinfo;
-class atsc_mpeg_packet;
-class atsc_mpeg_packet_no_sync;
-class atsc_mpeg_packet_rs_encoded;
-class atsc_data_segment;
-class atsc_soft_data_segment;
-
-%include <atsc_consts.h>
-
-
-// leave out the VrHistoryProc and pretend we're directly derived from VrSigProc
-
-// %template(VrHistoryProc_1) VrHistoryProc<atsc_mpeg_packet,atsc_mpeg_packet_no_sync>;
-
-class GrAtscRandomizer : public VrSigProc
-// class GrAtscRandomizer : public VrHistoryProc<atsc_mpeg_packet, atsc_mpeg_packet_no_sync>
-{
-public:
-  GrAtscRandomizer ();
-  ~GrAtscRandomizer ();
-};
-
-class GrAtscRSEncoder : public VrSigProc
-{
-public:
-  GrAtscRSEncoder ();
-  ~GrAtscRSEncoder ();
-};
-
-class GrAtscInterleaver : public VrSigProc
-{
-public:
-  GrAtscInterleaver ();
-  ~GrAtscInterleaver ();
-};
-
-class GrAtscTrellisEncoder : public VrSigProc
-{
-public:
-  GrAtscTrellisEncoder ();
-  ~GrAtscTrellisEncoder ();
-};
-
-class GrAtscFieldSyncMux : public VrSigProc
-{
-public:
-  GrAtscFieldSyncMux ();
-  ~GrAtscFieldSyncMux ();
-};
-
-template<class oType>
-class GrAtscSymbolMapper : public VrSigProc
-{
-public:
-  GrAtscSymbolMapper ();
-  ~GrAtscSymbolMapper ();
-};
-
-%template(GrAtscSymbolMapperF) GrAtscSymbolMapper<float>;
-
-template<class iType, class oType>
-class GrWeaverModHead : public VrSigProc
-{
-public:
-  GrWeaverModHead (int interp_factor);
-  ~GrWeaverModHead ();
-};
-
-%template(GrWeaverModHeadFF) GrWeaverModHead<float,float>;
-
-template<class iType, class oType>
-class GrWeaverModTail : public VrSigProc {
-public:
-  GrWeaverModTail (float freq, float gain);
-  ~GrWeaverModTail ();
-
-  //! frequency is in Hz
-  void set_freq (float frequency);
-  void set_gain (float g);
-};
-
-%template(GrWeaverModTailFS) GrWeaverModTail<float,short>;
-
-class GrAtscConvert2xTo20 : public VrSigProc
-{
-public:
-  GrAtscConvert2xTo20 ();
-  ~GrAtscConvert2xTo20 ();
-};
-
-
-#if 0  // FIXME
-%template(VrSource_mpeg_packet)     VrSource<atsc_mpeg_packet>;
-%template(VrFileSource_mpeg_packet) VrFileSource<atsc_mpeg_packet>;
-
-%template(VrSink_mpeg_packet)      VrSink<atsc_mpeg_packet>;
-%template(VrFileSink_mpeg_packet)   VrFileSink<atsc_mpeg_packet>;
-#endif
index aa5174a593d266e8e5584311f7a34f9d6cb67e24..7d0241f1c237f22eccb83808cf4de7dc6c562e54 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2003,2004 Free Software Foundation, Inc.
+ * Copyright 2003,2004,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
 // SWIG interface definition
 ////////////////////////////////////////////////////////////////////////
 
-
-#ifndef SWIGIMPORTED
-%module(directors="1") gnuradio_swig_py_runtime
-#endif
-
 ////////////////////////////////////////////////////////////////////////
 // Headers
 
-
 %{
+#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include <gr_types.h>
 #include <stddef.h>            // size_t
 %}
 
 %feature("autodoc","1");
 
-%include <shared_ptr.i>
+// local file
+%include <gr_shared_ptr.i>
+
+// non-local SWIG files
 %include <stl.i>
 %include <std_complex.i>
 %include <std_except.i>
@@ -81,11 +79,9 @@ namespace std {
 
 ////////////////////////////////////////////////////////////////////////
 
-%include <runtime.i>
- // %include <general.i>
- // %include <filter.i>
- // %include <io.i>
-
-// %include <atsc.i>
+#ifndef SW_RUNTIME
+// import runtime.i for all but sw_runtime, since it needs to %include
+%import <runtime.i>
+#endif
 
 ////////////////////////////////////////////////////////////////////////
diff --git a/gnuradio-core/src/lib/swig/gr_shared_ptr.i b/gnuradio-core/src/lib/swig/gr_shared_ptr.i
new file mode 100644 (file)
index 0000000..9663033
--- /dev/null
@@ -0,0 +1,43 @@
+//
+//  shared_ptr
+//
+//  An enhanced relative of scoped_ptr with reference counted copy semantics.
+//  The object pointed to is deleted when the last shared_ptr pointing to it
+//  is destroyed or reset.
+//
+
+//
+// This is highly hacked up version of boost::shared_ptr
+// We just need enough to get SWIG to "do the right thing" and
+// generate "Smart Pointer" code.
+//
+
+namespace boost {
+
+template<class T> class shared_ptr
+{
+public:
+
+    shared_ptr()
+    {
+    }
+
+    shared_ptr (T * p)
+    {
+    }
+
+
+    T * operator-> () // never throws
+    {
+        return px;
+    }
+    
+
+private:
+
+    T * px;                     // contained pointer
+    int pn;
+
+};  // shared_ptr
+
+};
\ No newline at end of file
diff --git a/gnuradio-core/src/lib/swig/gr_swig_block_magic.i b/gnuradio-core/src/lib/swig/gr_swig_block_magic.i
new file mode 100644 (file)
index 0000000..083d606
--- /dev/null
@@ -0,0 +1,45 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+%define GR_SWIG_BLOCK_MAGIC(PKG, BASE_NAME)
+_GR_SWIG_BLOCK_MAGIC_HELPER(PKG, PKG ## _ ## BASE_NAME, BASE_NAME)
+%enddef
+
+%define _GR_SWIG_BLOCK_MAGIC_HELPER(PKG, NAME, BASE_NAME)
+class NAME;
+typedef boost::shared_ptr<NAME> NAME ## _sptr;
+%template(NAME ## _sptr) boost::shared_ptr<NAME>;
+%rename(BASE_NAME) PKG ## _make_ ## BASE_NAME;
+%inline {
+  gr_block_sptr NAME ## _block (NAME ## _sptr r)
+  {
+    return gr_block_sptr (r);
+  }
+}
+
+%pythoncode %{
+NAME ## _sptr.block = lambda self: NAME ## _block (self)
+NAME ## _sptr.__repr__ = lambda self: "<gr_block %s (%d)>" % (self.name(), self.unique_id ())
+%}
+
+%ignore NAME;
+%enddef
diff --git a/gnuradio-core/src/lib/swig/shared_ptr.i b/gnuradio-core/src/lib/swig/shared_ptr.i
deleted file mode 100644 (file)
index 9663033..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-//
-//  shared_ptr
-//
-//  An enhanced relative of scoped_ptr with reference counted copy semantics.
-//  The object pointed to is deleted when the last shared_ptr pointing to it
-//  is destroyed or reset.
-//
-
-//
-// This is highly hacked up version of boost::shared_ptr
-// We just need enough to get SWIG to "do the right thing" and
-// generate "Smart Pointer" code.
-//
-
-namespace boost {
-
-template<class T> class shared_ptr
-{
-public:
-
-    shared_ptr()
-    {
-    }
-
-    shared_ptr (T * p)
-    {
-    }
-
-
-    T * operator-> () // never throws
-    {
-        return px;
-    }
-    
-
-private:
-
-    T * px;                     // contained pointer
-    int pn;
-
-};  // shared_ptr
-
-};
\ No newline at end of file
index d28bddd40480c29ee4e3a071b897b9b04f9a6cb7..6396a97d06240be961c41f714a0e45c5a3f8d6b4 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
 %module(directors="1") gnuradio_swig_py_filter
 #endif
 
+ //%feature("autodoc", "1");           // generate python docstrings
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"                           // the common stuff
-
-%{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-%}
+%include "gnuradio.i"                          // the common stuff
 
 %include "filter.i"
index 200e6fed984c63c362a5504de51932f2f58f9a2c..3ab1b056a792a517c55b904aee3457ceed95d755 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
 %module(directors="1") gnuradio_swig_py_general
 #endif
 
+ //%feature("autodoc", "1");           // generate python docstrings
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"                           // the common stuff
-
-%{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-%}
+%include "gnuradio.i"                          // the common stuff
 
 %include "general.i"
index b885500b74b68e9114d2f68a67bf0a241eb3f8eb..95e85cf6b8fe4d8147b823de37e9b653a6b9ba9b 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
 %module(directors="1") gnuradio_swig_py_gengen
 #endif
 
+ //%feature("autodoc", "1");           // generate python docstrings
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"                           // the common stuff
-
-%{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-%}
+%include "gnuradio.i"                          // the common stuff
 
 %include "gengen.i"
index acbe1adbe146b0d4b533db783fa5b98835e42342..9318f5d86b7984fba736d14ac3e22d58f7d14fc9 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
 %module(directors="1") gnuradio_swig_py_io
 #endif
 
+ //%feature("autodoc", "1");           // generate python docstrings
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"                           // the common stuff
-
-%{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-%}
+%include "gnuradio.i"                          // the common stuff
 
 %include "io.i"
diff --git a/gnuradio-core/src/lib/swig/sw_runtime.i b/gnuradio-core/src/lib/swig/sw_runtime.i
new file mode 100644 (file)
index 0000000..8f444f9
--- /dev/null
@@ -0,0 +1,32 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifndef SWIGIMPORTED
+%module(directors="1") gnuradio_swig_py_runtime
+#endif
+
+ //%feature("autodoc", "1");           // generate python docstrings
+
+#define SW_RUNTIME
+%include "gnuradio.i"                          // the common stuff
+
+%include "runtime.i"
index 77f5b75f2cfad1700ff5f5ad4a755c646362297a..e9746551aa13b19fe5f0a47c9b49a5e34f18c6fa 100644 (file)
@@ -1,13 +1,28 @@
 /* -*- c++ -*- */
-
-%feature("autodoc", "1");                      // generate python docstrings
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-#include <stdexcept>
 #include <atsc_randomizer.h>
 #include <atsc_derandomizer.h>
 #include <atsc_rs_encoder.h>
index 1a01cf79aa6948cf231abab32a99a68e48b8a877..88402333a193e36753d97142d15314cb0a88a5e2 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004,2006 Free Software Foundation, Inc.
+ * Copyright 2004,2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_alsa_sink.h"
 #include "audio_alsa_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index a5fb606a627e49e01c2d567fbc487a3f03bc6e35..62d70d399f1880da883d373027cb967be2971c59 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2005 Free Software Foundation, Inc.
+ * Copyright 2005,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_jack_sink.h"
 #include "audio_jack_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index a9dec9eb307ac7a3d5e8f5fdd2444a91686540d9..0a2e6e6a4d23088efb98243b2d8c95b6bbca80f1 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2004,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_oss_sink.h"
 #include "audio_oss_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 77c0ce68a6ca55e66633b5ff328abd539accfd6c..7be487269da181908643064bed08ae25c3b66682 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio.
  *
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_osx_sink.h"
 #include "audio_osx_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index ee6a3ae24968c5a7a5c79f6b3658f8003b018576..b0ec2438d2a5116f23091e892da3c3dde3da8dd5 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2004,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_portaudio_sink.h"
 #include "audio_portaudio_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 17ce02b5bbb5c85603299db9eaca7c985b21b0ca..b5b6f562ef0f60e4cd698f469b374368be788fef 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2004 Free Software Foundation, Inc.
+ * Copyright 2004,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "audio_windows_sink.h"
 #include "audio_windows_source.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index ac0c0a3edb7d4c7da57a6c1eda31f29c85f227a0..cdb77aee047f0c99ef898a6e37954dfc51cbd80c 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2005 Free Software Foundation, Inc.
+ * Copyright 2005,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "comedi_sink_s.h"
 #include "comedi_source_s.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index e8f8309fbcf5c9ac9c6fb23e2bb163e91e70ebcd..bf7a0b59fd823baa655e6fc4eb3d3a20eb7bf1fc 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2007 Free Software Foundation, Inc.
+ * Copyright 2007,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-%include "exception.i"
-%import "gnuradio.i"
+%include "gnuradio.i"
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "cvsd_encode_sb.h"
 #include "cvsd_decode_bs.h"
-#include <stdexcept>
 %}
 
 GR_SWIG_BLOCK_MAGIC(cvsd,encode_sb);
index cbe7abcc7709ac0efe2f306276c45e2e8dc6d4f4..29e69fdf7e4c3d75bc90e35c7e3ecd203a8fd898 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2008 Free Software Foundation, Inc.
+ * Copyright 2008,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
  */
 
-%feature("autodoc","1");
-
-//%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-//#include <stdexcept>
-
 #include <gcell/gc_job_manager.h>
-#include <gcell_fft_vcc.h>  
-
+#include <gcell_fft_vcc.h>
 %}
 
 %include "gc_job_manager.i"
index 8544e9138643ef012ad07f0f144b337cdedbf4e2..b65777d3c878f347199ca194c184e66522d79a7d 100644 (file)
@@ -1,14 +1,29 @@
 /* -*- c++ -*- */
-
-%feature("autodoc", "1");              // generate python docstrings
-
-%include "exception.i"
-%import "gnuradio.i"                   // the common stuff
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+%include "gnuradio.i"                  // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "gpio_and_const_ss.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 63beb95d7cfd811a6997d6ab968a11969a229b28..535faa7fca7f0c7226c0057afe67d2e624e04ca0 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2005 Free Software Foundation, Inc.
+ * Copyright 2005,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-%include "exception.i"
-%import "gnuradio.i"
+%include "gnuradio.i"
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "gsm_fr_encode_sp.h"
 #include "gsm_fr_decode_ps.h"
-#include <stdexcept>
 %}
 
 GR_SWIG_BLOCK_MAGIC(gsm_fr,encode_sp);
index 3d46ab47238ad32ea774bdcb4478eee717e85a9c..c3dae9dfc1ce9a7b7028b544c7e0aaae7c144475 100644 (file)
@@ -1,15 +1,10 @@
 /* -*- c++ -*- */
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%include "exception.i"
-%import "gnuradio.i"                   // the common stuff
+%include "gnuradio.i"                  // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "howto_square_ff.h"
 #include "howto_square2_ff.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 5046bb19643faf7c65647632e46d3835551af941..d122d4741abf3b90bb9e5f22d60176fc384aadbc 100644 (file)
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"   // the common stuff
+%include "gnuradio.i"  // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "msdd_source_s.h"
 #include "msdd_source_c.h"
 #include "msdd_source_simple.h"
index e6530be539782177129f11ff971748c0389645fd..aeb576db738bed3c93b32cb8c4d3e7f9354aa697 100644 (file)
@@ -1,5 +1,5 @@
 /*
- * Copyright 2005,2006 Free Software Foundation, Inc.
+ * Copyright 2005,2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-%include "exception.i"
-%import "gnuradio.i"
+%include "gnuradio.i"
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "pager_flex_frame.h"
 #include "pager_slicer_fb.h"
 #include "pager_flex_sync.h"
 #include "pager_flex_deinterleave.h"
 #include "pager_flex_parse.h"
-#include <stdexcept>
 %}
 
 %include "pager_flex_frame.i"
index 52156054ca7bbf785127b0e55ea5a854e60ba2a7..129e9269ed43b3980ac8d45dca07c33b8fc2a0ad 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2008 Free Software Foundation, Inc.
+ * Copyright 2008,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-%include "exception.i"
-%import "gnuradio.i"
+%include "gnuradio.i"
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "qtgui_sink_c.h"
 #include "qtgui_sink_f.h"
-#include <stdexcept>
 %}
 
 GR_SWIG_BLOCK_MAGIC(qtgui,sink_c)
index 15cfbfb34bb5822e44d7e6909a12f611cc7cb87f..e258b876921565f13efd177574fd5e535cd69230 100644 (file)
@@ -1,14 +1,26 @@
 /* -*- c++ -*- */
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%include "exception.i"
-%import "gnuradio.i"                   // the common stuff
-
-%{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
-#include <stdexcept>
-%}
+%include "gnuradio.i"                  // the common stuff
 
 // We'll need something like this if we add C++ blocks...
 // See the gr-howto-write-a-block tarball for examples
index 6f00f8c38c6d0e8c7d9f7e449e93d4c6a8ef1a92..ed1fe29caafb66f832f31a8de6c958dc95906fa6 100644 (file)
@@ -1,18 +1,33 @@
 /* -*- c++ -*- */
-
-%feature("autodoc", "1");              // generate python docstrings
-
-%include "exception.i"
-%import "gnuradio.i"                   // the common stuff
+/*
+ * Copyright 2009 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 3, or (at your option)
+ * any later version.
+ *
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+%include "gnuradio.i"                  // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "fsm.h"
 #include "interleaver.h"
 #include "trellis_permutation.h"
 #include "trellis_siso_f.h"
 #include "trellis_siso_combined_f.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 07dcb419e065c1ab700f8ab7707f85df93e91a6e..55ad2a763ae524ccd9c917d4b30956be8614073e 100644 (file)
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"   // the common stuff
+%include "gnuradio.i"  // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include <vector>
 %}
 
index c9a4af590d97d4f0696b0d71da53f9e5dd12ed56..f49a0cafbda9fe9d38e317509fd31e39a61be7e3 100644 (file)
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc", "1");              // generate python docstrings
-
-%import "gnuradio.i"   // the common stuff
-%import <stdint.i>     
+%include "gnuradio.i"  // the common stuff
+%import <stdint.i>
 
 %{
-#include <gnuradio_swig_bug_workaround.h>
 #include "usrp2_source_16sc.h"
 #include "usrp2_source_32fc.h"
 #include "usrp2_sink_16sc.h"
index 9cfa1589ff9a2a37fa8f3513d8c9a0517f7e8913..7084c209b9710c73f0fab0f31e82f9d6e23b21f6 100644 (file)
@@ -1,6 +1,6 @@
 /* -*- c++ -*- */
 /*
- * Copyright 2006 Free Software Foundation, Inc.
+ * Copyright 2006,2009 Free Software Foundation, Inc.
  * 
  * This file is part of GNU Radio
  * 
  * Boston, MA 02110-1301, USA.
  */
 
-%feature("autodoc","1");
-
-%include "exception.i"
-%import "gnuradio.i"                           // the common stuff
+%include "gnuradio.i"                          // the common stuff
 
 %{
-#include "gnuradio_swig_bug_workaround.h"      // mandatory bug fix
 #include "video_sdl_sink_uc.h"
 #include "video_sdl_sink_s.h"
-#include <stdexcept>
 %}
 
 // ----------------------------------------------------------------
index 3e567637ea1d880b56f5c52377f36b1c35419855..bd5483aa8c9efc0482cf4b4a6666be109e480a2f 100644 (file)
@@ -1,12 +1,12 @@
 /* -*- c++ -*- */
 //
-// Copyright 2008 Free Software Foundation, Inc.
+// Copyright 2008,2009 Free Software Foundation, Inc.
 // 
 // This file is part of GNU Radio
 // 
 // GNU Radio is free software; you can redistribute it and/or modify
 // it under the terms of the GNU General Public License as published by
-// the Free Software Foundation; either asversion 3, or (at your option)
+// the Free Software Foundation; either version 3, or (at your option)
 // any later version.
 // 
 // GNU Radio is distributed in the hope that it will be useful,
@@ -25,7 +25,7 @@
 #include "db_base.h"
 %}
 
-%include <shared_ptr.i>
+%include <gr_shared_ptr.i>
 
 class usrp_tune_result
 {