Merge tag 'debian/1.8.5p2-1' into squeeze
authorBdale Garbee <bdale@gag.com>
Tue, 25 Sep 2012 16:23:23 +0000 (10:23 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 25 Sep 2012 16:23:23 +0000 (10:23 -0600)
Conflicts:
debian/changelog
plugins/sudoers/check.c
plugins/sudoers/env.c

debian/changelog
debian/gbp.conf
plugins/sudoers/env.c

index e03915c18443b05c819aeeb045f0abca324df905..84dbd0479a4bbd57cc2b6846ca3f0d87e403f9a7 100644 (file)
@@ -1,3 +1,9 @@
+sudo (1.8.5p2-1~bpo60+1) squeeze-backports; urgency=low
+
+  * backport of version targeted for wheezy release by user request
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 25 Sep 2012 10:20:29 -0600
+
 sudo (1.8.5p2-1) unstable; urgency=low
 
   * new upstream version
@@ -130,6 +136,21 @@ sudo (1.7.4p4-3) unstable; urgency=low
 
  -- Bdale Garbee <bdale@gag.com>  Tue, 21 Sep 2010 23:53:08 -0600
 
+sudo (1.7.4p4-2.squeeze.2) stable; urgency=low
+
+  * patch from upstream to resolve interoperability problem between HOME in
+    env_keep and the -H flag, originally closed #596493, applying this to
+    to squeeze also closes: #614232
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 20 Feb 2011 09:35:07 -0700
+
+sudo (1.7.4p4-2.squeeze.1) testing; urgency=low
+
+  * patch from upstream to fix special case in password checking code
+    when only the gid is changing, closes #609641
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 26 Jan 2011 09:08:12 +1000
+
 sudo (1.7.4p4-2) unstable; urgency=low
 
   * add a NEWS item about change in $HOME handling that impacts programs
index 95106891f35a53f40cb894f2be222a5775e192a6..959c07bcda4bad4801c44c794e4d8f11234c80de 100644 (file)
@@ -8,7 +8,7 @@
 # the default branch for upstream sources:
 upstream-branch = upstream
 # the default branch for the debian patch:
-debian-branch = master
+debian-branch = squeeze
 # the default tag formats used:
 #upstream-tag = upstream/%(version)s
 #debian-tag = debian/%(version)s
index 9b043b282eb756d7a76e9912119a30e03a13da06..962228ccf4e7e985e90ae2b585506fb1f8bc3e76 100644 (file)
@@ -741,6 +741,15 @@ rebuild_env(void)
                env_update_didvar(*ep, &didvar);
        }
 
+    /* Reset HOME based on target user if configured to. */
+    if (ISSET(sudo_mode, MODE_RUN)) {
+       if (def_always_set_home ||
+           ISSET(sudo_mode, MODE_RESET_HOME | MODE_LOGIN_SHELL) || 
+           (ISSET(sudo_mode, MODE_SHELL) && def_set_home))
+           reset_home = TRUE;
+    }
+
+    if (def_env_reset || ISSET(sudo_mode, MODE_LOGIN_SHELL)) {
        /* Pull in vars we want to keep from the old environment. */
        for (ep = old_envp; *ep; ep++) {
            bool keepit;