* Makefile.am (FILES_TO_CHECK): New macro.
authorPaul Eggert <eggert@cs.ucla.edu>
Sun, 26 Nov 2006 06:00:49 +0000 (06:00 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Sun, 26 Nov 2006 06:00:49 +0000 (06:00 +0000)
(check-local): Check only the files in FILES_TO_CHECK, since some
files under the working directory might be mutating as the test is
run, e.g., with "make check >log".  Problem reported by Jim
Meyering.

ChangeLog
Makefile.am

index dda185fcfefa699995c730e8d3958574d1254bd2..22d6179535ba472ae14dafc21af30b4047ad89b6 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2006-11-25  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * Makefile.am (FILES_TO_CHECK): New macro.
+       (check-local): Check only the files in FILES_TO_CHECK, since some
+       files under the working directory might be mutating as the test is
+       run, e.g., with "make check >log".  Problem reported by Jim
+       Meyering.
+
 2006-11-20  Paul Eggert  <eggert@cs.ucla.edu>
 
        * NEWS, configure.ac (AC_INIT):
index af00e4d0bcb51a4df058110259f15b6495df037d..3d7adfbc91a1c3ebeeee7e6d163d7a96914ca521 100644 (file)
@@ -59,9 +59,10 @@ SUFFIXES = .in
        chmod a+x $@
 
 # A simple test, just of gzip -- more of a sanity check than anything else.
-check-local:
-       for file in `find * -type f -print | sort`; do \
-         test -r "$$file" || continue; \
+FILES_TO_CHECK = $(bin_SCRIPTS) $(gzip_LDADD) \
+  $(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
+check-local: $(FILES_TO_CHECK)
+       for file in $(FILES_TO_CHECK); do \
          ./gzip -cv $$file | ./gzip -d | cmp - "$$file" || exit; \
        done
        @echo 'Test succeeded.'