tests: arrange for skip and failure notices to go to stderr, not .log
authorJim Meyering <meyering@redhat.com>
Tue, 6 Apr 2010 07:08:03 +0000 (09:08 +0200)
committerJim Meyering <meyering@redhat.com>
Tue, 6 Apr 2010 16:28:56 +0000 (18:28 +0200)
* tests/init.cfg: New file.  Make init.sh's stderr_fileno_ match
what the "exec 9>&2" we use in TESTS_ENVIRONMENT.
* Makefile.am (EXTRA_DIST): Add it.

Makefile.am
tests/init.cfg [new file with mode: 0644]

index c7ab7f2a95796c89a2e983a849cf268748d877a2..d331e03050c25871e5f825750e3a81488f438f53 100644 (file)
@@ -120,6 +120,7 @@ TESTS =                                             \
   tests/znew-k
 
 EXTRA_DIST += $(TESTS)
+EXTRA_DIST += tests/init.cfg
 
 install-exec-hook: remove-installed-links
 install-exec-hook remove-installed-links:
diff --git a/tests/init.cfg b/tests/init.cfg
new file mode 100644 (file)
index 0000000..901209c
--- /dev/null
@@ -0,0 +1,5 @@
+# This file is sourced by init.sh, *before* its initialization.
+
+# This goes hand in hand with the "exec 9>&2;" in Makefile.am's
+# TESTS_ENVIRONMENT definition.
+stderr_fileno_=9