Update Debian packaging to reflect repository version, tweaks
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Sun, 21 Oct 2007 19:56:42 +0000 (19:56 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Sun, 21 Oct 2007 19:56:42 +0000 (19:56 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6660 221aa14e-8319-0410-a670-987f0aec2ac5

config/Makefile.am
config/gr_subversion.m4 [new file with mode: 0644]
configure.ac
debian/build-all.sh
debian/build-bin.sh
debian/build-src.sh
debian/changelog [deleted file]
debian/changelog.in [new file with mode: 0644]
debian/control

index be85ce7c8c1f396ddc3e3a6632e018c33b5b231f..6c5dd28cc1219c1d40aa98f0ea29298618ee1eaa 100644 (file)
@@ -67,6 +67,7 @@ m4macros = \
        gr_require_mc4020.m4 \
        gr_scripting.m4 \
        gr_set_md_cpu.m4 \
+       gr_subversion.m4 \
        gr_swig.m4 \
        gr_sysv_shm.m4 \
        gr_x86_64.m4 \
diff --git a/config/gr_subversion.m4 b/config/gr_subversion.m4
new file mode 100644 (file)
index 0000000..44ae49f
--- /dev/null
@@ -0,0 +1,36 @@
+dnl
+dnl Copyright 2007 Free Software Foundation, Inc.
+dnl 
+dnl This file is part of GNU Radio
+dnl 
+dnl GNU Radio is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3, or (at your option)
+dnl any later version.
+dnl 
+dnl GNU Radio is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+dnl GNU General Public License for more details.
+dnl 
+dnl You should have received a copy of the GNU General Public License
+dnl along with GNU Radio; see the file COPYING.  If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
+dnl 
+
+# GR_SUBVERSION()
+#
+# Test for presence of subversion, and create variables for 
+# current repository version and last changed date.
+
+AC_DEFUN([GR_SUBVERSION],[
+       AC_CHECK_PROG([SVN],[svn],[`which svn`])
+       if ! test -z $SVN ; then
+           SVNVERSION=`$SVN info . | grep '^Revision' | cut -f 2- -d ' '`
+           SVNDATE=`$SVN info . | grep 'Last Changed Date' | cut -f 4-6 -d ' '`
+       fi
+
+       AC_SUBST([SVNVERSION],[$SVNVERSION])
+       AC_SUBST([SVNDATE],[$SVNDATE])
+])
index e1a6c4df4afd36426b29a2d250cc302a73b141f0..3207b4bd201f8eaad8092b11c90f99e90761e21a 100644 (file)
@@ -186,6 +186,9 @@ dnl Define where to find boost includes
 dnl defines BOOST_CFLAGS
 GR_REQUIRE_BOOST_INCLUDES
 
+# If this is being done from a subversion tree, create variables
+GR_SUBVERSION
+
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
 AC_ARG_ENABLE(
@@ -229,6 +232,7 @@ AC_CONFIG_FILES([\
     Makefile \
     run_tests.sh
     config/Makefile
+    debian/changelog
 ])
 
 dnl run_tests.sh is created from run_tests.in.sh.  Make it executable.
index 0b3ec2460b6844376504708e4894e6bcc774eb62..dd03b729988d74cbed20c21d5d30afbfb95207e3 100755 (executable)
@@ -3,10 +3,5 @@
 cd ..
 svn-buildpackage \
     --svn-ignore-new \
-    -uc \
-    -us \
     -rfakeroot
 
-cd ../build-area
-dpkg-scanpackages . /dev/null | gzip -9c > Packages.gz
-
index a6298da49c5a9fc59f06784606fab638657b0c80..2ffea9e456224c83a9017a2347a3c4e6c6f216da 100755 (executable)
@@ -6,8 +6,6 @@ svn-buildpackage \
     --svn-dont-clean \
     --svn-dont-purge \
     --svn-reuse \
-    -uc \
-    -us \
     -nc \
     -rfakeroot
 
index adad7c22abf9ebd4bd9968b20433a2a03c79a79f..1a7c92047fa72bf1fcfbc80670987f65b9719d20 100755 (executable)
@@ -4,8 +4,6 @@ cd ..
 svn-buildpackage \
     --svn-ignore-new \
     -S \
-    -uc \
-    -us \
     -rfakeroot
 
 
diff --git a/debian/changelog b/debian/changelog
deleted file mode 100644 (file)
index 853584c..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-gnuradio (3.1.svn) unstable; urgency=low
-
-  * post release 3.1 trunk repository packages
-
- -- Bdale Garbee <bdale@gag.com>  Sat, 13 Oct 2007 14:50:00 -0600
-
-gnuradio (3.0.svn) unstable; urgency=low
-
-  * add/split packages to cover entire GNU Radio distribution
-  * fix build failure with gcc-4.3 by adding a #include, closes: #420896
-  * update copyright assertion on the debian/ contents, since I have
-    assigned my copyright to the FSF and now have upstream commit rights
-  * merge debian/ into upstream SVN repository
-  * add --disable-gr-qtgui (at least until we figure out qwt build deps!)
-  * add build dep on python-numpy
-  * conditionalize configure and clean targets to handle build from SVN
-
- -- Bdale Garbee <bdale@gag.com>  Thu, 26 Jul 2007 18:07:52 -0600
-
-gnuradio (3.0.3-1) unstable; urgency=low
-
-  * new upstream version
-  * tweak gnuradio-doc package to eliminate spurious subdirectory level
-  * add a usrp-doc binary package, recommended by the usrp package, and 
-    include xmlto in build dependencies so usrp_guide.html gets generated, 
-    closes: #407368
-
- -- Bdale Garbee <bdale@gag.com>  Sun, 11 Mar 2007 23:55:32 -0600
-
-gnuradio (3.0.2-2) unstable; urgency=high
-
-  * add run-time dependency on python-wxgtk2.6.  leaving urgency high since 
-    this would be a silly bug to release etch with if we can avoid it.
-
- -- Bdale Garbee <bdale@gag.com>  Mon,  4 Dec 2006 15:35:53 -0700
-
-gnuradio (3.0.2-1) unstable; urgency=high
-
-  * new upstream version, fixes FTBFS issues
-
- -- Bdale Garbee <bdale@gag.com>  Sun, 12 Nov 2006 14:52:33 -0800
-
-gnuradio (3.0-3) unstable; urgency=high
-
-  * put python-all-dev back in the build-depends list, closes: #398246
-  * move gr-wxgui conflicts/depends to python-gnuradio, closes: #396302
-  * fix up sections in control to match overrides
-
- -- Bdale Garbee <bdale@gag.com>  Sun, 12 Nov 2006 10:59:58 -0800
-
-gnuradio (3.0-2) unstable; urgency=high
-
-  * reworked package dependencies so that the 'gnuradio' binary package no
-    longer depends on the pieces in contrib.  instead, the 'usrp' binary
-    package in contrib now depends on all the USRP-related pieces.  A user
-    who doesn't have a USRP board can just install 'gnuradio' and get all
-    the relevant pieces, a USRP user needs to install both 'gnuradio' and
-    'usrp'.  Closes: #394533
-  * improve consistency of references to 'GNU Radio' as upstream project name
-  * make the gnuradio package dependencies on python-gnuradio and python-usrp
-    be version specific on suggestion from Ramakrishnan Muthukrishnan
-
- -- Bdale Garbee <bdale@gag.com>  Fri, 10 Nov 2006 00:39:38 -0800
-
-gnuradio (3.0-1) unstable; urgency=low
-
-  * new maintainer, new upstream version
-  * Restructuring source and binary packages to follow upstream changes, more
-    or less repackaging from scratch taking ideas from the previous packaging
-    by Ramakrishnan Muthukrishnan and Steinar H. Gunderson.  This single 
-    source package replaces all of: 
-        gnuradio-core
-        gnuradio-examples
-        gr-audio-alsa
-        gr-audio-jack
-        gr-audio-oss
-        gr-usrp
-        gr-wxgui
-        usrp
-    In addition, the 'gnuradio' binary package is a new meta-package that 
-    conveniently depends on everything gnuradio related to ease installation.
-
- -- Bdale Garbee <bdale@gag.com>  Sun,  8 Oct 2006 13:28:21 -0600
-
diff --git a/debian/changelog.in b/debian/changelog.in
new file mode 100644 (file)
index 0000000..092f7b7
--- /dev/null
@@ -0,0 +1,84 @@
+gnuradio (3.1.svn-r@SVNVERSION@) unstable; urgency=low
+
+  * post release 3.1 trunk repository packages
+
+ -- Johnathan Corgan <jcorgan@corganenterprises.com> @SVNDATE@
+gnuradio (3.0.svn) unstable; urgency=low
+
+  * add/split packages to cover entire GNU Radio distribution
+  * fix build failure with gcc-4.3 by adding a #include, closes: #420896
+  * update copyright assertion on the debian/ contents, since I have
+    assigned my copyright to the FSF and now have upstream commit rights
+  * merge debian/ into upstream SVN repository
+  * add --disable-gr-qtgui (at least until we figure out qwt build deps!)
+  * add build dep on python-numpy
+  * conditionalize configure and clean targets to handle build from SVN
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 26 Jul 2007 18:07:52 -0600
+
+gnuradio (3.0.3-1) unstable; urgency=low
+
+  * new upstream version
+  * tweak gnuradio-doc package to eliminate spurious subdirectory level
+  * add a usrp-doc binary package, recommended by the usrp package, and 
+    include xmlto in build dependencies so usrp_guide.html gets generated, 
+    closes: #407368
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 11 Mar 2007 23:55:32 -0600
+
+gnuradio (3.0.2-2) unstable; urgency=high
+
+  * add run-time dependency on python-wxgtk2.6.  leaving urgency high since 
+    this would be a silly bug to release etch with if we can avoid it.
+
+ -- Bdale Garbee <bdale@gag.com>  Mon,  4 Dec 2006 15:35:53 -0700
+
+gnuradio (3.0.2-1) unstable; urgency=high
+
+  * new upstream version, fixes FTBFS issues
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 12 Nov 2006 14:52:33 -0800
+
+gnuradio (3.0-3) unstable; urgency=high
+
+  * put python-all-dev back in the build-depends list, closes: #398246
+  * move gr-wxgui conflicts/depends to python-gnuradio, closes: #396302
+  * fix up sections in control to match overrides
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 12 Nov 2006 10:59:58 -0800
+
+gnuradio (3.0-2) unstable; urgency=high
+
+  * reworked package dependencies so that the 'gnuradio' binary package no
+    longer depends on the pieces in contrib.  instead, the 'usrp' binary
+    package in contrib now depends on all the USRP-related pieces.  A user
+    who doesn't have a USRP board can just install 'gnuradio' and get all
+    the relevant pieces, a USRP user needs to install both 'gnuradio' and
+    'usrp'.  Closes: #394533
+  * improve consistency of references to 'GNU Radio' as upstream project name
+  * make the gnuradio package dependencies on python-gnuradio and python-usrp
+    be version specific on suggestion from Ramakrishnan Muthukrishnan
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 10 Nov 2006 00:39:38 -0800
+
+gnuradio (3.0-1) unstable; urgency=low
+
+  * new maintainer, new upstream version
+  * Restructuring source and binary packages to follow upstream changes, more
+    or less repackaging from scratch taking ideas from the previous packaging
+    by Ramakrishnan Muthukrishnan and Steinar H. Gunderson.  This single 
+    source package replaces all of: 
+        gnuradio-core
+        gnuradio-examples
+        gr-audio-alsa
+        gr-audio-jack
+        gr-audio-oss
+        gr-usrp
+        gr-wxgui
+        usrp
+    In addition, the 'gnuradio' binary package is a new meta-package that 
+    conveniently depends on everything gnuradio related to ease installation.
+
+ -- Bdale Garbee <bdale@gag.com>  Sun,  8 Oct 2006 13:28:21 -0600
+
index 14456dab042070d700e0f12066e63ac784796a86..0e980a4413b29f375fe9adc42323326cc04ff411 100644 (file)
@@ -1,7 +1,7 @@
 Source: gnuradio
 Section: comm
 Priority: optional
-Maintainer: Bdale Garbee <bdale@gag.com>
+Maintainer: Johnathan Corgan <jcorgan@corganenterprises.com>
 Build-Conflicts: automake1.8, automake1.9
 Build-Depends: debhelper (>= 5.0.37.2), autotools-dev, doxygen, fftw3-dev | libfftw3-dev, libasound2-dev, libboost-dev, libcppunit-dev, libjack0.100.0-dev, libsdl1.2-dev, portaudio19-dev, libtool, libusb-dev, pkg-config, python, python-all-dev, python-central (>= 0.5), python-numpy, python-wxgtk2.6, sdcc, swig, xmlto
 Standards-Version: 3.7.2