Move gr_runtime.h out of the way in preparation for merge of hier developer branch...
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 12 Dec 2006 18:11:13 +0000 (18:11 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 12 Dec 2006 18:11:13 +0000 (18:11 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4068 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/lib/runtime/Makefile.am
gnuradio-core/src/lib/runtime/gr_block.h
gnuradio-core/src/lib/runtime/gr_block_detail.h
gnuradio-core/src/lib/runtime/gr_buffer.h
gnuradio-core/src/lib/runtime/gr_io_signature.h
gnuradio-core/src/lib/runtime/gr_runtime.h [deleted file]
gnuradio-core/src/lib/runtime/gr_runtime_types.h [new file with mode: 0644]
gnuradio-core/src/lib/runtime/gr_single_threaded_scheduler.h
gnuradio-core/src/lib/runtime/qa_gr_block.cc
gnuradio-core/src/lib/runtime/runtime.i

index cce4e6f8454663b6e025df3de3e3244d9204c4c1..2c1ea7eff02cda72b4890992b92abeffa43484a5 100644 (file)
@@ -74,7 +74,7 @@ grinclude_HEADERS =                           \
        gr_pagesize.h                           \
        gr_preferences.h                        \
        gr_realtime.h                           \
-       gr_runtime.h                            \
+       gr_runtime_types.h                      \
        gr_select_handler.h                     \
        gr_single_threaded_scheduler.h          \
        gr_timer.h                              \
index 8b234c751728286be4b4cfa4f3e4483e96de0bee..9723be1085dbd05e12156cae88f77d9437e8d490 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef INCLUDED_GR_BLOCK_H
 #define INCLUDED_GR_BLOCK_H
 
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 #include <string>
 
 /*!
index c3e360cd1f5506f12f321a2955b7a62819efa17d..8c46159194aa91b81e1048ebf0e6a7345294d71f 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef INCLUDED_GR_BLOCK_DETAIL_H
 #define INCLUDED_GR_BLOCK_DETAIL_H
 
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 #include <stdexcept>
 
 /*!
index 506a16616b5e08aef9e616a50c283f2f960ccee6..46017f6ad6f4a8fc25a062bc3d8f4b0ed3063aba 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef INCLUDED_GR_BUFFER_H
 #define INCLUDED_GR_BUFFER_H
 
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 
 class gr_vmcircbuf;
 
index c146193bc1b08f645666a4fd2218e0509543a9ed..e5e009781a6c14446d9739d34db66a7c89e053e5 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef INCLUDED_IO_SIGNATURE_H
 #define INCLUDED_IO_SIGNATURE_H
 
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 
 /*!
  * \brief i/o signature for input and output ports.
diff --git a/gnuradio-core/src/lib/runtime/gr_runtime.h b/gnuradio-core/src/lib/runtime/gr_runtime.h
deleted file mode 100644 (file)
index 55cbabe..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2004 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#ifndef INCLUDED_GR_RUNTIME_H
-#define INCLUDED_GR_RUNTIME_H
-
-#include <gr_types.h>
-
-/*
- * typedefs for smart pointers we use throughout the runtime system
- */
-
-class gr_block;
-class gr_block_detail;
-class gr_io_signature;
-class gr_buffer;
-class gr_buffer_reader;
-
-typedef boost::shared_ptr<gr_block>            gr_block_sptr;
-typedef boost::shared_ptr<gr_block_detail>     gr_block_detail_sptr;
-typedef boost::shared_ptr<gr_io_signature>     gr_io_signature_sptr;
-typedef boost::shared_ptr<gr_buffer>           gr_buffer_sptr;
-typedef boost::shared_ptr<gr_buffer_reader>    gr_buffer_reader_sptr;
-
-#endif /* INCLUDED_GR_RUNTIME_H */
diff --git a/gnuradio-core/src/lib/runtime/gr_runtime_types.h b/gnuradio-core/src/lib/runtime/gr_runtime_types.h
new file mode 100644 (file)
index 0000000..55cbabe
--- /dev/null
@@ -0,0 +1,44 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifndef INCLUDED_GR_RUNTIME_H
+#define INCLUDED_GR_RUNTIME_H
+
+#include <gr_types.h>
+
+/*
+ * typedefs for smart pointers we use throughout the runtime system
+ */
+
+class gr_block;
+class gr_block_detail;
+class gr_io_signature;
+class gr_buffer;
+class gr_buffer_reader;
+
+typedef boost::shared_ptr<gr_block>            gr_block_sptr;
+typedef boost::shared_ptr<gr_block_detail>     gr_block_detail_sptr;
+typedef boost::shared_ptr<gr_io_signature>     gr_io_signature_sptr;
+typedef boost::shared_ptr<gr_buffer>           gr_buffer_sptr;
+typedef boost::shared_ptr<gr_buffer_reader>    gr_buffer_reader_sptr;
+
+#endif /* INCLUDED_GR_RUNTIME_H */
index 304199bf2750230265ce1242303a8d54b9c67ee7..5e21d8d082c089d65db3ca5f510ee8f45c250f5a 100644 (file)
@@ -23,7 +23,7 @@
 #ifndef INCLUDED_GR_SINGLE_THREADED_SCHEDULER_H
 #define INCLUDED_GR_SINGLE_THREADED_SCHEDULER_H
 
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 #include <fstream>
 
 class gr_single_threaded_scheduler;
index becaf4f29aa24f0668a40751b1a5fc2cb2ae0e32..4773a6eaa64e26bd2d78e38c5ced72552ccb9c6f 100644 (file)
@@ -25,7 +25,7 @@
 #endif
 #include <qa_gr_block.h>
 #include <gr_block.h>
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 #include <gr_io_signature.h>
 #include <gr_null_sink.h>
 #include <gr_null_source.h>
index 3b08edd009a42bafd3d9d801e9624d219e9f7ac5..f2fd36437876ed7080d91f96f77227f276cb1798 100644 (file)
@@ -21,7 +21,7 @@
  */
 
 %{
-#include <gr_runtime.h>
+#include <gr_runtime_types.h>
 #include <gr_io_signature.h>
 #include <gr_buffer.h>
 #include <gr_block.h>