Imported Debian patch 1.6.8p7-1.1 debian/1.6.8p7-1.1
authorSteve Langasek <vorlon@debian.org>
Wed, 27 Apr 2005 05:59:06 +0000 (22:59 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 14 May 2008 18:03:33 +0000 (12:03 -0600)
21 files changed:
CHANGES
LICENSE
Makefile.in
TROUBLESHOOTING
auth/pam.c
config.guess
config.sub
debian/changelog
debian/rules
debian/source.lintian-overrides [new file with mode: 0644]
env.c
ldap.c
sudo.c
sudo.cat
sudo.man.in
sudoers.cat
sudoers.man.in
sudoers.pod
version.h
visudo.cat
visudo.man.in

diff --git a/CHANGES b/CHANGES
index d4d5ab765d5bd1615d65083ce7c2ae054c5bff42..928b09f77dc6a891a7ca821313c420f246ee70af 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1764,3 +1764,17 @@ Sudo 1.6.8p4 released.
 556) Invalid values for a tuple are now handled correctly.
 
 Sudo 1.6.8p5 released.
+
+557) Added a set of missing braces needed for MacOS X / Darwin.
+
+558) Define LDAP_OPT_SUCCESS for those without it.
+
+Sudo 1.6.8p6 released.
+
+559) Warn if the user tries to use the -u option when not running a command.
+
+560) Better PAM error handling and messages.
+
+561) Fixed setting of $USER when env_reset is enabled.
+
+Sudo 1.6.8p7 released.
diff --git a/LICENSE b/LICENSE
index 8703535ff31175eaf28fec98b5f04c59d304dedb..70655fa144f8330552e2008743fd98524dff9060 100644 (file)
--- a/LICENSE
+++ b/LICENSE
@@ -1,6 +1,6 @@
 Sudo is distributed under the following ISC-style license:
 
-   Copyright (c) 1994-1996,1998-2004 Todd C. Miller <Todd.Miller@courtesan.com>
+   Copyright (c) 1994-1996,1998-2005 Todd C. Miller <Todd.Miller@courtesan.com>
 
    Permission to use, copy, modify, and distribute this software for any
    purpose with or without fee is hereby granted, provided that the above
index b5585b65a94b65e9b2ebcc2eb30e89ec986b74f0..477ad2b7a8a39c93e5b9f4dcf20ca3a053b247a9 100644 (file)
@@ -130,7 +130,7 @@ TESTOBJS = interfaces.o testsudoers.o $(PARSEOBJS)
 
 LIBOBJS = @LIBOBJS@ @ALLOCA@
 
-VERSION = 1.6.8p5
+VERSION = 1.6.8p7
 
 DISTFILES = $(SRCS) $(HDRS) BUGS CHANGES HISTORY INSTALL INSTALL.configure \
            LICENSE Makefile.in PORTING README README.LDAP RUNSON TODO \
index 94a93ccbcd44e69c456cec01dfda115c0f882f10..3f7dd35a880800dff6e25b12d3a5ebefbf71657d 100644 (file)
@@ -25,9 +25,19 @@ A) The operating system you are running probably has broken support for
    option and rebuild sudo.
 
 Q) Sudo never gives me a chance to enter a password using PAM, it just
-   says 'Sorry, try again.' three times and quits.
-A) You didn't setup PAM to work with sudo.  On Linux this generally
-   means installing sample.pam as /etc/pam.d/sudo.
+   says 'Sorry, try again.' three times and exits.
+A) You didn't setup PAM to work with sudo.  On Redhat Linux or Fedora
+   Core this generally means installing sample.pam as /etc/pam.d/sudo.
+   See the sample.pam file for hints on what to use for other Linux
+   systems.
+
+Q) Sudo says 'Account expired or PAM config lacks an "account"
+   section for sudo, contact your system administrator' and exits
+   but I know my account has not expired.
+A) Your PAM config lacks an "account" specification.  On Linux this
+   usually means you are missing a line like:
+       account    required    pam_unix.so
+   in /etc/pam.d/sudo.
 
 Q) Sudo is setup to log via syslog(3) but I'm not getting any log
    messages.
index 1dc162ab94d1ec3ead702dbc44299e5da2f4ca26..d289a06ef5c3510fdfd34211e5bfc1a6f831d64a 100644 (file)
@@ -91,8 +91,7 @@ pam_init(pw, promptp, auth)
     pam_conv.conv = sudo_conv;
     pam_status = pam_start("sudo", pw->pw_name, &pam_conv, &pamh);
     if (pam_status != PAM_SUCCESS) {
-       log_error(USE_ERRNO|NO_EXIT|NO_MAIL,
-           "unable to initialize PAM");
+       log_error(USE_ERRNO|NO_EXIT|NO_MAIL, "unable to initialize PAM");
        return(AUTH_FATAL);
     }
     if (strcmp(user_tty, "unknown"))
@@ -125,25 +124,30 @@ pam_verify(pw, prompt, auth)
                        *pam_status);
                    return(AUTH_FAILURE);
                case PAM_NEW_AUTHTOK_REQD:
-                   log_error(NO_EXIT|NO_MAIL, "%s, %s"
+                   log_error(NO_EXIT|NO_MAIL, "%s, %s",
                        "Account or password is expired",
                        "reset your password and try again");
-                   *pam_status = pam_chauthtok(pamh, PAM_CHANGE_EXPIRED_AUTHTOK);
+                   *pam_status = pam_chauthtok(pamh,
+                       PAM_CHANGE_EXPIRED_AUTHTOK);
                    if (*pam_status == PAM_SUCCESS)
                        return(AUTH_SUCCESS);
                    if ((s = pam_strerror(pamh, *pam_status)))
-                       log_error(NO_EXIT|NO_MAIL, "pam_chauthtok: %s",s);
+                       log_error(NO_EXIT|NO_MAIL, "pam_chauthtok: %s", s);
                    return(AUTH_FAILURE);
+               case PAM_AUTHTOK_EXPIRED:
+                   log_error(NO_EXIT|NO_MAIL,
+                       "Password expired, contact your system administrator");
+                   return(AUTH_FATAL);
                case PAM_ACCT_EXPIRED:
-                   log_error(NO_EXIT|NO_MAIL, "%s, %s"
-                       "Account or password is expired",
-                       "contact your system administrator");
-                   /* FALLTHROUGH */
-               default:
-                   return(AUTH_FAILURE);
+                   log_error(NO_EXIT|NO_MAIL, "%s %s",
+                       "Account expired or PAM config lacks an \"account\"",
+                       "section for sudo, contact your system administrator");
+                   return(AUTH_FATAL);
            }
+           /* FALLTHROUGH */
        case PAM_AUTH_ERR:
        case PAM_MAXTRIES:
+       case PAM_PERM_DENIED:
            return(AUTH_FAILURE);
        default:
            if ((s = pam_strerror(pamh, *pam_status)))
index 77c7cbab0abf51f97f03dbf1e4ede962d9e51a4d..9c292ea45b88464ed079d493a7a932cd59d3a09a 100644 (file)
@@ -1,9 +1,9 @@
 #! /bin/sh
 # Attempt to guess a canonical system name.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 
-timestamp='2004-08-13'
+timestamp='2005-03-24'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
@@ -53,7 +53,7 @@ version="\
 GNU config.guess ($timestamp)
 
 Originally written by Per Bothner.
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
@@ -319,6 +319,9 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
     *:OS/390:*:*)
        echo i370-ibm-openedition
        exit 0 ;;
+    *:z/VM:*:*)
+       echo s390-ibm-zvmoe
+       exit 0 ;;
     *:OS400:*:*)
         echo powerpc-ibm-os400
        exit 0 ;;
@@ -342,7 +345,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
     DRS?6000:unix:4.0:6*)
        echo sparc-icl-nx6
        exit 0 ;;
-    DRS?6000:UNIX_SV:4.2*:7*)
+    DRS?6000:UNIX_SV:4.2*:7* | DRS?6000:isis:4.2*:7*)
        case `/usr/bin/uname -p` in
            sparc) echo sparc-icl-nx7 && exit 0 ;;
        esac ;;
@@ -801,6 +804,9 @@ EOF
     i*:UWIN*:*)
        echo ${UNAME_MACHINE}-pc-uwin
        exit 0 ;;
+    amd64:CYGWIN*:*:*)
+       echo x86_64-unknown-cygwin
+       exit 0 ;;
     p*:CYGWIN*:*)
        echo powerpcle-unknown-cygwin
        exit 0 ;;
@@ -824,6 +830,12 @@ EOF
     cris:Linux:*:*)
        echo cris-axis-linux-gnu
        exit 0 ;;
+    crisv32:Linux:*:*)
+       echo crisv32-axis-linux-gnu
+       exit 0 ;;
+    frv:Linux:*:*)
+       echo frv-unknown-linux-gnu
+       exit 0 ;;
     ia64:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
        exit 0 ;;
@@ -1188,6 +1200,9 @@ EOF
     *:QNX:*:4*)
        echo i386-pc-qnx
        exit 0 ;;
+    NSE-?:NONSTOP_KERNEL:*:*)
+       echo nse-tandem-nsk${UNAME_RELEASE}
+       exit 0 ;;
     NSR-?:NONSTOP_KERNEL:*:*)
        echo nsr-tandem-nsk${UNAME_RELEASE}
        exit 0 ;;
@@ -1241,7 +1256,10 @@ EOF
            A*) echo alpha-dec-vms && exit 0 ;;
            I*) echo ia64-dec-vms && exit 0 ;;
            V*) echo vax-dec-vms && exit 0 ;;
-       esac
+       esac ;;
+    *:XENIX:*:SysV)
+       echo i386-pc-xenix
+       exit 0 ;;
 esac
 
 #echo '(No uname command or uname output not recognized.)' 1>&2
@@ -1401,7 +1419,9 @@ This script, last modified $timestamp, has failed to recognize
 the operating system you are using. It is advised that you
 download the most up to date version of the config scripts from
 
-    ftp://ftp.gnu.org/pub/gnu/config/
+  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
+and
+  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
 
 If the version you run ($0) is already up to date, please
 send the following data and any information you think might be
index ac6de9869c9a1b0a8145abac6ac35d9854fb11f9..d8fd2f8fa2f58cb9a31d7494d75d7ed8b7135dfe 100755 (executable)
@@ -1,9 +1,9 @@
 #! /bin/sh
 # Configuration validation subroutine script.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 
-timestamp='2004-06-24'
+timestamp='2005-02-10'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -70,7 +70,7 @@ Report bugs and patches to <config-patches@gnu.org>."
 version="\
 GNU config.sub ($timestamp)
 
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
@@ -237,7 +237,7 @@ case $basic_machine in
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
        | i370 | i860 | i960 | ia64 \
        | ip2k | iq2000 \
-       | m32r | m32rle | m68000 | m68k | m88k | mcore \
+       | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
        | mips | mipsbe | mipseb | mipsel | mipsle \
        | mips16 \
        | mips64 | mips64el \
@@ -267,7 +267,7 @@ case $basic_machine in
        | tahoe | thumb | tic4x | tic80 | tron \
        | v850 | v850e \
        | we32k \
-       | x86 | xscale | xstormy16 | xtensa \
+       | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
        | z8k)
                basic_machine=$basic_machine-unknown
                ;;
@@ -310,7 +310,7 @@ case $basic_machine in
        | ip2k-* | iq2000-* \
        | m32r-* | m32rle-* \
        | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
-       | m88110-* | m88k-* | mcore-* \
+       | m88110-* | m88k-* | maxq-* | mcore-* \
        | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
        | mips16-* \
        | mips64-* | mips64el-* \
@@ -343,8 +343,8 @@ case $basic_machine in
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xps100-* | xscale-* | xstormy16-* \
-       | xtensa-* \
+       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
+       | xstormy16-* | xtensa-* \
        | ymp-* \
        | z8k-*)
                ;;
@@ -457,6 +457,9 @@ case $basic_machine in
        crds | unos)
                basic_machine=m68k-crds
                ;;
+       crisv32 | crisv32-* | etraxfs*)
+               basic_machine=crisv32-axis
+               ;;
        cris | cris-* | etrax*)
                basic_machine=cris-axis
                ;;
@@ -486,6 +489,10 @@ case $basic_machine in
                basic_machine=m88k-motorola
                os=-sysv3
                ;;
+       djgpp)
+               basic_machine=i586-pc
+               os=-msdosdjgpp
+               ;;
        dpx20 | dpx20-*)
                basic_machine=rs6000-bull
                os=-bosx
@@ -1026,6 +1033,10 @@ case $basic_machine in
                basic_machine=hppa1.1-winbond
                os=-proelf
                ;;
+       xbox)
+               basic_machine=i686-pc
+               os=-mingw32
+               ;;
        xps | xps100)
                basic_machine=xps100-honeywell
                ;;
@@ -1294,6 +1305,9 @@ case $os in
        -kaos*)
                os=-kaos
                ;;
+       -zvmoe)
+               os=-zvmoe
+               ;;
        -none)
                ;;
        *)
index 74e6c94f91ffb004ec45e90d19a4ee04aad00d35..ca5dd56b52d334c1ac240bd1cffd362624d50d42 100644 (file)
@@ -1,3 +1,21 @@
+sudo (1.6.8p7-1.1) unstable; urgency=high
+
+  * Non-maintainer upload.
+  * High-urgency upload for sarge-targetted RC bugfix.
+  * Fix up a broken symlink pointing to debian/sudo/usr/bin/sudo, so
+    that sudoedit is usable again.  Closes: #305735.
+
+ -- Steve Langasek <vorlon@debian.org>  Tue, 26 Apr 2005 22:59:06 -0700
+
+sudo (1.6.8p7-1) unstable; urgency=low
+
+  * new upstream version, closes: #299585
+  * update lintian overrides to squelch the postinst warning
+  * change sudoedit from a hard to a soft link, closes: #296896
+  * fix regex doc in sudoers man page, closes: #300361
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 26 Mar 2005 22:18:34 -0700
+
 sudo (1.6.8p5-1) unstable; urgency=high
 
   * new upstream version
index d2deaabe1ab617b3988c08cb40f018c87a87b95d..50b19ebcd848be65bc84081c0448ff8d13e6c8ff 100755 (executable)
@@ -51,7 +51,7 @@ install: build
        dh_installdirs
 
        install -o root -g root -m 4755 -s sudo debian/sudo/usr/bin/sudo
-       ln -f debian/sudo/usr/bin/sudo debian/sudo/usr/bin/sudoedit
+       ln -sf sudo debian/sudo/usr/bin/sudoedit
        install -o root -g root -m 0755 -s visudo debian/sudo/usr/sbin/visudo
        install -o root -g root -m 0644 sudo.man \
                debian/sudo/usr/share/man/man8/sudo.8 
diff --git a/debian/source.lintian-overrides b/debian/source.lintian-overrides
new file mode 100644 (file)
index 0000000..3d77003
--- /dev/null
@@ -0,0 +1 @@
+sudo source: maintainer-script-lacks-debhelper-token debian/postinst
diff --git a/env.c b/env.c
index 3f58b446ee4637460925c444308d7ca9c42b68e6..9d3a765654650bae103bd55d4471c82995744353 100644 (file)
--- a/env.c
+++ b/env.c
@@ -69,7 +69,7 @@ static const char rcsid[] = "$Sudo: env.c,v 1.42 2004/09/08 15:57:49 millert Exp
 #undef DID_LOGNAME
 #define DID_LOGNAME    0x10
 #undef DID_USER
-#define DID_USER       0x12
+#define DID_USER       0x20
 
 #undef VNULL
 #define        VNULL   (VOID *)NULL
@@ -499,7 +499,7 @@ rebuild_env(envp, sudo_mode, noexec)
      * http://www.fortran-2000.com/ArnaudRecipes/sharedlib.html
      * XXX - should prepend to original value, if any
      */
-    if (noexec && def_noexec_file != NULL)
+    if (noexec && def_noexec_file != NULL) {
 #if defined(__darwin__) || defined(__APPLE__)
        insert_env(format_env("DYLD_INSERT_LIBRARIES", def_noexec_file, VNULL), 1);
        insert_env(format_env("DYLD_FORCE_FLAT_NAMESPACE", VNULL), 1);
@@ -510,6 +510,7 @@ rebuild_env(envp, sudo_mode, noexec)
        insert_env(format_env("LD_PRELOAD", def_noexec_file, VNULL), 1);
 # endif
 #endif
+    }
 
     /* Set PS1 if SUDO_PS1 is set. */
     if (ps1)
diff --git a/ldap.c b/ldap.c
index 838587df80c55f8b89a3d2b7e6c65fbdeb9e1d49..b5ecc44782fc0a508a7b4a4816f98bffd199d8c6 100644 (file)
--- a/ldap.c
+++ b/ldap.c
@@ -66,6 +66,10 @@ static const char rcsid[] = "$Sudo: ldap.c,v 1.14 2004/09/02 04:03:25 aaron Exp
 #define BUF_SIZ 1024
 #endif
 
+#ifndef LDAP_OPT_SUCCESS
+#define LDAP_OPT_SUCCESS LDAP_SUCCESS
+#endif
+
 extern int printmatches;
 
 /* ldap configuration structure */
diff --git a/sudo.c b/sudo.c
index 09449113b71da158f7d2aff6d722bc6eaa05051a..31edb653603b86de3b0aa95e9cafa1e1e78e67c8 100644 (file)
--- a/sudo.c
+++ b/sudo.c
@@ -837,6 +837,12 @@ parse_args(argc, argv)
        NewArgv++;
     }
 
+    if (user_runas != NULL && !ISSET(rval, (MODE_EDIT|MODE_RUN))) {
+       if (excl != '\0')
+           warnx("the `-u' and '-%c' options may not be used together", excl);
+       usage(1);
+    }
+
     if ((NewArgc == 0 && (rval & MODE_EDIT)) ||
        (NewArgc > 0 && !(rval & (MODE_RUN | MODE_EDIT))))
        usage(1);
index 166721aaf1404de974d6a1e85bd96099b380be17..c64eacee72b3e3e08e2099f94a7cf562d73fa3b2 100644 (file)
--- a/sudo.cat
+++ b/sudo.cat
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.6.8p5                 November 26, 2004                       1
+1.6.8p7                 February 5, 2005                        1
 
 
 
@@ -127,7 +127,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.6.8p5                 November 26, 2004                       2
+1.6.8p7                 February 5, 2005                        2
 
 
 
@@ -193,7 +193,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p5                 November 26, 2004                       3
+1.6.8p7                 February 5, 2005                        3
 
 
 
@@ -259,7 +259,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p5                 November 26, 2004                       4
+1.6.8p7                 February 5, 2005                        4
 
 
 
@@ -325,7 +325,7 @@ S\bSE\bEC\bCU\bUR\bRI\bIT\bTY\bY N\bNO\bOT\bTE\bES\bS
 
 
 
-1.6.8p5                 November 26, 2004                       5
+1.6.8p7                 February 5, 2005                        5
 
 
 
@@ -391,7 +391,7 @@ E\bEN\bNV\bVI\bIR\bRO\bON\bNM\bME\bEN\bNT\bT
 
 
 
-1.6.8p5                 November 26, 2004                       6
+1.6.8p7                 February 5, 2005                        6
 
 
 
@@ -457,7 +457,7 @@ A\bAU\bUT\bTH\bHO\bOR\bRS\bS
 
 
 
-1.6.8p5                 November 26, 2004                       7
+1.6.8p7                 February 5, 2005                        7
 
 
 
@@ -523,7 +523,7 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p5                 November 26, 2004                       8
+1.6.8p7                 February 5, 2005                        8
 
 
 
@@ -589,6 +589,6 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.6.8p5                 November 26, 2004                       9
+1.6.8p7                 February 5, 2005                        9
 
 
index 2ac134adc099cd739483ae38e56aa8f4e1b0f6cc..49c4faa76191dcf492a372f6a73000b6eabd716b 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDO @mansectsu@"
-.TH SUDO @mansectsu@ "November 26, 2004" "1.6.8p5" "MAINTENANCE COMMANDS"
+.TH SUDO @mansectsu@ "February 5, 2005" "1.6.8p7" "MAINTENANCE COMMANDS"
 .SH "NAME"
 sudo, sudoedit \- execute a command as another user
 .SH "SYNOPSIS"
index d89549882e4f09d3c4d842f8454755ea17e9c14e..bdf046542e7d42ff95791aeba306b1c320e2a728 100644 (file)
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.6.8p5                 November 28, 2004                       1
+1.6.8p7                 February 5, 2005                        1
 
 
 
@@ -127,7 +127,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       2
+1.6.8p7                 February 5, 2005                        2
 
 
 
@@ -193,7 +193,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       3
+1.6.8p7                 February 5, 2005                        3
 
 
 
@@ -259,7 +259,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       4
+1.6.8p7                 February 5, 2005                        4
 
 
 
@@ -325,7 +325,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       5
+1.6.8p7                 February 5, 2005                        5
 
 
 
@@ -391,7 +391,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       6
+1.6.8p7                 February 5, 2005                        6
 
 
 
@@ -457,7 +457,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       7
+1.6.8p7                 February 5, 2005                        7
 
 
 
@@ -523,7 +523,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       8
+1.6.8p7                 February 5, 2005                        8
 
 
 
@@ -589,7 +589,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                       9
+1.6.8p7                 February 5, 2005                        9
 
 
 
@@ -655,7 +655,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      10
+1.6.8p7                 February 5, 2005                       10
 
 
 
@@ -721,7 +721,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      11
+1.6.8p7                 February 5, 2005                       11
 
 
 
@@ -787,7 +787,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      12
+1.6.8p7                 February 5, 2005                       12
 
 
 
@@ -853,7 +853,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      13
+1.6.8p7                 February 5, 2005                       13
 
 
 
@@ -919,7 +919,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      14
+1.6.8p7                 February 5, 2005                       14
 
 
 
@@ -985,7 +985,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      15
+1.6.8p7                 February 5, 2005                       15
 
 
 
@@ -1051,7 +1051,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      16
+1.6.8p7                 February 5, 2005                       16
 
 
 
@@ -1117,7 +1117,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      17
+1.6.8p7                 February 5, 2005                       17
 
 
 
@@ -1183,7 +1183,7 @@ E\bEX\bXA\bAM\bMP\bPL\bLE\bES\bS
 
 
 
-1.6.8p5                 November 28, 2004                      18
+1.6.8p7                 February 5, 2005                       18
 
 
 
@@ -1249,7 +1249,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      19
+1.6.8p7                 February 5, 2005                       19
 
 
 
@@ -1315,7 +1315,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.6.8p5                 November 28, 2004                      20
+1.6.8p7                 February 5, 2005                       20
 
 
 
@@ -1381,7 +1381,7 @@ P\bPR\bRE\bEV\bVE\bEN\bNT\bTI\bIN\bNG\bG S\bSH\bHE\bEL\bLL\bL E\bES\bSC\bCA\bAP\bPE\bES\bS
 
 
 
-1.6.8p5                 November 28, 2004                      21
+1.6.8p7                 February 5, 2005                       21
 
 
 
@@ -1447,7 +1447,7 @@ C\bCA\bAV\bVE\bEA\bAT\bTS\bS
 
 
 
-1.6.8p5                 November 28, 2004                      22
+1.6.8p7                 February 5, 2005                       22
 
 
 
@@ -1513,6 +1513,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p5                 November 28, 2004                      23
+1.6.8p7                 February 5, 2005                       23
 
 
index 3f3b388065457ff6a4cc2679c0064d09a94af9d2..294ff6716f18c5fc37d1b63f401a122b9f18b708 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDOERS @mansectform@"
-.TH SUDOERS @mansectform@ "November 28, 2004" "1.6.8p5" "MAINTENANCE COMMANDS"
+.TH SUDOERS @mansectform@ "February 5, 2005" "1.6.8p7" "MAINTENANCE COMMANDS"
 .SH "NAME"
 sudoers \- list of which users may execute what
 .SH "DESCRIPTION"
index 0988611aec6245a92a857a96c03cd885547c8703..563ab15a6921e4fffea9855e000bc1baa98cc278 100644 (file)
@@ -93,7 +93,7 @@ C<Host_Alias> and C<Cmnd_Alias>.
 
  Cmnd_Alias ::= NAME '=' Cmnd_List
 
- NAME ::= [A-Z]([A-Z][0-9]_)*
+ NAME ::= [A-Z]([a-z][A-Z][0-9]_)*
 
 Each I<alias> definition is of the form
 
index 3f06dfbc986cdb1b3271d913099f2c2cca957de6..e7e46ff1e2c8fe1f5d6c8437e08d4994ba7e5dc1 100644 (file)
--- a/version.h
+++ b/version.h
@@ -23,6 +23,6 @@
 #ifndef _SUDO_VERSION_H
 #define _SUDO_VERSION_H
 
-static const char version[] = "1.6.8p5";
+static const char version[] = "1.6.8p7";
 
 #endif /* _SUDO_VERSION_H */
index a6341271ba0d63f7456b65e59615d262194da895..dfcd8bc2eede01aeedb1a6e7b95875da32fb7c56 100644 (file)
@@ -61,7 +61,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.6.8p5                 November 26, 2004                       1
+1.6.8p7                 February 5, 2005                        1
 
 
 
@@ -127,7 +127,7 @@ D\bDI\bIA\bAG\bGN\bNO\bOS\bST\bTI\bIC\bCS\bS
 
 
 
-1.6.8p5                 November 26, 2004                       2
+1.6.8p7                 February 5, 2005                        2
 
 
 
@@ -193,6 +193,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.6.8p5                 November 26, 2004                       3
+1.6.8p7                 February 5, 2005                        3
 
 
index 4e7fce5f3c06251b0f0007daee2ca454c2a24309..3593696357885890d8a4bd5322841cfc52fb16f7 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "VISUDO @mansectsu@"
-.TH VISUDO @mansectsu@ "November 26, 2004" "1.6.8p5" "MAINTENANCE COMMANDS"
+.TH VISUDO @mansectsu@ "February 5, 2005" "1.6.8p7" "MAINTENANCE COMMANDS"
 .SH "NAME"
 visudo \- edit the sudoers file
 .SH "SYNOPSIS"