Merge branch 'sync' of git@gnuradio.org:trondeau into master
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 13 Oct 2009 01:46:56 +0000 (18:46 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 13 Oct 2009 01:46:56 +0000 (18:46 -0700)
This merge adds polyphase clock recovery, implements new PAM demodulators
that use it, and also moves GRC examples to gnuradio-examples component.

See merge commit diff for updated files post merge.

* 'sync' of git@gnuradio.org:trondeau: (54 commits)
  Reverting dqpsk to be mpsk_receiver based and not change its behavior.
  Fixing initialization of timing gains. Alpha should be < 1, and beta should be << 1.
  This splits the rate into a fractional an integer value, which allows the loop to adjust the fractional rate while the integer rate keeps the increments moving properly. Allows the max rate deviation to be independent of the integer rate. Scaling of the differential taps also allows alpha and beta to operate independent of the rate when fractional samples per symbol are used. Slightly more tolerant to large signal values, but they still should be close to +/-1.
  Fixing compiler warnings.
  Adding dqpsk2 block to makefile for installation.
  Adding DQPSK version that uses the PFB timing sync block (dqpsk2).
  Minor fixes for logging.
  Fixing import of UI file.
  Temporary working dbpsk2 example until we match everything.
  Working DBPSK implementation with new PFB clock recovery block. The feedforward AGC wasn't playing nicely, the frequency aquistion range was increased to swing half the sample rate in either direction, and the number of filter phases to use was increased to 32.
  A bit of code cleanup.
  Starting to rework QT app to control new PFB clock recovery alg.
  Making old dbpsk work again to compare against new version.
  Adding new DBPSK block with new PFB clock recovery alg.
  Revert "More additions to PAM timing simulation."
  More additions to PAM timing simulation.
  Using 2-PAM by default.
  Cleaning up GRC PAM timing example and adding ability to do M-ary PAM.
  Cleaning up constructor.
  Moving filter number decision to start work function.
  ...

1  2 
config/grc_gnuradio_examples.m4
debian/bin/gen-install-files.sh
debian/control
gnuradio-core/src/python/gnuradio/blks2impl/dbpsk.py
gnuradio-core/src/python/gnuradio/blks2impl/dqpsk.py
grc/blocks/Makefile.am
grc/blocks/block_tree.xml

index 3225f3ab510f130d5dd7723b3df39de1b2bf3403,685761ff366d9a794aa69066b9641c963c8a2cb8..4d6116c70f1b142b2d7174545ae6c29ac5a38a2e
@@@ -1,4 -1,4 +1,4 @@@
--dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
++dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2009 Free Software Foundation, Inc.
  dnl 
  dnl This file is part of GNU Radio
  dnl 
@@@ -25,15 -25,16 +25,16 @@@ AC_DEFUN([GRC_GNURADIO_EXAMPLES],
  
      AC_CONFIG_FILES([ \
          gnuradio-examples/Makefile \
 -    gnuradio-examples/c++/Makefile \
 -    gnuradio-examples/python/Makefile \
 -    gnuradio-examples/grc/Makefile \
 -    gnuradio-examples/python/apps/hf_explorer/Makefile \
 +      gnuradio-examples/c++/Makefile \
 +      gnuradio-examples/python/Makefile \
++      gnuradio-examples/grc/Makefile \
 +      gnuradio-examples/python/apps/hf_explorer/Makefile \
        gnuradio-examples/python/apps/hf_radio/Makefile \
        gnuradio-examples/python/apps/Makefile \
        gnuradio-examples/python/audio/Makefile \
        gnuradio-examples/python/digital/Makefile \
        gnuradio-examples/python/digital_voice/Makefile \
-         gnuradio-examples/python/digital-bert/Makefile \
 -    gnuradio-examples/python/digital-bert/Makefile \
++      gnuradio-examples/python/digital-bert/Makefile \
        gnuradio-examples/python/mp-sched/Makefile \
        gnuradio-examples/python/multi-antenna/Makefile \
        gnuradio-examples/python/multi_usrp/Makefile \
index 5e900095a97a97a34be04357be55b69005ba137e,5e900095a97a97a34be04357be55b69005ba137e..45296bff689371e940ce950833fb13507125e66b
@@@ -433,6 -433,6 +433,12 @@@ $EXTRACT gnuradio-examples/python/pfb/M
  $EXTRACT gnuradio-examples/python/usrp/Makefile dist_ourdata_SCRIPTS >>$NAME
  $EXTRACT gnuradio-examples/python/usrp2/Makefile dist_ourdata_SCRIPTS >>$NAME
  $EXTRACT gnuradio-examples/python/usrp2/Makefile dist_ourdata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_audiodata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_demoddata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_simpledata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_trellisdata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_usrpdata_DATA >>$NAME
++$EXTRACT gnuradio-examples/grc/Makefile dist_xmlrpcdata_DATA >>$NAME
  
  # gnuradio-pager
  NAME=debian/gnuradio-pager.install
@@@ -492,11 -492,11 +498,6 @@@ $EXTRACT grc/Makefile dist_etc_DATA >>$
  $EXTRACT grc/base/Makefile ourpython_PYTHON >>$NAME
  $EXTRACT grc/base/Makefile dist_ourdata_DATA >>$NAME
  $EXTRACT grc/blocks/Makefile dist_ourdata_DATA >>$NAME
--$EXTRACT grc/examples/Makefile dist_audiodata_DATA >>$NAME
--$EXTRACT grc/examples/Makefile dist_simpledata_DATA >>$NAME
--$EXTRACT grc/examples/Makefile dist_trellisdata_DATA >>$NAME
--$EXTRACT grc/examples/Makefile dist_usrpdata_DATA >>$NAME
--$EXTRACT grc/examples/Makefile dist_xmlrpcdata_DATA >>$NAME
  $EXTRACT grc/freedesktop/Makefile dist_ourdata_DATA >>$NAME
  $EXTRACT grc/freedesktop/Makefile dist_bin_SCRIPTS >>$NAME
  $EXTRACT grc/grc_gnuradio/Makefile root_python_PYTHON >>$NAME
diff --cc debian/control
index a7b33f0be2d1b5ab8b007ba5ab5713ffa6bee5d1,a7b33f0be2d1b5ab8b007ba5ab5713ffa6bee5d1..0760ddaec682887a9387a4b6e232dc0deb1404c3
@@@ -551,16 -551,16 +551,6 @@@ XB-Python-Version: ${python:Versions
  Description: GNU Radio Utilities
   This package provides commonly used utilities for GNU Radio
  
--Package: gnuradio-examples
--Architecture: any
--Depends: ${python:Depends}, python-gnuradio-core
--Provides: ${python:Provides}
--Recommends: python-gnuradio-wxgui, python-gnuradio
--Section: comm
--XB-Python-Version: ${python:Versions}
--Description: GNU Radio Example Programs
-- This package provides examples of GNU Radio usage using Python.
--
  Package: gnuradio-pager
  Architecture: any
  Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp
@@@ -621,6 -621,6 +611,16 @@@ XB-Python-Version: ${python:Versions
  Description: The GNU Radio Companion
   GRC is a graphical flowgraph editor for the GNU Software Radio
  
++Package: gnuradio-examples
++Architecture: any
++Depends: ${python:Depends}, python-gnuradio-core, gnuradio-companion
++Provides: ${python:Provides}
++Recommends: python-gnuradio-wxgui, python-gnuradio
++Section: comm
++XB-Python-Version: ${python:Versions}
++Description: GNU Radio Example Programs
++ This package provides examples of GNU Radio usage using Python.
++
  ################################################################################
  # Documentation packages                                                       #
  ################################################################################
index 3147bfa2ab4f4f102b27121083368394063148c7,47a13a787a2ce0c36599146d88d4f772e8043a40..860015c3f02ab33621e576fd7b5aad9d2329741e
@@@ -1,5 -1,5 +1,5 @@@
  #
--# Copyright 2005,2006,2007 Free Software Foundation, Inc.
++# Copyright 2005,2006,2007,2009 Free Software Foundation, Inc.
  # 
  # This file is part of GNU Radio
  # 
index 8c15d2173427750bcee5062cf6d985ef4dc10c3e,edd3024a676c0cfd25fe4807a6b945157cbfef26..42d534168579d2d308b8d0876d93f16c4e4c9081
@@@ -1,5 -1,5 +1,5 @@@
  #
--# Copyright 2005,2006,2007 Free Software Foundation, Inc.
++# Copyright 2005,2006,2007,2009 Free Software Foundation, Inc.
  # 
  # This file is part of GNU Radio
  # 
Simple merge
Simple merge