add support for /etc/sudoers.d
authorBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 18:08:29 +0000 (12:08 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 18:08:29 +0000 (12:08 -0600)
debian/changelog
debian/sudo-ldap.postinst
debian/sudo.postinst

index 1582d672f179862b4ab8d996cc4b488c68321c46..b0dedc1b84f26c77d4bfb60378a7c2b0b4aa0726 100644 (file)
@@ -1,3 +1,10 @@
+sudo (1.7.2-3) UNRELEASED; urgency=low
+
+  * add support for /etc/sudoers.d using #includedir in default sudoers, 
+    closes: #539994
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 31 Aug 2009 12:08:04 -0600
+
 sudo (1.7.2-2) unstable; urgency=low
 
   * further improve initial sudoers to not include the NOPASSWD option on 
index 5145cc9b74289f9296021e0591851ab414e051ea..9dea6d781347268e6470b7b098d6dceb4ecd4634 100644 (file)
@@ -23,7 +23,9 @@ if ( ! -f "/etc/sudoers") {
          "# Allow members of group sudo to not need a password\n",
          "# (Note that later entries override this, so you might need to move\n",
           "# it further down)\n",
-         "%sudo ALL=(ALL) ALL\n";
+         "%sudo ALL=(ALL) ALL\n",
+         "#\n",
+         "#includedir /etc/sudoers.d\n";
        close SUDOERS;
 
 }
@@ -32,7 +34,7 @@ if ( ! -f "/etc/sudoers") {
 system ('chown root:root /etc/sudoers');
 system ('chmod 440 /etc/sudoers');
 
-# do a remove first to un-do "bad" links created by previous versions
+# must do a remove first to un-do the "bad" links created by previous version
 system ('update-rc.d -f sudo remove >/dev/null 2>&1');
 
 system ('update-rc.d sudo start 75 S . >/dev/null');
index c4f948220a7a08d7916094fa1b9e0c0a70a4f6e6..6dc9cd206d089204ebc3f7b8341dc732a9887a94 100644 (file)
@@ -23,7 +23,9 @@ if ( ! -f "/etc/sudoers") {
          "# Allow members of group sudo to not need a password\n",
          "# (Note that later entries override this, so you might need to move\n",
           "# it further down)\n",
-         "%sudo ALL=(ALL) ALL\n";
+         "%sudo ALL=(ALL) ALL\n",
+         "#\n",
+         "#includedir /etc/sudoers.d\n";
        close SUDOERS;
 
 }