Imported Debian patch 1.6.8p12-5 debian/1.6.8p12-5
authorBdale Garbee <bdale@gag.com>
Wed, 4 Apr 2007 03:48:45 +0000 (21:48 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 14 May 2008 18:03:50 +0000 (12:03 -0600)
14 files changed:
Makefile.in
config.guess
config.sub
debian/NEWS [new file with mode: 0644]
debian/OPTIONS
debian/README.Debian
debian/changelog
debian/control
debian/copyright
debian/postinst
debian/postrm
debian/rules
debian/sudo-ldap.postrm
env.c

index c832f22cfb28160060da028ca679a1a882989839..0474932b1947b3d233cf34b0b115e99b5d5ca8f0 100644 (file)
@@ -318,7 +318,7 @@ install-sudoers:
            $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
                $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
 
-install-man:
+install-man: sudo.$(mantype) visudo.$(mantype) sudoers.$(mantype)
        $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
        @rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
        ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
index c38553dc74bb4f06a43f734903d1e1c0f1ed6fdb..396482d6cb50b24a598700992f65d340165591d6 100644 (file)
@@ -1,9 +1,10 @@
 #! /bin/sh
 # Attempt to guess a canonical system name.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
+#   Inc.
 
-timestamp='2006-02-23'
+timestamp='2006-07-02'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
@@ -210,7 +211,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
        echo ${UNAME_MACHINE}-unknown-solidbsd${UNAME_RELEASE}
        exit ;;
     macppc:MirBSD:*:*)
-       echo powerppc-unknown-mirbsd${UNAME_RELEASE}
+       echo powerpc-unknown-mirbsd${UNAME_RELEASE}
        exit ;;
     *:MirBSD:*:*)
        echo ${UNAME_MACHINE}-unknown-mirbsd${UNAME_RELEASE}
@@ -770,6 +771,8 @@ EOF
        case ${UNAME_MACHINE} in
            pc98)
                echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
+           amd64)
+               echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
            *)
                echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
        esac
@@ -780,9 +783,6 @@ EOF
     i*:MINGW*:*)
        echo ${UNAME_MACHINE}-pc-mingw32
        exit ;;
-    i*:MSYS_NT-*:*:*)
-       echo ${UNAME_MACHINE}-pc-mingw32
-       exit ;;
     i*:windows32*:*)
        # uname -m includes "-pc" on this system.
        echo ${UNAME_MACHINE}-mingw32
@@ -790,10 +790,10 @@ EOF
     i*:PW*:*)
        echo ${UNAME_MACHINE}-pc-pw32
        exit ;;
-    x86:Interix*:[345]*)
+    x86:Interix*:[3456]*)
        echo i586-pc-interix${UNAME_RELEASE}
        exit ;;
-    EM64T:Interix*:[345]*)
+    EM64T:Interix*:[3456]*)
        echo x86_64-unknown-interix${UNAME_RELEASE}
        exit ;;
     [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
@@ -831,6 +831,9 @@ EOF
     arm*:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
        exit ;;
+    avr32*:Linux:*:*)
+       echo ${UNAME_MACHINE}-unknown-linux-gnu
+       exit ;;
     cris:Linux:*:*)
        echo cris-axis-linux-gnu
        exit ;;
@@ -989,7 +992,7 @@ EOF
        LIBC=gnulibc1
        # endif
        #else
-       #if defined(__INTEL_COMPILER) || defined(__PGI) || defined(__sun)
+       #if defined(__INTEL_COMPILER) || defined(__PGI) || defined(__SUNPRO_C) || defined(__SUNPRO_CC)
        LIBC=gnu
        #else
        LIBC=gnuaout
index ad9f39571183b5c22b2d269bb52eb9ad50227430..fab0aa3556632a4aec253b77804270a096c11c3e 100755 (executable)
@@ -1,9 +1,10 @@
 #! /bin/sh
 # Configuration validation subroutine script.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
+#   Inc.
 
-timestamp='2006-02-23'
+timestamp='2006-09-20'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -240,7 +241,7 @@ case $basic_machine in
        | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
        | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
        | am33_2.0 \
-       | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
+       | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
        | bfin \
        | c4x | clipper \
        | d10v | d30v | dlx | dsp16xx \
@@ -248,7 +249,8 @@ case $basic_machine in
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
        | i370 | i860 | i960 | ia64 \
        | ip2k | iq2000 \
-       | m32r | m32rle | m68000 | m68k | m88k | maxq | mb | microblaze | mcore \
+       | m32c | m32r | m32rle | m68000 | m68k | m88k \
+       | maxq | mb | microblaze | mcore \
        | mips | mipsbe | mipseb | mipsel | mipsle \
        | mips16 \
        | mips64 | mips64el \
@@ -274,21 +276,19 @@ case $basic_machine in
        | pdp10 | pdp11 | pj | pjl \
        | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
        | pyramid \
-       | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
+       | score \
+       | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
        | sh64 | sh64le \
-       | sparc | sparc64 | sparc64b | sparc86x | sparclet | sparclite \
-       | sparcv8 | sparcv9 | sparcv9b \
-       | strongarm \
+       | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
+       | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
+       | spu | strongarm \
        | tahoe | thumb | tic4x | tic80 | tron \
        | v850 | v850e \
        | we32k \
-       | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
+       | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
        | z8k)
                basic_machine=$basic_machine-unknown
                ;;
-       m32c)
-               basic_machine=$basic_machine-unknown
-               ;;
        m6811 | m68hc11 | m6812 | m68hc12)
                # Motorola 68HC11/12.
                basic_machine=$basic_machine-unknown
@@ -318,7 +318,7 @@ case $basic_machine in
        | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
        | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
        | arm-*  | armbe-* | armle-* | armeb-* | armv*-* \
-       | avr-* \
+       | avr-* | avr32-* \
        | bfin-* | bs2000-* \
        | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
        | clipper-* | craynv-* | cydra-* \
@@ -329,7 +329,7 @@ case $basic_machine in
        | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
        | i*86-* | i860-* | i960-* | ia64-* \
        | ip2k-* | iq2000-* \
-       | m32r-* | m32rle-* \
+       | m32c-* | m32r-* | m32rle-* \
        | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
        | m88110-* | m88k-* | maxq-* | mcore-* \
        | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
@@ -358,23 +358,21 @@ case $basic_machine in
        | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
        | pyramid-* \
        | romp-* | rs6000-* \
-       | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | shbe-* \
+       | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
        | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
-       | sparc-* | sparc64-* | sparc64b-* | sparc86x-* | sparclet-* \
+       | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
        | sparclite-* \
-       | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
+       | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
        | tahoe-* | thumb-* \
        | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
+       | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
        | xstormy16-* | xtensa-* \
        | ymp-* \
        | z8k-*)
                ;;
-       m32c-*)
-               ;;
        # Recognize the various machine names and aliases which stand
        # for a CPU type and a company and sometimes even an OS.
        386bsd)
@@ -912,6 +910,10 @@ case $basic_machine in
        sb1el)
                basic_machine=mipsisa64sb1el-unknown
                ;;
+       sde)
+               basic_machine=mipsisa32-sde
+               os=-elf
+               ;;
        sei)
                basic_machine=mips-sei
                os=-seiux
@@ -1128,7 +1130,7 @@ case $basic_machine in
        sh[1234] | sh[24]a | sh[34]eb | sh[1234]le | sh[23]ele)
                basic_machine=sh-unknown
                ;;
-       sparc | sparcv8 | sparcv9 | sparcv9b)
+       sparc | sparcv8 | sparcv9 | sparcv9b | sparcv9v)
                basic_machine=sparc-sun
                ;;
        cydra)
@@ -1217,7 +1219,7 @@ case $os in
              | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
              | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
              | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
-             | -skyos* | -haiku* | -rdos*)
+             | -skyos* | -haiku* | -rdos* | -toppers*)
        # Remember, each alternative MUST END IN *, to match a version number.
                ;;
        -qnx*)
@@ -1369,6 +1371,12 @@ else
 # system, and we'll never get to this point.
 
 case $basic_machine in
+        score-*)
+               os=-elf
+               ;;
+        spu-*)
+               os=-elf
+               ;;
        *-acorn)
                os=-riscix1.2
                ;;
@@ -1378,9 +1386,9 @@ case $basic_machine in
        arm*-semi)
                os=-aout
                ;;
-    c4x-* | tic4x-*)
-        os=-coff
-        ;;
+        c4x-* | tic4x-*)
+               os=-coff
+               ;;
        # This must come before the *-dec entry.
        pdp10-*)
                os=-tops20
diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644 (file)
index 0000000..d942146
--- /dev/null
@@ -0,0 +1,9 @@
+sudo (1.6.8p12-5) unstable; urgency=low
+
+  The sudo package is no longer configured --with-exempt=sudo.  If you 
+  depend on members of group sudo being able to run sudo without needing
+  a password, you will need to put "%sudo ALL=NOPASSWD: ALL" in 
+  /etc/sudoers to preserve equivalent functionality.
+
+ -- Bdale Garbee <bdale@gag.com>  Tue,  3 Apr 2007 21:13:39 -0600
+
index 4f98523b3bca4df6c45bd63ae1b205a389aa2023..8f7f3182b58a28026594225edabf50b808413061 100644 (file)
@@ -1,10 +1,8 @@
 The following options were used to configure sudo for Debian GNU/Linux.
 
-  --with-exempt=sudo 
+  --with-devel
 
-       Any user in group 'sudo' will not need to type their password.  It
-       is strongly recommended that no users be put in group sudo, and that
-       instead the NOPASSWD option in the sudoers file be used if desired.
+       Force flex and bison runs on each build.
 
   --with-pam 
        
index 9f92f3392f3dfdc8322adc35d4ea92a671fa294a..48333fc9a17c8d7c0009c046b1e1f51222547ace 100644 (file)
@@ -3,7 +3,8 @@ environment, as described by the "env_reset" flag in the sudoers file.
 
 This implies that all environment variables are removed, except for
 HOME, LOGNAME, PATH, SHELL, TERM, DISPLAY, XAUTHORITY, XAUTHORIZATION,
-LANG, LANGUAGE, LC_*, and USER.
+XAPPLRESDIR, XFILESEARCHPATH, XUSERFILESEARCHPATH, LANG, LANGUAGE, LC_*, 
+and USER.
 
 In case you want sudo to preserve more environment variables, you must
 specify the env_keep variable in the sudoers file. You should edit the
@@ -20,3 +21,9 @@ Preserve the default variables plus all variables starting with LC_:
 
 See the file OPTIONS in this directory for more information on the sudo
 build options used in building the Debian package.
+
+If you're having trouble grasping the fundamental idea of what sudo is all
+about, here's a succinct and humorous take on it...   
+
+       http://www.xkcd.com/c149.html
+
index ebb3812addd5e3d919b5bd7f7d7cf4f86efd1f6b..d7d10b9bf92839395572ed06d9ec8373c02e1ec7 100644 (file)
@@ -1,3 +1,20 @@
+sudo (1.6.8p12-5) unstable; urgency=low
+
+  * update debian/copyright to reflect new upstream URL, closes: #368746
+  * add sandwich cartoon URL to the README.Debian
+  * don't remove sudoers on purge.  can cause problems when moving between
+    sudo and sudo-ldap.  leaving sudoers around on purge seems like the least
+    evil choice for now, closes: #401366
+  * also preserve XAPPLRESDIR, XFILESEARCHPATH, and XUSERFILESEARCHPATH,
+    closes: #374509
+  * accept patch that improves debian/rules from Ted Percival, closes: #382122
+  * no longer build with --with-exempt=sudo, provide an example entry in the
+    default sudoers file instead, closes: #296605
+  * add --with-devel to configure and augment build dependencies so that flex
+    and yacc files get re-generated on every build, closes: #316249
+
+ -- Bdale Garbee <bdale@gag.com>  Tue,  3 Apr 2007 21:48:45 -0600
+
 sudo (1.6.8p12-4) unstable; urgency=low
 
   * patch from Petter Reinholdtsen for the LSB info block in the init.d
index 2fd3895db26cabf7b838bd851e7e4d9bbe09af07..e6251646c4162e60971cd8ed6a4da17d9664c8de 100644 (file)
@@ -2,8 +2,8 @@ Source: sudo
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 5), libpam0g-dev, libldap2-dev, autotools-dev, bison
-Standards-Version: 3.6.2.1
+Build-Depends: debhelper (>= 5), libpam0g-dev, libldap2-dev, autotools-dev, bison, flex
+Standards-Version: 3.7.2
 
 Package: sudo
 Architecture: any
index dc138e87dee773e491220fcf8816a94971304996..e4190ff7aaf718cd027f1b33b779487c09745a9c 100644 (file)
@@ -1,9 +1,9 @@
 This is the Debian GNU/Linux prepackaged version of sudo.  sudo is
 used to provide limited super user privileges to specific users.
 
-This package was put together by Bdale Garbee <bdale@gag.com> using sources
-from 
-       ftp://ftp.cs.colorado.edu/pub/sudo/
+Bdale Garbee <bdale@gag.com> maintains this package using sources from 
+
+       http://www.sudo.ws/
 
 Sudo is distributed under the following BSD-style license:
 
index 732d750ce3f8114fc81a67e50e5c87dc3da9dc1d..36cdd235c89e4de80576edfa280def1318d16944 100644 (file)
@@ -16,6 +16,8 @@ if ( ! -f "/etc/sudoers") {
          "#\n",
          "# See the man page for details on how to write a sudoers file.\n",
          "#\n\nDefaults\tenv_reset\n\n",
+         "# Uncomment to allow members of group sudo to not need a password\n",
+         "# %sudo ALL=NOPASSWD: ALL\n\n",
          "# Host alias specification\n\n",
          "# User alias specification\n\n",
          "# Cmnd alias specification\n\n",
index e018f12c4c30febab688d427a03e41c7f634502e..af99cb6605f675d43f299dfd68f6ca21a6b2b607 100644 (file)
@@ -4,7 +4,6 @@ set -e
 
 case "$1" in
        purge)
-       rm -f /etc/sudoers
         ;;
 
        remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
index c47793902a1fb96219116523732c642d77469443..07385b362b715974ba5075a47e36b835fd984316 100755 (executable)
@@ -17,7 +17,7 @@ config-stamp:
        cd build-simple && NROFFPROG=/usr/bin/nroff ../configure \
                --prefix=/usr -v \
                --with-all-insults \
-               --with-exempt=sudo --with-pam --with-fqdn \
+               --with-devel --with-pam --with-fqdn \
                --with-logging=syslog --with-logfac=authpriv \
                --with-env-editor --with-editor=/usr/bin/editor \
                --with-timeout=15 --with-password-timeout=0 \
@@ -48,11 +48,10 @@ build-stamp: config-stamp
        dh_testdir
 
        # ensure our pod changes get picked up
-       -rm -f sudoers.man.in sudoers.man sudo.man.in sudo.man
-       -$(MAKE) sudoers.man.in sudo.man.in
+       $(MAKE) -C build-simple sudoers.man.in sudo.man.in visudo.man.in
 
-       -$(MAKE) -C build-simple
-       -$(MAKE) -C build-ldap
+       $(MAKE) -C build-simple
+       $(MAKE) -C build-ldap
 
        touch build-stamp
 
index e018f12c4c30febab688d427a03e41c7f634502e..af99cb6605f675d43f299dfd68f6ca21a6b2b607 100644 (file)
@@ -4,7 +4,6 @@ set -e
 
 case "$1" in
        purge)
-       rm -f /etc/sudoers
         ;;
 
        remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
diff --git a/env.c b/env.c
index ce6314b9f810bfd17caf62119b3555f3718bdcc1..5d14216d69bc9afc4641c3251a38b131e562335e 100644 (file)
--- a/env.c
+++ b/env.c
@@ -372,6 +372,9 @@ rebuild_env(envp, sudo_mode, noexec)
            if (!strncmp (*ep, "DISPLAY=",8)
                || !strncmp (*ep, "XAUTHORITY=", 11)
                || !strncmp (*ep, "XAUTHORIZATION=", 15)
+               || !strncmp (*ep, "XAPPLRESDIR=", 12)
+               || !strncmp (*ep, "XFILESEARCHPATH=", 16)
+               || !strncmp (*ep, "XUSERFILESEARCHPATH=", 20)
                || !strncmp (*ep, "LANG=", 5)
                || !strncmp (*ep, "LANGUAGE=", 9)
                || !strncmp (*ep, "LC_", 3))