* NEWS, configure.ac (AC_INIT):
authorPaul Eggert <eggert@cs.ucla.edu>
Fri, 15 Dec 2006 08:18:02 +0000 (08:18 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Fri, 15 Dec 2006 08:18:02 +0000 (08:18 +0000)
Version 1.3.9 released.

* bootstrap (gnulib_tool_options_extras): New var.
(gnulib_tool_options): Use it.
* bootstrap.conf (gnulib_tool_options_extras): Avoid getline and
rpmatch.  gzip doesn't need them, since it doesn't ENABLE_NLS.

ChangeLog
NEWS
bootstrap
bootstrap.conf
configure.ac

index ac0bde56c8fd210b3d694a6dd50fb6e4537cd3ee..737befd1a760371259b97f202ae4ab7d6761be83 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2006-12-15  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * NEWS, configure.ac (AC_INIT):
+       Version 1.3.9 released.
+
+       * bootstrap (gnulib_tool_options_extras): New var.
+       (gnulib_tool_options): Use it.
+       * bootstrap.conf (gnulib_tool_options_extras): Avoid getline and
+       rpmatch.  gzip doesn't need them, since it doesn't ENABLE_NLS.
+
 2006-12-13  Bruno Haible  <bruno@clisp.org>
 
        * configure.ac: Use $CPPFLAGS everywhere $CPP is used, and use
diff --git a/NEWS b/NEWS
index d315a1f33e43b6d5134ef8c1829c42bc43a15afb..881c9d61abe33394ef9f896501567f27dedd839f 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,7 @@
+Gzip 1.3.9 (2006-12-15)
+
+* No major changes; only porting fixes.
+
 Major changes in Gzip 1.3.8 (2006-12-08)
 
 * Fix some gzip problems:
index 7b6b019eb11415e30b2729cadf40098efca0e3cb..ab31ae7d02927ac88f9bb2f7b0cde43148b164db 100755 (executable)
--- a/bootstrap
+++ b/bootstrap
@@ -97,6 +97,9 @@ gnulib_extra_files='
        doc/INSTALL
 '
 
+# Additional gnulib-tool options to use.  Use "\newline" to break lines.
+gnulib_tool_option_extras=
+
 # Other locale categories that need message catalogs.
 EXTRA_LOCALE_CATEGORIES=
 
@@ -425,6 +428,7 @@ gnulib_tool_options="\
  --source-base $bt/lib/\
  --tests-base $bt/tests\
  --local-dir gl\
+$gnulib_tool_option_extras\
 "
 echo "$0: $gnulib_tool $gnulib_tool_options --import ..."
 $gnulib_tool $gnulib_tool_options --import $gnulib_modules &&
index 39420d163d321a08e895249cf7ef027d5b33acef..7229807e625b077392395ca6fd143c294643b1c0 100644 (file)
@@ -34,5 +34,12 @@ gnulib_modules='
        yesno
 '
 
+# Additional gnulib-tool options to use.  Use "\newline" to break lines.
+# We don't need the getline and rpmatch, since yesno doesn't do i18n.
+gnulib_tool_option_extras="\
+ --avoid getline\
+ --avoid rpmatch\
+"
+
 # Create build-aux, since 'bootstrap' won't do that for us.
 mkdir -p build-aux
index d07f375f2b8fea488cea3228b56dbc051907c48b..48e8728c6195c4b7f0b231105c5899d09da34f39 100644 (file)
@@ -19,7 +19,7 @@
 # 02111-1307, USA.
 
 AC_PREREQ([2.60])
-AC_INIT([gzip], [1.3.8], [bug-gzip@gnu.org])
+AC_INIT([gzip], [1.3.9], [bug-gzip@gnu.org])
 AC_CONFIG_SRCDIR(gzip.c)
 AC_CONFIG_AUX_DIR(build-aux)
 AC_CONFIG_HEADERS([lib/config.h:lib/config.hin])