tests: exercise the segfault fix
authorJim Meyering <meyering@redhat.com>
Mon, 11 Jan 2010 07:20:52 +0000 (08:20 +0100)
committerJim Meyering <meyering@redhat.com>
Wed, 20 Jan 2010 14:00:37 +0000 (15:00 +0100)
* tests/helin-segv: New test.
* Makefile.am (TESTS): Add it.

Makefile.am
tests/helin-segv [new file with mode: 0755]

index 67dc18b85dffca06e5487f44ac799a040126ef0d..ac9561540504171b67cec3afae8ace8bf3d8eedd 100644 (file)
@@ -104,6 +104,7 @@ check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
        @echo 'Test succeeded.'
 
 TESTS =                                                \
+  tests/helin-segv                             \
   tests/memcpy-abuse                           \
   tests/trailing-nul                           \
   tests/zdiff                                  \
diff --git a/tests/helin-segv b/tests/helin-segv
new file mode 100755 (executable)
index 0000000..d6b14f6
--- /dev/null
@@ -0,0 +1,37 @@
+#!/bin/sh
+# Before gzip-1.4, gzip -d would segfault on some inputs.
+
+# Copyright (C) 2010 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+# limit so don't run it by default.
+
+if test "$VERBOSE" = yes; then
+  set -x
+  gzip --version
+fi
+
+: ${srcdir=.}
+. "$srcdir/tests/init.sh"; path_prepend_ .
+
+# This test case was provided by Aki Helin.
+printf '\037\235\220\0\0\0\304' > helin.gz || framework_failure
+printf '\0\0' > exp || framework_failure
+
+fail=0
+
+gzip -dc helin.gz > out || fail=1
+compare out exp || fail=1
+
+Exit $fail