robust check for xdg-utils
authorjblum <jblum@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 30 Sep 2008 23:56:59 +0000 (23:56 +0000)
committerjblum <jblum@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 30 Sep 2008 23:56:59 +0000 (23:56 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9686 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_grc.m4
grc/Makefile.am
grc/freedesktop/README [new file with mode: 0644]

index f02923f1695adc69e68173367ef78da429a1ec1d..b5ae52cee023c0cfec13a43fe7b979f63213ce11 100644 (file)
@@ -22,7 +22,8 @@ AC_DEFUN([GRC_GRC],[
 
     GRC_CHECK_DEPENDENCY(grc, gr-wxgui)
 
-    AC_CHECK_PROG(XDG_UTILS,xdg-mime,freedesktop,)
+    AC_CHECK_PROG(XDG_UTILS, xdg-mime, true, false)
+    AM_CONDITIONAL(XDG_UTILS, $XDG_UTILS)
 
     dnl ########################################
     dnl # test python dependencies
index 8b77fc31a5bba87b4b3c38283a5c854be4f347b1..7f62f39b6d9fe0a1ef8b809afd9b0709c4d19c75 100644 (file)
 
 include $(top_srcdir)/grc/Makefile.inc
 
-SUBDIRS = $(XDG_UTILS) \
+SUBDIRS = \
        data \
        examples \
        scripts \
        src
+
+## append freedesktop to the list of subdirs when xdg utils are present
+if XDG_UTILS
+SUBDIRS += freedesktop
+endif
diff --git a/grc/freedesktop/README b/grc/freedesktop/README
new file mode 100644 (file)
index 0000000..0857ecc
--- /dev/null
@@ -0,0 +1,20 @@
+##################################################
+# Freedesktop Notes
+##################################################
+
+This directory contains icons, a mime type, and menu files for grc.
+Installation of these files requires a set of tools called xdg-utils.
+xdg-utils will install files in a standard way according to the freedesktop.org standards.
+
+Desktop enviroments that implement these standards are gnome, kde, xfce, and others.
+If you have one of these desktop enviroments, xdg-utils should come installed.
+If xdg-utils is not installed, then this directory will be ignored by the build.
+
+The gtk IconTheme module locates the installed icons for use inside the grc app.
+On recent versions of gtk, IconTheme ignores the icons installed into the default theme.
+This presents a problem for the gnome file system browser, nautilus, and the grc app.
+As a solution, icons are also installed under the gnome theme.
+
+*.png files - these are the icons of various sizes
+*.desktop files - these are the menu items for grc executables
+*.xml file - this is the mime type for the saved flow graphs