* gzip.c (abort_gzip_signal): Don't call abort () as a "safeguard",
authorPaul Eggert <eggert@cs.ucla.edu>
Sat, 2 Dec 2006 00:02:44 +0000 (00:02 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Sat, 2 Dec 2006 00:02:44 +0000 (00:02 +0000)
since it actually causes a core dump.  Problem reported by
Jakub Bogusz.

ChangeLog
gzip.c

index b0fb1b4c6f70e0a4574ae95221771c4089ff19e6..b6d0620df22a57d7b5ad4d17bfe3985426f4ac02 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
 2006-12-01  Paul Eggert  <eggert@cs.ucla.edu>
 
+       * gzip.c (abort_gzip_signal): Don't call abort () as a "safeguard",
+       since it actually causes a core dump.  Problem reported by
+       Jakub Bogusz.
+
        * NEWS: Describe gzexe changes noted below.
        * Makefile.am (.in): Don't bother with SEDCMD.  This stuff isn't needed
        any more (the hosts it caters to are long extinct), and was questionable
diff --git a/gzip.c b/gzip.c
index 013beeb25b1a58514e00a38e031f8d884a312942..a9016a29a7a41ad4002c5c11326c6a66a355ea9c 100644 (file)
--- a/gzip.c
+++ b/gzip.c
@@ -1848,5 +1848,4 @@ abort_gzip_signal (sig)
    remove_output_file ();
    signal (sig, SIG_DFL);
    raise (sig);
-   abort ();
 }