Applied patch from Don Ward for Cygwin platform
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 7 Oct 2009 16:11:13 +0000 (09:11 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Wed, 7 Oct 2009 16:11:13 +0000 (09:11 -0700)
Add *.exe to .gitignore
Restore ac_compiler in gr_fortran.m4 even when no Fortran was found
Add $(NO_UNDEFINED) to LDFLAGS in atsc Makefile.am, so shared libraries
 will be built
Change the order of searching pmt/libpmt-qa.la and libgruel.la in gruel
 Makefile.am so references to libgruel from limpmt-qa will be resolved

.gitignore
config/gr_fortran.m4
gr-atsc/src/lib/Makefile.am
gruel/src/lib/Makefile.am

index b333709ee11bbe673fcfbfc4fd94f0ee99cce818..5461bf8bf37b0c9d17b201727961e7ce7cec6e66 100644 (file)
@@ -16,6 +16,7 @@
 *.lo
 *.py[oc]
 *.gz
+*.exe
 *.patch
 *~
 \#*#
index a558b2f7e3f00eaecddd39bc5248a0ece883c543..03105204304b5e1f0e28c3eec121aa54b1ef1702 100644 (file)
@@ -28,6 +28,6 @@ AC_DEFUN([GR_FORTRAN],[
     then
         AC_PROG_F77
         AC_F77_LIBRARY_LDFLAGS
-       AC_PROG_CC dnl bux fix to restore $ac_ext
     fi
+    AC_PROG_CC dnl bux fix to restore $ac_ext
 ])
index b435461254fedf1639898fba2749105c906604e1..8aeb80c0a5be7f4b19ee9dbb5bf4a8a22155eae0 100644 (file)
@@ -92,6 +92,9 @@ BUILT_SOURCES =                               \
 libgnuradio_atsc_la_LIBADD =                   \
        $(GNURADIO_CORE_LA)
 
+libgnuradio_atsc_la_LDFLAGS = \
+       $(NO_UNDEFINED)
+
 noinst_LTLIBRARIES = libgnuradio-atsc-qa.la
 
 libgnuradio_atsc_qa_la_SOURCES =               \
@@ -113,6 +116,9 @@ libgnuradio_atsc_qa_la_SOURCES =            \
 libgnuradio_atsc_qa_la_LIBADD =                        \
        $(GNURADIO_CORE_LA)
 
+libgnuradio_atsc_qa_la_LDFLAGS = \
+       $(NO_UNDEFINED)
+
 
 # These headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                            \
index 9afa0d292f2df871f46af49174f53314d9efe50b..b21f8023c72e3f6d8d9b03bb38b291bf9e6355e5 100644 (file)
@@ -58,5 +58,5 @@ libgruel_la_LIBADD =                  \
 # ----------------------------------------------------------------
 
 test_gruel_SOURCES = test_gruel.cc
-test_gruel_LDADD   = libgruel.la pmt/libpmt-qa.la
+test_gruel_LDADD   = pmt/libpmt-qa.la libgruel.la