Misc. packaging tweaks
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 25 Sep 2009 14:05:13 +0000 (07:05 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 25 Sep 2009 14:05:13 +0000 (07:05 -0700)
Note gcell/apps/gen_script.py needs to use git
Install gnuradio-config-info in libgnuradio-core0
Add pfb examples to gnuradio-examples
Add missing python files in gnuradio-examples

debian/bin/gen-install-files.sh
debian/libgnuradio-core0.install
gcell/apps/gen_script.py

index 53460f29ea1dcad9949da998378e7505e9a0cc0c..5e900095a97a97a34be04357be55b69005ba137e 100755 (executable)
@@ -427,6 +427,9 @@ $EXTRACT gnuradio-examples/python/multi_usrp/Makefile dist_ourdata_SCRIPTS >>$NA
 $EXTRACT gnuradio-examples/python/network/Makefile dist_ourdata_SCRIPTS >>$NAME
 $EXTRACT gnuradio-examples/python/ofdm/Makefile dist_ourdata_DATA >>$NAME
 $EXTRACT gnuradio-examples/python/ofdm/Makefile dist_ourdata_SCRIPTS >>$NAME
+$EXTRACT gnuradio-examples/python/pfb/Makefile dist_ourdata_SCRIPTS >>$NAME
+$EXTRACT gnuradio-examples/python/pfb/Makefile dist_ourdata_PYTHON >>$NAME
+$EXTRACT gnuradio-examples/python/pfb/Makefile dist_ourdata_DATA >>$NAME
 $EXTRACT gnuradio-examples/python/usrp/Makefile dist_ourdata_SCRIPTS >>$NAME
 $EXTRACT gnuradio-examples/python/usrp2/Makefile dist_ourdata_SCRIPTS >>$NAME
 $EXTRACT gnuradio-examples/python/usrp2/Makefile dist_ourdata_DATA >>$NAME
index e5c1d708c8e884f80d4b0ba746c52e0094a3e2bb..9feb625d882ab1b18cefac1d0349336c1fdd33c9 100644 (file)
@@ -1,3 +1,4 @@
 etc/gnuradio/conf.d/gnuradio-core.conf
 usr/lib/libgnuradio-core.la
 usr/lib/libgnuradio-core.so.*
+usr/bin/gnuradio-config-info
index e4bbc74807229359f041b73152b384805db0626f..2ad0fb78e27eb18f68ace1d971835dfe69ae5076 100755 (executable)
@@ -57,6 +57,7 @@ def main():
         parser.print_help()
         sys.exit(1)
 
+    #FIXME to use git now
     svn_rev = get_svn_rev()
 
     os.environ['TZ'] = 'PST8PDT'        # always pacific