Merge utils from http://gnuradio.org/git/trondeau.git
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 25 Aug 2009 23:02:33 +0000 (16:02 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Tue, 25 Aug 2009 23:04:43 +0000 (16:04 -0700)
  Added files to Makefile.am for distribution.
  Added colorbar to spectrogram for magnitude measurement.
  Fixed spectrogram plotting axis.
  Adding a spectrogram plot. The axis need work.
  GR plotter tool handles end of file and files shorter than the block length.
  Manages window/filter types better. Disables filter types if the designing algorithm doesn't support it (no RRC or Gaussian for equiripple filters).
  User messages if PyQt and PyQwt are not installed (or found).
  Setting validators for all edit boxes.
  Fixing tab order.
  Adding display for the number of taps in the filter.
  Adding equiripple band reject filter to filter design app.
  Adding P-M version of band reject filter.
  Fixed documentation for optfir band pass filters.
  Added routine for optfir equiripple filter design code to create complex bandpass filters. Also adds this ability to the filter designer.
  Added design for Guassian filters.
  Added design for RRC filters.
  Added Band Notch filter
  Adding complex bandpass filter design (for windowed filters only).
  Adding plotting of group delay.
  Adding labels to the plots.
  ...

1  2 
gr-utils/src/python/Makefile.am

index 65cbd536cceeefee28e4f1d445edc32f5a48280b,0c8240fe47ab21d7720617c9652b3281cb296092..59ca215a764a920392979754e8b5e46b715601fb
@@@ -43,8 -47,9 +47,10 @@@ bin_SCRIPTS = 
      gr_plot_int.py \
      gr_plot_iq.py \
      gr_plot_short.py \
+     gr_plot_qt.py \
+     gr_filter_design.py \
      lsusrp \
 +    qr_fft.py \
      usrp_fft.py \
      usrp_oscope.py \
      usrp_print_db.py \