maint: update bootstrap script
authorJim Meyering <meyering@redhat.com>
Wed, 30 Sep 2009 10:53:28 +0000 (12:53 +0200)
committerJim Meyering <meyering@redhat.com>
Wed, 30 Sep 2009 10:55:57 +0000 (12:55 +0200)
* bootstrap (with_gettext): Update from coreutils.

bootstrap

index b6dce12ed71d88da5ab3f622148b491319da3fe1..5ef537a4719a19089c855f5b5fcf65f67c6d2ba5 100755 (executable)
--- a/bootstrap
+++ b/bootstrap
@@ -70,6 +70,9 @@ gnulib_modules=
 # Any gnulib files needed that are not in modules.
 gnulib_files=
 
+# A function to be called after everything else in this script.
+bootstrap_epilogue() { :; }
+
 # The command to download all .po files for a specified domain into
 # a specified directory.  Fill in the first %s is the domain name, and
 # the second with the destination directory.  Use rsync's -L and -r
@@ -728,6 +731,10 @@ find "$m4_base" "$source_base" \
 
 # Reconfigure, getting other files.
 
+# Skip autoheader if it's not needed.
+grep '^[        ]*AC_CONFIG_HEADERS\>' configure.ac >/dev/null ||
+  AUTOHEADER=true
+
 for command in \
   libtool \
   "${ACLOCAL-aclocal} --force -I m4" \
@@ -796,6 +803,8 @@ if test $with_gettext = yes; then
   fi
 fi
 
+bootstrap_epilogue
+
 echo "$0: done.  Now you can run './configure'."
 
 # Local Variables: