Created a grc_blockdir in makefile.common.
authorJosh Blum <josh@joshknows.com>
Wed, 28 Oct 2009 21:33:52 +0000 (14:33 -0700)
committerJosh Blum <josh@joshknows.com>
Wed, 28 Oct 2009 21:33:52 +0000 (14:33 -0700)
Switched the grc src prefix in grc makefiles.
Removed grc/Makefile.inc as it was no longer neededed.

Makefile.common
gr-noaa/grc/Makefile.am
grc/Makefile.am
grc/Makefile.inc [deleted file]
grc/base/Makefile.am
grc/blocks/Makefile.am
grc/freedesktop/Makefile.am
grc/gui/Makefile.am
grc/python/Makefile.am
grc/scripts/Makefile.am

index aca56b34aeac948d2a9757a878d7a780f54931fa..64891345ba778b99600d6b7e2620b6beb9df2068 100644 (file)
@@ -113,6 +113,9 @@ gr_docdir = $(docdir)-$(DOCVER)
 # System configuration files
 gr_prefsdir = $(GR_PREFSDIR)
 
+# Data directory for grc block wrappers
+grc_blocksdir = $(pkgdatadir)/grc/blocks
+
 # Other common defines; use "+=" to add to these
 STAMPS =
 MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
index 1f056473c5be0be468b554702523081c0eb00eb7..a290204b0a45c7950590f88d8c7d1b1e6b86031d 100644 (file)
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-grcblocksdir = $(prefix)/share/gnuradio/grc/blocks
+grcblocksdir = $(grc_blocksdir)
 
 dist_grcblocks_DATA = \
        noaa_hrpt_decoder.xml \
index 30b955a1efbb3a47419303d7de5d74b0b9940127..2b5dc730b5e3184b9c25c6ad3e1a34f4b0dd0cde 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 if PYTHON
 SUBDIRS = \
@@ -35,7 +35,7 @@ if XDG_UTILS
 SUBDIRS += freedesktop
 endif
 
-ourpythondir = $(grc_src_prefix)
+ourpythondir = $(pkgpythondir)/grc
 ourpython_PYTHON = __init__.py
 
 etcdir = $(gr_prefsdir)
diff --git a/grc/Makefile.inc b/grc/Makefile.inc
deleted file mode 100644 (file)
index c45d1ce..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#
-# Copyright 2008, 2009 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-grc_src_prefix = $(pkgpythondir)/grc
-grc_blocksdir = $(pkgdatadir)/grc/blocks
index e489601db264095dbb23149f265ba0e306ae734a..6a95e33b983b841dcb691e0aa4eeb2ff05b6769e 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/base
+ourpythondir = $(pkgpythondir)/grc/base
 ourpython_PYTHON = \
        odict.py \
        ParseXML.py \
@@ -35,7 +35,7 @@ ourpython_PYTHON = \
        Port.py \
        __init__.py
 
-ourdatadir = $(grc_src_prefix)/base
+ourdatadir = $(pkgpythondir)/grc/base
 dist_ourdata_DATA = \
        block_tree.dtd \
        flow_graph.dtd
index 61c0038038e5ce8ef6dcd7d4466380d035dde556..9194d99ec2a79734ff2cd0ac2152f5ef615dd1c0 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 ourdatadir = $(grc_blocksdir)
 dist_ourdata_DATA = \
index 79388ba3a00984e1ef4d3e3f137969e52cbbb4ca..bfbdee9404fea4671740d578050cec6132bc2706 100644 (file)
@@ -19,7 +19,7 @@
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 ourdatadir = $(pkgdatadir)/grc/freedesktop
 
index b14817d04e0d9e891544a99736a99ad3ccbe358a..a73b6855dc5514fde4b0c1e174cfb08da78cf9b1 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/gui
+ourpythondir = $(pkgpythondir)/grc/gui
 ourpython_PYTHON = \
        Block.py \
        Colors.py \
index 0a62c08257a36e9ba3fef5294b899a0933243dd7..67b71bc4723d75cf9b524042d9ca0282bb5aa915 100644 (file)
@@ -19,9 +19,9 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-ourpythondir = $(grc_src_prefix)/python
+ourpythondir = $(pkgpythondir)/grc/python
 ourpython_PYTHON = \
        convert_hier.py \
        expr_utils.py \
@@ -37,7 +37,7 @@ ourpython_PYTHON = \
        Port.py \
        __init__.py
 
-ourdatadir = $(grc_src_prefix)/python
+ourdatadir = $(pkgpythondir)/grc/python
 dist_ourdata_DATA = \
        block.dtd \
        default_flow_graph.grc \
index 35c75d5feb5ba3a54fcdcd77942c6b8926920d64..e24f88800f0ddc68b65d7245ceed2efab379ec8d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008, 2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -19,6 +19,6 @@
 # Boston, MA 02110-1301, USA.
 # 
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 dist_bin_SCRIPTS = grc usrp2_probe usrp_probe