document the process for existing users to enable /etc/sudoers.d functionality
authorBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 20:37:27 +0000 (14:37 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 20:37:27 +0000 (14:37 -0600)
debian/README.Debian
debian/rules

index ae4212f661bdbc4ae109ed013a45ac92c3ef2875..c89e431066ad87263fdbe8e2fd8373d4e4851770 100644 (file)
@@ -1,3 +1,19 @@
+As of Debian version 1.7.2p1-1, the default /etc/sudoers file created on
+installation of the package now includes the directive:
+
+       #includedir /etc/sudoers.d
+
+This will cause sudo to read and parse any files in the /etc/sudoers.d 
+directory that do not end in '~' or contain a '.' character.
+
+Note that because the sudoers file is not a 'conffile' in the Debian sense,
+and sudoers contents can very widely, no attempt is made to add this directive
+to existing sudoers files on upgrade.  Feel free to add the above directive
+to the end of your /etc/sudoers file to enable this functionality for existing
+installations if you wish!
+
+       - - - - -
+
 The version of sudo that ships with Debian by default resets the
 environment, as described by the "env_reset" flag in the sudoers file.
 
index 3323153f42e5af80513b883902b65a22c2ff608b..8d4ea4002167ab3943d940a185433e0f744363e3 100755 (executable)
@@ -106,6 +106,9 @@ install: build-stamp
        install -o root -g root -m 0644 $(CURDIR)/debian/sudo-ldap.lintian \
                debian/sudo-ldap/usr/share/lintian/overrides/sudo-ldap
 
+       ln -s /usr/share/doc/sudo/README.Debian debian/sudo/etc/sudoers.d
+       ln -s /usr/share/doc/sudo/README.Debian debian/sudo-ldap/etc/sudoers.d
+
 binary-indep: build install
 
 binary-arch: build install