* bootstrap (gnulib_tool_option_extras): Put this back; it was
authorPaul Eggert <eggert@cs.ucla.edu>
Fri, 13 Apr 2007 21:23:04 +0000 (21:23 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Fri, 13 Apr 2007 21:23:04 +0000 (21:23 +0000)
inadvertently omitted from gnulib.
(gnulib_tool_option): Use it.
* .cvsignore: Add *._bootmp*.
* lib/.cvsignore: Add stdlib.h, stdlib_.h, time.h, time_.h, unistd.h.
Remove alloca.c, alloca.h, alloca_.h, exit.h, getdelim.c, getdelim.h,
getline.c, getline.h, malloc.c, mbchar.c, mbchar.h, mbuiter.h, memchr.c,
regcomp.c, regex.c, regex.h, regex_internal.c, regex_internal.h,
regexec.c, rpmatch.c, stdint.h, stdint_.h, strcase.h, strcasecmp.c,
strncasecmp.c, strnlen1.c, strnlen1.h, timespec.h, wcwidth.h.
* m4/.cvsignore: Add stdlib_h.m4, time_h.m4.
Remove alloca.m4, codeset.m4, getdelim.m4, getline.m4,
longlong.m4, mbchar.m4, mbiter.m4, mbrtowc.m4, memchr.m4, regex.m4,
rpmatch.m4, ssize_t.m4, stdint.m4 strcase.m4, timespec.m4, ulonglong.m4,
wchar_t.m4, wcwidth.m4, wint_t.m4.

.cvsignore
ChangeLog
bootstrap
lib/.cvsignore
m4/.cvsignore

index f3ea3c0972cb47b0ddc3bab029300338348f776e..ab29b288bc165a01c9cc64752598cf03210fc1f6 100644 (file)
@@ -1,3 +1,4 @@
+*._bootmp*
 *.cache
 *.doc
 *.gz
index c65cb9f20e86b97975bb150cadf8d9fcf6101cd5..54462c799fc66bc1e6a140b06a3b7ec2a05909b2 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,21 @@
+2007-04-13  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * bootstrap (gnulib_tool_option_extras): Put this back; it was
+       inadvertently omitted from gnulib.
+       (gnulib_tool_option): Use it.
+       * .cvsignore: Add *._bootmp*.
+       * lib/.cvsignore: Add stdlib.h, stdlib_.h, time.h, time_.h, unistd.h.
+       Remove alloca.c, alloca.h, alloca_.h, exit.h, getdelim.c, getdelim.h,
+       getline.c, getline.h, malloc.c, mbchar.c, mbchar.h, mbuiter.h, memchr.c,
+       regcomp.c, regex.c, regex.h, regex_internal.c, regex_internal.h,
+       regexec.c, rpmatch.c, stdint.h, stdint_.h, strcase.h, strcasecmp.c,
+       strncasecmp.c, strnlen1.c, strnlen1.h, timespec.h, wcwidth.h.
+       * m4/.cvsignore: Add stdlib_h.m4, time_h.m4.
+       Remove alloca.m4, codeset.m4, getdelim.m4, getline.m4,
+       longlong.m4, mbchar.m4, mbiter.m4, mbrtowc.m4, memchr.m4, regex.m4,
+       rpmatch.m4, ssize_t.m4, stdint.m4 strcase.m4, timespec.m4, ulonglong.m4,
+       wchar_t.m4, wcwidth.m4, wint_t.m4.
+
 2007-03-29  Paul Eggert  <eggert@cs.ucla.edu>  (tiny change)
 
        * znew.in (tmp): Use $TMPDIR as temp directory, if given.
index 3294085057373b9d8a1146f48de8e39208b42286..c028967894c87f2f70c3a13de955bd4f195563dc 100755 (executable)
--- a/bootstrap
+++ b/bootstrap
@@ -103,6 +103,8 @@ gnulib_extra_files="
        $build_aux/config.sub
        doc/INSTALL
 "
+# Additional gnulib-tool options to use.  Use "\newline" to break lines.
+gnulib_tool_option_extras=
 
 # Other locale categories that need message catalogs.
 EXTRA_LOCALE_CATEGORIES=
@@ -460,6 +462,7 @@ gnulib_tool_options="\
  --source-base $bt/lib/\
  --tests-base $bt/tests\
  --local-dir gl\
+$gnulib_tool_option_extras\
 "
 echo "$0: $gnulib_tool $gnulib_tool_options --import ..."
 $gnulib_tool $gnulib_tool_options --import $gnulib_modules &&
index fb0931a4dda1957f2e1195b9e495947723a6c38a..310aa73eb9046cfafe2efba8fe47307a483d073b 100644 (file)
@@ -1,16 +1,12 @@
 .deps
 Makefile
 Makefile.in
-alloca.c
-alloca.h
-alloca_.h
 config.h
 config.hin
 creat-safer.c
 dup-safer.c
 error.c
 error.h
-exit.h
 exitfail.c
 exitfail.h
 fcntl--.h
@@ -18,50 +14,30 @@ fcntl-safer.h
 fcntl.h
 fcntl_.h
 fd-safer.c
-getdelim.c
-getdelim.h
-getline.c
-getline.h
 getopt.c
 getopt1.c
 getopt_.h
 getopt_int.h
 gettext.h
 gnulib.mk
-malloc.c
-mbchar.c
-mbchar.h
-mbuiter.h
-memchr.c
 open-safer.c
 pipe-safer.c
-regcomp.c
-regex.c
-regex.h
-regex_internal.c
-regex_internal.h
-regexec.c
-rpmatch.c
 stamp-h1
 stat-time.h
 stat_.h
 stdbool_.h
-stdint.h
-stdint_.h
-strcase.h
-strcasecmp.c
-strncasecmp.c
-strnlen1.c
-strnlen1.h
+stdlib.h
+stdlib_.h
 sys
 sys_time_.h
-timespec.h
+time.h
+time_.h
 unistd--.h
 unistd-safer.h
+unistd.h
 unistd_.h
 utimens.c
 utimens.h
-wcwidth.h
 xalloc-die.c
 xalloc.h
 xmalloc.c
index 207a9da327bbbb6eb1241ffadd3d784e1b4f1fde..708382eccf38b0157d25d43dac4c4b33eb77a55b 100644 (file)
@@ -1,42 +1,25 @@
 absolute-header.m4
-alloca.m4
-codeset.m4
 error.m4
 exitfail.m4
 extensions.m4
 fcntl-safer.m4
 fcntl_h.m4
-getdelim.m4
-getline.m4
 getopt.m4
 gnulib-cache.m4
 gnulib-common.m4
 gnulib-comp.m4
 gnulib-tool.m4
 inline.m4
-longlong.m4
-mbchar.m4
-mbiter.m4
-mbrtowc.m4
-memchr.m4
-regex.m4
-rpmatch.m4
-ssize_t.m4
 stat-time.m4
 stdbool.m4
-stdint.m4
-strcase.m4
+stdlib_h.m4
 sys_stat_h.m4
 sys_time_h.m4
-timespec.m4
-ulonglong.m4
+time_h.m4
 unistd-safer.m4
 unistd_h.m4
 utimbuf.m4
 utimens.m4
 utimes.m4
-wchar_t.m4
-wcwidth.m4
-wint_t.m4
 xalloc.m4
 yesno.m4