fixed problem with gr_noise_source_* caused by splitting gnuradio_swig_python
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 16 Jan 2007 17:57:28 +0000 (17:57 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 16 Jan 2007 17:57:28 +0000 (17:57 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4280 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/lib/general/Makefile.am
gnuradio-core/src/lib/general/general.i
gnuradio-core/src/lib/general/gr_noise_type.h [deleted file]
gnuradio-core/src/lib/gengen/Makefile.am
gnuradio-core/src/lib/gengen/gengen.i
gnuradio-core/src/lib/gengen/gr_noise_type.h [new file with mode: 0644]

index 30f6ba1dbc509dc93f24efb4f1c594a840a5a75b..3014ee05bb53f1d25601c1f2a9d0257fd2b35436 100644 (file)
@@ -210,7 +210,6 @@ grinclude_HEADERS =                         \
        gr_misc.h                       \
        gr_nco.h                        \
        gr_nlog10_ff.h                  \
-       gr_noise_type.h                 \
        gr_nop.h                        \
        gr_null_sink.h                  \
        gr_null_source.h                \
index 1bf75299835ef7f3fced74d05d86ce1241594991..fe3ccacdf68c5e964a73c11d2340d393a639c36a 100644 (file)
@@ -27,7 +27,6 @@
 #include <gr_null_source.h>
 #include <gr_head.h>
 #include <gr_skiphead.h>
-#include <gr_noise_type.h>
 #include <gr_quadrature_demod_cf.h>
 #include <gr_remez.h>
 #include <gr_float_to_complex.h>
 %include "gr_null_source.i"
 %include "gr_head.i"
 %include "gr_skiphead.i"
-%include "gr_noise_type.h"
 %include "gr_quadrature_demod_cf.i"
 %include "gr_remez.i"
 %include "gr_float_to_complex.i"
diff --git a/gnuradio-core/src/lib/general/gr_noise_type.h b/gnuradio-core/src/lib/general/gr_noise_type.h
deleted file mode 100644 (file)
index d04b7ca..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2004 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#ifndef INCLUDED_GR_NOISE_TYPE_H
-#define INCLUDED_GR_NOISE_TYPE_H
-
-typedef enum {
-  GR_UNIFORM = 200, GR_GAUSSIAN, GR_LAPLACIAN, GR_IMPULSE
-} gr_noise_type_t;
-
-#endif /* INCLUDED_GR_NOISE_TYPE_H */
index d5074634a5ce655fee85a4679472f69df2b8c901..a338e39b751da4d7ea848a6c7c521c91cfa8c016 100644 (file)
@@ -110,6 +110,7 @@ libgengen_la_SOURCES =                      \
 grinclude_HEADERS =                    \
        $(GENERATED_H)                  \
        gr_endianness.h                 \
+       gr_noise_type.h                 \
        gr_sig_source_waveform.h        
 
 noinst_HEADERS =                       
index 4047e430aedb8ad1ec3d3d53e08513a37e6cf41e..420b8ef5e2dc39e04f8a0b7016a63bd49839e9aa 100644 (file)
@@ -1,9 +1,11 @@
 %{
 #include "gr_endianness.h"
 #include "gr_sig_source_waveform.h"
+#include "gr_noise_type.h"
 %}
 
 %include "gr_endianness.i"
 %include "gr_sig_source_waveform.h"
+%include "gr_noise_type.h"
 
 %include "gengen_generated.i"
diff --git a/gnuradio-core/src/lib/gengen/gr_noise_type.h b/gnuradio-core/src/lib/gengen/gr_noise_type.h
new file mode 100644 (file)
index 0000000..d04b7ca
--- /dev/null
@@ -0,0 +1,30 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2004 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#ifndef INCLUDED_GR_NOISE_TYPE_H
+#define INCLUDED_GR_NOISE_TYPE_H
+
+typedef enum {
+  GR_UNIFORM = 200, GR_GAUSSIAN, GR_LAPLACIAN, GR_IMPULSE
+} gr_noise_type_t;
+
+#endif /* INCLUDED_GR_NOISE_TYPE_H */