removed obsolete distribution tools used with CVS
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 8 Nov 2007 18:13:34 +0000 (18:13 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 8 Nov 2007 18:13:34 +0000 (18:13 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6833 221aa14e-8319-0410-a670-987f0aec2ac5

dtools/bin/incr_release [deleted file]
dtools/bin/show_release [deleted file]
dtools/bin/tag_release [deleted file]
dtools/python/release_tools.py [deleted file]

diff --git a/dtools/bin/incr_release b/dtools/bin/incr_release
deleted file mode 100755 (executable)
index 9373ac4..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/usr/bin/env python
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-from optparse import OptionParser
-import release_tools
-import os.path
-
-def main():
-    parser = OptionParser()
-    parser.add_option('-f', '--final', action='store_true', default=False)
-    (options, args) = parser.parse_args()
-
-    for f in args:
-        release_tools.incr_release(os.path.join(f, 'configure.ac'), options.final)
-
-if __name__ == '__main__':
-    main()
-    
diff --git a/dtools/bin/show_release b/dtools/bin/show_release
deleted file mode 100755 (executable)
index 31a06c5..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/env python
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-from optparse import OptionParser
-import release_tools
-import os.path
-
-def main():
-    parser = OptionParser()
-    (options, args) = parser.parse_args()
-
-    for f in args:
-        print release_tools.get_release(os.path.join(f, 'configure.ac'))
-
-if __name__ == '__main__':
-    main()
-    
diff --git a/dtools/bin/tag_release b/dtools/bin/tag_release
deleted file mode 100755 (executable)
index e7fac7c..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/usr/bin/env python
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-from optparse import OptionParser
-import release_tools
-import os
-import os.path
-import sys
-
-def main():
-    parser = OptionParser()
-    (options, args) = parser.parse_args()
-
-    exit_code = 0
-    for d in args:
-        f = os.path.join(d, 'configure.ac')
-        rel = release_tools.get_release(f)
-        if rel is None:
-            raise ValueError, "%s: couldn't find version" % (f,)
-        tag = release_tools.make_tag(rel)
-        cmd = '(cd %s; cvs tag %s)' % (d, tag)
-        print cmd
-        exit_code = exit_code | os.system(cmd)
-
-    sys.exit(exit_code)
-
-if __name__ == '__main__':
-    main()
diff --git a/dtools/python/release_tools.py b/dtools/python/release_tools.py
deleted file mode 100644 (file)
index ff170b1..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-#
-# Copyright 2005 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-import re
-import os
-
-def get_release(configure_ac_filename):
-    f = open(configure_ac_filename,'r')
-    contents = f.read()
-    pat = re.compile('^AM_INIT_AUTOMAKE\((.*),(\d+)\.(\d+)(.*)\)', re.M)
-    mo = pat.search(contents)
-    if mo:
-        return mo.groups()
-
-def set_release(configure_ac_filename, new_release):
-    f = open(configure_ac_filename,'r')
-    contents = f.read()
-    pat = re.compile('^AM_INIT_AUTOMAKE\(((.*),(\d+)\.(\d+)(.*))\)', re.M)
-    repl = ''.join(('AM_INIT_AUTOMAKE(',
-                    new_release[0],
-                    ',',
-                    new_release[1],
-                    '.',
-                    new_release[2],new_release[3],')'))
-    new = pat.sub(repl, contents)
-    return new
-
-def incr_release(configure_ac_filename, final=False):
-    cur = get_release(configure_ac_filename)
-    if cur is None:
-        raise ValueError, "%s: couldn't find version" % (configure_ac_filename,)
-    new = set_release(configure_ac_filename, up_rev(cur, final))
-    os.rename(configure_ac_filename, configure_ac_filename + '.bak')
-    f = open(configure_ac_filename,'w')
-    f.write(new)
-    f.close()
-
-def up_rev(current_rev, final=False):
-    """
-    X.Y -> X.Ycvs
-    if final:
-      X.Ycvs -> X.(Y+1)rc1
-    else:
-      X.Ycvs -> X.(Y+1)
-    if final:
-      X.YrcN -> X.Y
-    else
-      X.YrcN -> X.Yrc(N+1)
-    """
-    pkg, major, minor, suffix = current_rev
-
-    if len(suffix) == 0:
-        if final:
-            raise RuntimeError, ("Can't go from current to final.  current = " + str(current_rev))
-        return (pkg, major, minor, "cvs")
-    if suffix == "cvs":
-        if final:
-            return (pkg, major, str(int(minor)+1), "")
-        return (pkg, major, str(int(minor)+1), "rc1")
-    elif suffix.startswith('rc'):
-        if final:
-            return (pkg, major, minor, "")
-        return (pkg, major, minor, "rc" + (str(int(suffix[2:]) + 1)))
-
-def make_tag(current_rev):
-    pkg, major, minor, suffix = current_rev
-    if suffix == "cvs":
-        raise ValueError, "You tried to tag a X.Ycvs release..."
-    return 'REL_%s_%s%s' % (major, minor, suffix)