making use of PACKAGE
authorjblum <jblum@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 18 Sep 2008 18:52:42 +0000 (18:52 +0000)
committerjblum <jblum@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 18 Sep 2008 18:52:42 +0000 (18:52 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9603 221aa14e-8319-0410-a670-987f0aec2ac5

grc/src/gui/Dialogs.py
grc/src/gui/Messages.py
grc/src/platforms/base/Constants.py.in
grc/src/platforms/base/Makefile.am

index 415a53c9393760d5dd56811b8dac2963ba1f692f..738109673311c1e4f41edc94fc7d790c159e8e3a 100644 (file)
@@ -21,7 +21,7 @@ import pygtk
 pygtk.require('2.0')
 import gtk
 from Constants import MIN_DIALOG_WIDTH, MIN_DIALOG_HEIGHT
 pygtk.require('2.0')
 import gtk
 from Constants import MIN_DIALOG_WIDTH, MIN_DIALOG_HEIGHT
-from .. platforms.base.Constants import VERSION
+from .. platforms.base.Constants import PACKAGE, VERSION
 import Preferences
 
 class TextDisplay(gtk.TextView):
 import Preferences
 
 class TextDisplay(gtk.TextView):
@@ -85,8 +85,8 @@ class AboutDialog(gtk.AboutDialog):
        def __init__(self):
                """AboutDialog constructor."""
                gtk.AboutDialog.__init__(self)
        def __init__(self):
                """AboutDialog constructor."""
                gtk.AboutDialog.__init__(self)
+               self.set_name(PACKAGE)
                self.set_version(VERSION)
                self.set_version(VERSION)
-               self.set_name('GNU Radio Companion')
                self.set_license(__doc__)
                self.set_copyright(__doc__.strip().splitlines()[0])
                self.set_website('http://gnuradio.org/trac/wiki/GNURadioCompanion')
                self.set_license(__doc__)
                self.set_copyright(__doc__.strip().splitlines()[0])
                self.set_website('http://gnuradio.org/trac/wiki/GNURadioCompanion')
index 8f6a280480b42cb707f40bf12b3cad31e8f8dab5..fd925fefc2831e9cc6bbcddf5946ee61236fca3c 100644 (file)
@@ -17,7 +17,7 @@ along with this program; if not, write to the Free Software
 Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
 """
 
 Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
 """
 
-from .. platforms.base.Constants import VERSION
+from .. platforms.base.Constants import PACKAGE, VERSION
 import traceback
 import sys
 
 import traceback
 import sys
 
@@ -45,7 +45,7 @@ register_messenger(sys.stdout.write)
 # Special functions for specific program functionalities
 ###########################################################################
 def send_init():
 # Special functions for specific program functionalities
 ###########################################################################
 def send_init():
-       send("""<<< Welcome to GNU Radio Companion %s >>>\n"""%VERSION)
+       send("""<<< Welcome to %s %s >>>\n"""%(PACKAGE, VERSION))
 
 def send_page_switch(file_path):
        send('\nShowing: "%s"\n'%file_path)
 
 def send_page_switch(file_path):
        send('\nShowing: "%s"\n'%file_path)
index 26ba72d977648526408b0077ed2a2d390304d7d5..4ee4278f1c94cdc5d4dbf5859f7512ae734332ea 100644 (file)
@@ -19,7 +19,10 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
 
 import os
 
 
 import os
 
-##The current version of this code
+##The package name.
+PACKAGE = '@PACKAGE@'
+
+##The current version.
 VERSION = '@VERSION@'
 
 ##Location of external data files.
 VERSION = '@VERSION@'
 
 ##Location of external data files.
index a40d8c5bb574a6686ca541de948b8a0ac06f4bc2..fbfc87e00d67854f73ee96d21c42852f7e742b2d 100644 (file)
@@ -38,6 +38,7 @@ BUILT_SOURCES = Constants.py
 
 Constants.py: Makefile $(srcdir)/Constants.py.in
        sed \
 
 Constants.py: Makefile $(srcdir)/Constants.py.in
        sed \
+               -e 's|@PACKAGE[@]|$(PACKAGE)|g' \
                -e 's|@VERSION[@]|$(VERSION)|g' \
                -e 's|@datadir[@]|$(grc_base_data_dir)|g' \
        $(srcdir)/Constants.py.in > $@
                -e 's|@VERSION[@]|$(VERSION)|g' \
                -e 's|@datadir[@]|$(grc_base_data_dir)|g' \
        $(srcdir)/Constants.py.in > $@