Modified grc_gr_qtgui.m4 AND the README in gr-qtgui to enable gr-qtgui to build from...
authorn4hy <n4hy@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 2 Mar 2007 21:55:22 +0000 (21:55 +0000)
committern4hy <n4hy@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 2 Mar 2007 21:55:22 +0000 (21:55 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4692 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_gr_qtgui.m4
gr-qtgui/README

index 300462188a81c1f881429b385f8bede1a033200c..aa8ca7c89125770b306f7e349688f0e2d428a156 100644 (file)
@@ -36,8 +36,8 @@ AC_DEFUN([GRC_GR_QTGUI],[
        [passed=no;AC_MSG_RESULT([gr-qtgui requires qt, not found. Checking for qt-mt])])
     fi
 
        [passed=no;AC_MSG_RESULT([gr-qtgui requires qt, not found. Checking for qt-mt])])
     fi
 
-    PKG_CHECK_MODULES(QWT, qwt >= 5.0.0, [],
-    [passed=no;AC_MSG_RESULT([gr-qtgui requires qwt, not found.])])
+    AC_HAVE_LIBRARY(qwt, [],
+       [passed=no;AC_MSG_RESULT([gr-qtgui requires qwt, not found.])])
 
     
     GRC_BUILD_CONDITIONAL([gr-qtgui], [
 
     
     GRC_BUILD_CONDITIONAL([gr-qtgui], [
index d9662d43761571061c07acdb04291a2fa0eb91b2..c4c32412adda394c733dce39c4cda2836d6e3f69 100644 (file)
@@ -5,13 +5,10 @@ from http://sourceforge.net/projects/qwt
 
 For Linux, this may be obtained from:
 
 
 For Linux, this may be obtained from:
 
-  http://n4hy.org/Qwt/qwt.spec
-  http://n4hy.org/Qwt/qwt.pc
   http://n4hy.org/Qwt/qwt-5.0.0.tar.bz2
   http://n4hy.org/Qwt/qwt-5.0.0.tar.bz2
-  http://n4hy.org/Qwt/qwt-5.0.0-1.src.rpm
 
 On NetBSD or other pkgsrc systems, pkgsrc/x11/qwt exists and seems to
 
 On NetBSD or other pkgsrc systems, pkgsrc/x11/qwt exists and seems to
-be a much older version linked against qt2.
+be a much older version linked against qt2.  You need qt3!
 
 
 QTDIR is an environment variable that must be set for
 
 
 QTDIR is an environment variable that must be set for
@@ -26,11 +23,30 @@ on Fedora Core 6 for example it is automatically set to
 
 /usr/lib/qt-3.3
 
 
 /usr/lib/qt-3.3
 
-by Qt install
+by Qt install from the Fedora Core software setup.
+
+If you are building from source from n4hy.org, the untar the bz2 ball,
+cd into the qwt-5.0.0 directory and run
+
+qmake
+
+Now edit the file  qwtconfig.pri
+
+and make the INSTALLBASE = /usr/local
+
+
+run 
+
+make
+sudo make install
+
+and qwt will be loaded into /usr/local/lib and the includes will be in
+/usr/local/include
+
+gr-qtgui will now make.
+
 
 
-Qwt probably needs to be built and installed for now using
 
 
-rpmbuild --rebuild qwt-5.0.0-1.src.rpm
 
 which must be run as root (as in sudo) so that files are
 installed in the proper place for the gnuradio build
 
 which must be run as root (as in sudo) so that files are
 installed in the proper place for the gnuradio build