Merged r11123:11148 from jcorgan/np into trunk.
[debian/gnuradio] / usrp / host / lib / legacy / Makefile.am
index e2fabc229c84d7faa2e977961c39f02e0f656b6e..e1b1b850abf72192f09e8da40c0c290729cfd60c 100644 (file)
@@ -47,10 +47,10 @@ EXTRA_DIST =                                \
        usrp_dbid.dat                   
 
 BUILT_SOURCES =                        \
-       usrp_dbid.h                     \
-       usrp_dbid.cc                    \
-       usrp_dbid.py                    
+       usrp_dbid.h
 
+BUILT_SOURCES += usrp_dbid.cc \
+                usrp_dbid.py
 
 # ----------------------------------------------------------------
 # FUSB_TECH is set at configure time by way of
@@ -118,7 +118,6 @@ libusrp_la_common_SOURCES =                 \
        db_dtt768.cc                    \
        db_util.cc
 
-#      db_wbx.cc
 
 
 if FUSB_TECH_generic
@@ -177,6 +176,7 @@ noinst_HEADERS =                    \
        rate_to_regval.h                \
        usrp_local_sighandler.h         
 
+if PYTHON
 usrppython_PYTHON =                    \
        usrp_dbid.py                    
 
@@ -186,6 +186,7 @@ noinst_PYTHON =                             \
        dump_data.py
 
 swiginclude_HEADERS = db_base.i
+endif
 
 # common way for generating sources from templates when using
 # BUILT_SOURCES, using parallel build protection.